cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
738
Views
5
Helpful
4
Replies

Remote VPN Cannot Access LAN

jgorman1977
Level 1
Level 1

My VPN terminates fine, but cannot access the LAN. The caveat is the LAN is a fully public /24 subnet.  I am unsure of how to NAT the LAN to access the VPN subnet and not disturb any other funtionality.  I have attached the configuration. 

Thank you in advance.

ciscoasa# sh run
: Saved
:
ASA Version 8.2(2)
!
hostname ciscoasa
enable password Anuj/1RTcTy/SmZO encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address ***.***.149.200 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address ***.165.37.131 255.255.255.248
!
interface Vlan5
no nameif
security-level 50
ip address 10.10.10.1 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
switchport access vlan 5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone GMT 0
access-list MASTERPWRTRANS_splitTunnelAcl standard permit ***.***.149.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip ***.***.149.0 255.255.255.0 172.30.110.0 255.255.255.224
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool POOL1 172.30.110.1-172.30.110.30 mask 255.255.255.224
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
global (outside) 2 ***.165.37.132
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 2 ***.***.149.199 255.255.255.255
nat (inside) 1 0.0.0.0 0.0.0.0
static (outside,inside) ***.***.149.199 ***.165.37.132 netmask 255.255.255.255
route outside 0.0.0.0 0.0.0.0 ***.165.37.134 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa-server MPT protocol radius
aaa-server MPT (inside) host ***.***.149.210
timeout 5
key *****
aaa authentication enable console LOCAL
aaa authentication ssh console LOCAL
http server enable
http 0.0.0.0 0.0.0.0 inside
http 0.0.0.0 0.0.0.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash md5
group 2
lifetime 86400
telnet ***.***.149.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
management-access inside

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy MASTERPWRTRANS internal
group-policy MASTERPWRTRANS attributes
dns-server value ***.***.149.10 ***.***.149.11
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value MASTERPWRTRANS_splitTunnelAcl
default-domain value mci.local
username ptiadmin password BtOLil2gR0VaUjfX encrypted privilege 15
username mptadmin password U2T.1fmOIe772zE/ encrypted
tunnel-group MASTERPWRTRANS type remote-access
tunnel-group MASTERPWRTRANS general-attributes
address-pool POOL1
authentication-server-group MPT
default-group-policy MASTERPWRTRANS
tunnel-group MASTERPWRTRANS ipsec-attributes
pre-shared-key *****
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:820529ed70de923a8375694004b2544c
: end
ciscoasa#

1 Accepted Solution

Accepted Solutions

The 2821 should have a route pointing to the ASA for the pool of VPN addresses (since the ASA is not the default gateway for the LAN).

This should do it.

Federico.

View solution in original post

4 Replies 4

Hi,

So the tunnel establishes, but the remote users cannot access the LAN?


You have these commands:

access-list inside_nat0_outbound extended permit ip ***.***.149.0 255.255.255.0 172.30.110.0 255.255.255.224
nat (inside) 0 access-list inside_nat0_outbound

The ***.***.149.0 network should be the internal LAN that the remote users should access.

Introduce the command:
management-access inside

And try to PING the inside IP of the ASA from a VPN client.

Let us know.

Federico.

Jennifer Halim
Cisco Employee
Cisco Employee

The configuration for ipsec is already correct. You should be able to access internal LAN on that public ip subnet.

If you are testing with ping, you need to enable icmp inspection as follows:

policy-map global_policy
  class inspection_default

     inspect icmp

Apart from that, I assume that ASA is already the default gateway for your internal public subnet. If it's not, you might need to add route for the ip pool towards the ASA inside interface.

I can ping the inside interface of the ASA, but nothing else. The default route for the LAN is a 2821 router, but the ASA internal and 2821 internal are connected.  I added icmp inspect, but that did not seem to do the trick.

The 2821 should have a route pointing to the ASA for the pool of VPN addresses (since the ASA is not the default gateway for the LAN).

This should do it.

Federico.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: