What is "Share Call Active" on an SPA504 phone?

Unanswered Question
Apr 5th, 2010

This is happening too often, triggered by unrelated random non-reproducible behavior:  Two phones that share the same "Shared Line Appearance" extension suddenly have their line LED red, and when that line button is pressed the display says "Share Call Active" and lists another unrelated extension.  The only way to turn this off is by power cycling one of the phones.


Does anyone know what this "Share Call Active" message means?  That message does not appear in any of the SPA9000/400/504g docs.


We are also seeing alot of other SLA problems, like LEDs not show the correct state of an SLA extension.  Or calls from FXS lines to SLA extensions not ringing properly.  I'm beginning to think using SLAs should be avoided.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
nseto Thu, 04/08/2010 - 10:48

Is this a spa9000 with the spa phones setup?

I just tried this on my spa9000 and spa phones.

A call from one spa phone to a shared line, the call rings the shared line (which has two spa phones).

I pick up with one of the spa phones that has the shared line.

While that call is in progress, the other spa phone with the shared line shows it's led light as red blinking for the shared line.  Then when I push the led button for the line, it shows the 'share call active'.  Meaning the shared line is in use.


For the initial config, did you use the spa9000 wizard to set up the phones or did you set these shared lines manually?

William Paulsen Thu, 04/08/2010 - 11:02

Thanks for the reply.  I didn't use the Wizard for a few reasons: It doesn't recognize the SPA400 with the older firmware version (the latest 1.1.2.2 firmware causes constant SPA400 restarts).


But iit seems the problem might be with one of our PSTN lines from our local phone company.  The SPA400 shows 0 or sometimes -2 volts for one of the lines, while the other 3 lines show about -48 volts, when the lines are on-hook.  It seems the SPA400 cannot always detect an on-hook after an off-hook on this particular line.  So maybe the Share Call Active is showing when the SPA400 stays off-hook on a line. We're waiting for the service call.  I'll report back here after the service call.

William Paulsen Wed, 04/14/2010 - 03:49

The intermittent problem on one PSTN line was fixed, but we are still seeing the "Share Call Active" message at least once a day.  How does this happen???

nseto Wed, 04/14/2010 - 08:46

Please enclose the html of the spa phones so I can check your shared line setup.  thanks.

William Paulsen Wed, 04/14/2010 - 11:59

I attached a zip file with the html config files. For the extension 101, on the Voice/Info page, you will see Line 1 Call 1 as idle, and Line 1 Call 2 has "Share Call Active".  Note there's no G711 encoder listed for that.

Attachment: 
nseto Wed, 04/14/2010 - 13:28

Phone with ext 101, 102 and 110 have the shared line function.

But the shared extension numbers should only be in the 'Shared User ID' (under Share Line Appearance)

The 'User ID' (under Subscriber Info) needs to have it's own individual 'User ID'.  Only one of those phones should have 'User ID' 101, not all three phones.

The 'Shared User ID' for all three phones would contain the shared number of 101.

William Paulsen Wed, 04/14/2010 - 19:03

Thanks for the reply.  But I'm not what to use for the Voice/Ext_n/Subscriber Info/User ID.  For the three phones, I want to share the three different extensions.


For example, on the extension 101 phone, should the User ID be set to 101 for Ext 1, Ext 2, and also Ext 3 tabs?  (And on the x102 phone, User ID would the 102 for Ext 1, Ext 2, and Ext 3 tabs.) 

nseto Thu, 04/15/2010 - 08:36

Only the Shared User ID can be the same.  That's the shared line extension number.

The User ID can't be the same.  Each User ID must be unique.  Each phone's Ext and each phone must have a unique User ID.

William Paulsen Fri, 04/16/2010 - 06:29

The "User ID" change was a big disaster.


Things seem to work OK for when there's exactly one call active.  But with more than one call active, we get chaos: for example, calls cannot be answered (ie, pick up the handset and the other party is talking but they don't hear you), or if an outside call if made the other party hears imusic, calls are crossed, or with an incoming call you pick up the handset but the phones keep ringing.  However on a positive note none of the phones has gotten stuck in the "Share Call Active" state.


So I need to fix this real soon now.


This is my wife's business.  I thought this would be easy to set up: There are 4 analog PSTN outside line connected to a SPA400.  There are 3 phones at a front desk, with several people always there.  And there are 6 other private phones.  I thought "Shared Line Appearance" would be good, so that an outside call would ring on 3 front desk phones, and also on all the private phones.  Then anyone could answer an outside call if someone is busy or they see on the caller ID who it is.


This setup almost works, except:  Now there's the chaos that I described above because I changed the "User ID" on the EXT tabs of the SPA504 phones.  The SPA400 locks up about every two days, meaning that incoming calls are not answered, so either a web restart or a power cycle is needed.  A call sometimes goes into severe echo mode - and this happens even when there are no other calls active, and it even happens on inside calls.  The LAN is very lightly used and PCs don't have connection problems.


So it seems to me that shared line appearance doesn't work too well.  My next fix attempt is to remove all SLA, and try to use a hunt group for outside calls.


But, a big problem with the SPA9000/SPA400 is the poor documentation and non-existent examples.  It would be good to see actual configurations for some simple installations.

nseto Fri, 04/16/2010 - 09:34

Do you have the spa9000 admin guide and spa500 admin guide?  It's available at the cisco.com site.

If you can enclose the latest changes to the phones, I can check it.  Just for explanation, the User ID is an individual subscriber to the proxy (in this case, the proxy is the spa9000), there should only be one User ID subscribed to the proxy.   The Shared User ID allows an individual subcriber to share a number with other subscribers to the same proxy.  (Your shared phone number)


It's hard to see how this one change is causing so many problems.  You are describing one way audio, calls being crossed onto other extensions, phone that keeps ringing.


For your hunt group setup, you can also send the config if you'd like us to take a look.  Thanks.

William Paulsen Fri, 04/16/2010 - 09:57

I guess I don't understand you comments.


You had suggested that each line on each phone needs a unique "User ID".  So for 8 phones that each have 4 lines, that's a total of 32 User IDs.


But in this comment, you say:  "the User ID is an individual subscriber to the proxy (in this case, the proxy is the spa9000), there should only be one User ID subscribed to the proxy."


This sounds like an SPA9000 should only have a total of exactly one "User ID".    So it sounds like instead of 32 "User IDs" I should just pick one ID.  That really doesn't seem like what all the docs say...  And yes, I already have the docs you mention, but there are no examples in them.

nseto Fri, 04/16/2010 - 12:37

Guess my comments wasn't clear, I should have put down, there needs to be one unique User ID registered to the proxy. The 1st thing you wrote is correct, the 32 unique User ID.

William Paulsen Thu, 05/06/2010 - 06:39

Thanks, I reconfigured all the phones so that User Ids are unique.  But is there a limit of just one phone that can share an extension?  That is, suppose I have 3 phones with User Ids 101, 102, and 103.  On the first and second phones I set the the Shared id to 101.  Is it OK to set the Shared id on the third phone also to 101? 

nseto Thu, 05/06/2010 - 08:23

Yes, it's ok.  No limit to shared User ID.

William Paulsen Thu, 05/06/2010 - 09:06

Thanks for the prompt reply.  I'd just like to confirm the IDs setup for this with 4 phones.  If a call occurs on x101 then Line 1 will ring on all 4 phones.  For a call on x102, then Line 2 will ring on all 4 phones, etc.


On SPA504g 101/Voice tab:

Ext1: Shared User ID = 101, User ID = 101
Ext2: Shared User ID = 102, User ID = 150

Ext3: Shared User ID = 103, User ID = 151
Ext4: Shared User ID = 104, User ID = 152


On SPA504g 102/Voice tab:

Ext1: Shared User ID = 101, User ID = 160
Ext2: Shared User ID = 102, User ID = 102

Ext3: Shared User ID = 103, User ID = 161
Ext4: Shared User ID = 104, User ID = 162


On SPA504g 103/Voice tab:

Ext1: Shared User ID = 101, User ID = 170
Ext2: Shared User ID = 102, User ID = 171

Ext3: Shared User ID = 103, User ID = 103
Ext4: Shared User ID = 104, User ID = 172


On SPA504g 104/Voice tab:

Ext1: Shared User ID = 101, User ID = 180
Ext2: Shared User ID = 102, User ID = 181

Ext3: Shared User ID = 103, User ID = 182
Ext4: Shared User ID = 104, User ID = 104

rseelaender Wed, 06/01/2011 - 12:47

I noticed that since upgrading to firmware 7.4.8 that all Keys on the SPA5xx phones were set to

private on all keys but Key 1. This caused major issues with SIP Forked lines. To correct this I added


  shared
  shared
  shared
  shared
etc .... for the 509 and 525's


to the .cfg files. Works like a charm now.


I also added, if you only want MWI for the first line:


  No
  Yes
  Yes
  Yes

Actions

This Discussion