Switch configuration for ESX host NIC Teaming

Unanswered Question
Apr 5th, 2010
User Badges:

There are many ESX hosts in our network environment. As default,we configure two NICs on ESX hosts as Teaming for Active/Active mode

. We also set up etherchannel on the switch end. They are working fine.

Like the following configurations:


interface Port-channel6
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,86
switchport mode trunk


interface GigabitEthernet1/0/19
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,86
switchport mode trunk
channel-group 6 mode on


interface GigabitEthernet2/0/19
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,86
switchport mode trunk
channel-group 6 mode on


But the right now they would like yo change NICs teaming as Active/Standby mode on ESX host.Could you please let me konw how to change switch end? Should we still use etherchannel for it? Thanks for your two cents!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Mon, 04/05/2010 - 08:31
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

HWangLoyalty wrote:


There are many ESX hosts in our network environment. As default,we configure two NICs on ESX hosts as Teaming for Active/Active mode



But the right now they would like yo change NICs teaming as Active/Standby mode on ESX host.Could you please let me konw how to change switch end? Should we still use etherchannel for it? Thanks for your two cents!


If the 2 NICs are connected to the same switch then you can't use etherchannel, you will have to configure them as separate L2 trunks. Ideally if you are using active/standby you want the NICs to be going to 2 separate switches which are interconnected via a L2 trunk.


Jon


Cisco are currently donating money to the Haiti earthquake appeal for every rating so please consider rating all helpful posts.

HWangLoyalty_2 Mon, 04/05/2010 - 08:43
User Badges:

Thanks for your quick reponse. Right now the NICs in the Teaming are connected to different stack member switch. But it is logical one switch. So the A/A mode is working to us with etherchannel.


According to your suggestion, I rquire to remove the port-channel and keep the trunk settings if we still keep the current port connection, is it right?


Thanks again!

Jon Marshall Mon, 04/05/2010 - 08:50
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

HWangLoyalty wrote:


Thanks for your quick reponse. Right now the NICs in the Teaming are connected to different stack member switch. But it is logical one switch. So the A/A mode is working to us with etherchannel.


According to your suggestion, I rquire to remove the port-channel and keep the trunk settings if we still keep the current port connection, is it right?


Thanks again!


Yes you need to break up the etherchannel but still configure both server links as L2 trunks.


Jon

Actions

This Discussion