DTMF Isn't Working When a Call is Placed Outbound from UCCX

Unanswered Question
Apr 5th, 2010

I have a script that places an outbound call and when the caller answers the call, I do a get digit string to capture caller input and the DTMF isn't working. The caller is hearing "Are you there?".

Here is the call flow:

Http Trigger into a script

Script places an outbound call using the Place Call command

The call gets answered.

Using the Get Digit String command, the caller hears the prompt that is played with get digit string.

The caller presses keys, but no keys are accepted.

Caller hears "Are you still there" and timesout.

I believe this was working at one time, but the script wasn't used and now we are revisiting this script.

I am using a H.323 gateway. IP phones using the same gateway to reach the PSTN do not have problems with DTMF. Inbound calls to the UCCX script are working when calling into a script with a Menu step.

Your help is appreciated.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Ryan LaFountain Tue, 04/06/2010 - 06:17


If the Place Call target is an IP phone and not a PSTN phone through the gateway does DTMF work? Make sure you are not matching dial peer 0 on the VOIP call leg on the gateway which does not negotiate DTMF relay by default.

marknigh1 Tue, 04/06/2010 - 06:21

You are exactly right. I was hitting DP 0 since during the cut I adding a ^ in front of my voip dial-peer pointing to the CUCM cluster. Once I waited to the call volume went down, after 9pm, I was able to do a debug voip dialpeer and I was able to see that the inbound dial-peer was matching.

Thanks for your reply.


This Discussion