Broadcast prevention on switch

Unanswered Question
Apr 6th, 2010
User Badges:

HI,

                 I am getting some broadcast problems at some sites with L2 and L3 switches.Actually at each site both L2 and L3 switches are connected with non-manageable switches or hubs , so i m getting to much broadcast packets on those interfaces. I have tried to stop this with storm-control feature and then with ACLs. In ACL i have denied 255.255.255.255 and even broadcast IP of those subnets but still the broadcast packets are coming with same pace. I have also tried flow control but no gain in it. Plz help me to sort out this issue.






Thanks

Taran

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ganesh Hariharan Tue, 04/06/2010 - 02:05
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Member's Choice, February 2016

HI,

                 I am getting some broadcast problems at some sites with L2 and L3 switches.Actually at each site both L2 and L3 switches are connected with non-manageable switches or hubs , so i m getting to much broadcast packets on those interfaces. I have tried to stop this with storm-control feature and then with ACLs. In ACL i have denied 255.255.255.255 and even broadcast IP of those subnets but still the broadcast packets are coming with same pace. I have also tried flow control but no gain in it. Plz help me to sort out this issue.






Thanks

Taran

Hi Taran,


Have you tried configuring storm-control broadcast on switch port, check out the below link for more information about the same :-


http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.1E/native/configuration/guide/storm.html


Hope to help !!


Ganesh.H

tarnhundal Tue, 04/06/2010 - 02:41
User Badges:

HI Ganesh,

                         I have tried this method but didnt get result. Even I set storm control for broadcast to 0.0.



thanks

Taran

Leo Laohoo Tue, 04/06/2010 - 17:07
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Get rid of your un-managed switch and hub.  It doesn't matter what commands you've got if these devices are there.  In the end, the broadcast can kill your switches.


Disable spanning-tree portfast and enable spanning-tree bpduguard enable.

tarnhundal Wed, 04/07/2010 - 01:20
User Badges:

portfast is not enabled on that int and there is hub . I dont think BPDU guard will help in this because hub doesnt send bpdu. plz let me know other solutions.



regards,

Taran

Leo Laohoo Wed, 04/07/2010 - 01:29
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Enable port security and set for only 1 MAC address.

tarnhundal Wed, 04/07/2010 - 01:36
User Badges:

Thanks for reply. Actually the problem is I cant bind only one MAC because there may be more IP addresses because I have already given a IP pool to that LAN segment.

Actions

This Discussion