2 Internet Connection with router

Unanswered Question
Apr 6th, 2010

Hi,

     I have 2 Internet Connection with my client and one cisco router with 2 gis ports.My client has one cheap priced Internet connection and one heavy priced Internet connection.My client has some special demand:-

    All Traffic should go cheap priced Internet connection with the help of router initialy and In case of Congestion in Network, heavy priced Internet should be used for time being till traffic load goes down.

  My question :-

1) How it is possible?

2) What need to configure in router for that?

   Kindly help me.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jennifer Halim Tue, 04/06/2010 - 04:54

You can use "IP SLA" feature.

Default gateway points towards the cheap internet connection, and IP SLA to track if the cheap internet is down, when it's down to use the expensive internet connection, and once the cheap internet connection is UP, it will automatically switch back to it.

Giuseppe Larosa Tue, 04/06/2010 - 05:13

Hello Siddindia,

if both links are terminated on the same router you could think to use the high priced link as backup of the cheapest one.

the backup command allows to trigger use of backup link also when a load treshold is reached.

However, this feature has a big drawback that is the interface to be used as backup is not operational but reserved

This can cause problems with the ISP

see

http://www.cisco.com/en/US/docs/ios/dial/configuration/guide/dia_backup_serial_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1000951

I would suggest to configure and to use cheapest link as primary link for example playing on AD value of default static routes but I would not use the backup command.

Other ways to do this could be the use of OER/PFR but it is much more complex

http://www.cisco.com/en/US/docs/ios/oer/configuration/guide/12_4/oer_12_4_book.html

Hope to help

Giuseppe

siddindia Tue, 04/06/2010 - 07:15

Hi

Giuseppe,

               Thanks to you for excellent response.

                Actaully senarios is:-

                 We have one cisco router with 2 gigabitethernet ports and Links are comming through VSATs.I need to configure router for those VSAT links.All traffic should go first VSAT link initially.But the second link should be used in case of congestion in first VSAT link( traffic crosses treshold value) and also comes back all traffic in first VSAT link in case of traffic load goes down.Is it possible to fix treshold limit of traffic?

                 How it is possible to configure?

Regards,

Siddhartha

Giuseppe Larosa Tue, 04/06/2010 - 09:58

Hello Siddharta,

in the IOS Dial configuration guide there is an example:

interface serial 0

 backup interface serial 1

 backup load 75 5


This should be adapted to your case. First of all I hope you have fixed the speed at 10 Mbps full or half in your GE interfaces connected to VSAT modems.

To use the high price VSAT as secondary link you should define that GE as the backup of primary interface

interface g0/0

speed 10

duplex full

ip address 10.11.11.2 255.255.255.0

! to improve interface timers

load-interval 30

backup interface gi0/1

backup load 75 5

interface g0/1

speed 10

duplex full

ip address 10.22.22.2 255.255.255.0

! to improve interface timers

load-interval 30

you can have two equal AD default static routes

ip route 0.0.0.0 0.0.0.0 10.11.11.1

ip route 0.0.0.0 0.0.0.0 10.22.22.1

interface gi0/1 will not be really operational until load on primary interface does not reach 75%

Warning:

this point is critical and needs to be tested, we cannot know how the VSAT modem will react being connected to an interface that is not operational all the time.

So this solution advantage is that it is easy to configure but it should be tested with attention to convergence times and to behaviour of VSAT modem over long time intervals of inactivity.

So be aware of all these possible drawbacks. The presence of VSAT modems should be of help: link to provider could be operational even if the GE interface is not operational.

This however open a serious question about return traffic: if return traffic comes back on higher price link it might be simply dropped at modem interface if no routing protocol is in use.

A possible correction to this would be the use of eBGP sessions on both links combined with the backup feature described above.

the OER/PFR solution can avoid to keep not operational the second interface but it is much more complex to configure.

Other solutions are possible specially using management features like EEM that could create an object that monitors the link usage of first link.

You can see an example of this in Krasnoperov's post

Hope to help

Giuseppe

Krasnoperov Tue, 04/06/2010 - 05:20

Hi, on cisco.com example exist

https://www.cisco.com/en/US/tech/tk648/tk361/technologies_configuration_example09186a0080950834.shtml

So, if don't mind, I'll ask my question, in your discussion

I have two ISP connection to my router, r1 it's a router which do NAT for both ISP's, here the schema

ASA5520 (2 for failover, it's acting like central point of VPN tunneling) int f0(172.16.1.3)-----connected---->r1(it's making NAT for my ASA5520, and connected to 2 ISP's, if one ISP goes down, it's switch to second, and when first ISP come up again, it's back to him), here is my config fo r1 router, and my question is: Why when I do clear ip nat translation *, several times...it's always diferent my router reboot with BUS ERROR, I'm Already change IOS, change routers, same thing on 28xx 17xx 37xx, why it's happends?

Current configuration : 4385 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
ip cef
no ip domain lookup
ip domain name r1
rlogin trusted-remoteuser-source local
rlogin trusted-localuser-source local
!
multilink bundle-name authenticated
vpdn enable
!
ip rcmd rsh-enable
!
track 123 rtr 1 reachability
delay down 30
!
track 124 rtr 2 reachability
delay down 13 up 120
!
!
bba-group pppoe global
!
!
interface Ethernet0/0
description ---- Link To ISP 1 ----
ip address 200.0.0.2 255.255.255.248
ip nat outside
ip virtual-reassembly
full-duplex
!
interface FastEthernet0/0
ip address 172.16.1.3 255.255.255.0
ip nat inside
ip virtual-reassembly
ip policy route-map traking
speed auto
!
interface ATM1/0
description ISP2
no ip address
ip virtual-reassembly
no ip mroute-cache
no atm ilmi-keepalive
dsl operating-mode auto
pvc 0/35
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
!
!
interface Dialer1
description ---Link to ISP 2---
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname XXXXX
ppp chap password XXXXX
ppp pap sent-username XXXXX password XXXXX
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1 10 track 123
ip route 0.0.0.0 0.0.0.0 200.0.0.1  5 track 124
ip route 200.1.1.1 255.255.255.255 Dialer1
ip route 200.1.1.1 255.255.255.255 200.0.0.1
no ip http server
no ip http secure-server
!
ip nat translation udp-timeout 1
ip nat inside source route-map ISP1 interface Ethernet0/0 overload
ip nat inside source route-map ISP2 interface Dialer1 overload
ip nat inside source static 172.16.1.1 200.0.0.2 route-map ISP1 extendable no-alias
ip nat inside source static 172.16.1.1 200.2.2.2 route-map ISP2 extendable no-alias
!
!
ip sla 1
icmp-echo 200.1.1.1 source-interface Dialer1
timeout 2000
frequency 3
ip sla schedule 1 life forever start-time now
ip sla 2
icmp-echo 200.1.1.1 source-interface Ethernet0/0
timeout 2000
frequency 3
ip sla schedule 2 life forever start-time now

!
!
!
route-map ISP1 permit 10
match interface Ethernet0/0
!
route-map ISP2 permit 10
match interface Dialer1
!
route-map traking permit 10
set ip next-hop verify-availability 200.0.0.1 5 track 124
set ip next-hop verify-availability 200.2.2.1 10 track 123
!
!
event manager applet 123
event track 123 state down
action 1.0 cli command "enable"
action 1.1 cli command "clear ip nat tra *"
action 1.2 syslog msg "Channel of ISP2 is DOWN"
event manager applet 124
event track 124 state up
action 1.0 cli command "enable"
action 1.1 cli command "clear ip nat tra *"
action 1.2 syslog msg "Channel of ISP1 is UP"
event manager applet 123_1
event track 123 state up
action 1.0 cli command "enable"
action 1.1 cli command "clear ip nat tra *"
action 1.2 syslog msg "Channel of ISP2 is UP"
event manager applet 124_1
event track 124 state down
action 1.0 cli command "enable"
action 1.1 cli command "clear ip nat tra *"
action 1.2 syslog msg "Channel of ISP1 is DOWN"
!
en

Actions

This Discussion