How to copy IOS software back

Unanswered Question
Apr 7th, 2010

Hello

I have been given a 3750 switch to put back to working order. The issue with it is that a user deleted all the content of nvram. So now when the switch is started, it cannot load the IOS from flash. The only option i have are below. Is there a way to copy the IOS back on it? I cannot use tftp as cannot make Ip connection to the switch.

Thanks

Raoul

switch: ?
? -- Present list of available commands
boot -- Load and boot an executable image
cat -- Concatenate (type) file(s)
copy -- Copy a file
delete -- Delete file(s)
dir -- List files in directories
flash_init -- Initialize flash filesystem(s)
format -- Format a filesystem
fsck -- Check filesystem consistency
help -- Present list of available commands
load_helper -- Load and initialize a helper image
memory -- Present memory heap utilization information
mkdir -- Create dir(s)
more -- Concatenate (display) file(s)
rename -- Rename a file
reset -- Reset the system
rmdir -- Delete empty dir(s)
set -- Set or display environment variables
set_bs -- Set attributes on a boot sector filesystem
set_param -- Set system parameters in flash
sleep -- Pause (sleep) for a specified number of seconds
trap -- Cause a software breakpoint to occur
type -- Concatenate (type) file(s)
unset -- Unset one or more environment variables
version -- Display boot loader version

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
m.hahn Wed, 04/07/2010 - 03:00

Hi,

if you delete the NVRAM content, the image itself should still be on the flash:

Have you tried what you see in the ROMmon with "dir flash:"?

I assume the image is still present, then try to start it manually with " boot flash:/dir/image-name.bin".

regrads,

michael

raoul2341 Wed, 04/07/2010 - 03:17

Hi

Yes I have and it is completely empty. The user must have done something elase then to empty the flash.

I am in the process of copying the image back using x-modem as suggested by Jon.

Thanks

Jon Marshall Wed, 04/07/2010 - 03:22

Raoul

Forgot to mention. Xmodem is very slow so you should set the BAUD rate to 115200 to speed it up.

Jon


Cisco are currently donating money to the Haiti earthquake appeal for every rating so please consider rating all helpful posts.

raoul2341 Wed, 04/07/2010 - 04:55

Thanks Jon.

The send file has now completed but cannot find where the image is copied to. This is what I get when I do dir:

switch: dir

List of filesystems currently registered:

               flash[0]: (read-write)
              xmodem[1]: (read-only)
                null[2]: (read-write)
                  bs[3]: (read-only)

-flash is still empty

-cannot run dir xmodem:

Thanks

Raoul

raoul2341 Wed, 04/07/2010 - 06:15

Hi Jon

Yes I did check the content of flash, it is empty. The copying seems to have worked but at the end when I do dir flash: I get

switch: dir flash:
Directory of flash:/


15997952 bytes available (1024 bytes used)

switch:

Thanks

Raoul

raoul2341 Wed, 04/07/2010 - 06:20

Hi Michael

I couldn't access the link but I guess it shows how to configure the Hyper Terminal but could find that on other links.  This is what I get when I click on the link and after entering my login credentials:

Forbidden File or Application

The file or application you are trying to access may require additional entitlement or you are trying to access a file with an invalid name. Additional entitlement levels are granted based on a users relationship with Cisco on a per-application basis.

If you feel you have reached this page in error, please try one of the following methods to locate your document:

  1. If you are manually entering the URL into your browser location bar, be sure to include the file name of the page you are trying to access (file names typically end in .htm, .html or .shtml).
  2. Use the Search feature located in the upper right section of this page.
  3. Return to the Cisco.com Home or select a primary site area from the top navigation bar.
  4. Consult with your Cisco Account Manager to confirm you have the appropriate entitlement to access this page.

If you would like to contact someone about this problem, please click on the Contacts & Feedback link below.

Thanks

Raoul

m.hahn Wed, 04/07/2010 - 06:28

Hi,

when you started the download, did you mention the destination filename? Like in this example?

  1. Issue the copy xmodem: flash:filename command on the switch.

    Here is an example:

    switch: copy xmodem: flash:c2955-i6q4l2-mz.121-13.EA1.bin
    Begin the Xmodem or Xmodem-1K transfer now...
    CCC
  2. From the top of the HyperTerminal window, choose Transfer > Send File. ...

After the download the file should be visable in the flash:? Can you try to download it again?

thanks

michael

raoul2341 Wed, 04/07/2010 - 07:38

Hi Michael

No I didn't. I followed your instructions and it stated downloading but looks like it is going to take over 2 hours to finish. Also I cannot change the baud rate from 9600 after entering the command and before starting the download. WIll have another go at it tomorrow.

Many thanks for your help Michael, Jon.

Cheers

Raoul

raoul2341 Thu, 04/08/2010 - 05:50

Many thanks Michael, this has worked beautifully.

Cheers

Raoul

Actions

This Discussion