Ciscoworks Lms 3.2 giving ANi Server issue

Unanswered Question
Apr 7th, 2010

We have lms 3.2 configured at our organisation.But i am not able to initialise ANI server.The process is always down and not coming up.

EDS and anidatabase processes are up.But ani server is not coming up due to which i am not able to access the CAmpus manager.Please reply asap.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
mohiuddin.idris Sat, 04/10/2010 - 03:17

Before this below was the output then i followed one doc im attaching  it now and changed as per the instructions.Il paste the current files also.


EnablePurgeArchives=ON
PurgeArchivesOlderThan=180
EnablePurgeJobs=ON
PurgeJobsOlderThan=180
EnableCMPurgeArchives=ON


I have attached the doc which i followed to change the aniserver file but still did not initialise the aniserver.

Aniserver issue .pdf is the file i followed to change the corrupted aniserver file.

aniserver.properties is the file attached with current settings after changing.

mohiuddin.idris Mon, 04/12/2010 - 06:06

I have followed the steps and restored the configs but still ani server is down.Please advise

Joe Clarke Mon, 04/12/2010 - 10:04

Post the new pdshow output, ani.log, and ANIServer.log.  Repost the ANIServer.properties that you now have in NMSROOT/campus/etc/cwsi.

mohiuddin.idris Tue, 04/13/2010 - 23:56

Thankyou the Ani Server is up but it is running with busy flagset.The other thing is the Discrepencies reports and violations report is not  showing anything.

The respone time of the server is ver y slow

Joe Clarke Wed, 04/14/2010 - 09:04

Running with busy flag set is the normal state for ANIServer.  See my Daemon Cheat Sheet at https://supportforums.cisco.com/docs/DOC-8798 for more on what the healthy daemon states should be.


The Discrepancies and BPD will only be populated after a Campus Data Collection is run.  It can take up to 30 minutes after a restart of Daemon Manager before the daemons calm down, and the system becomes responsive.

mohiuddin.idris Fri, 04/16/2010 - 22:01

Thankyou very much ,The Campus Manager lists are populated again.One more thing i wanted to Know regarding MS Tcp loopback Interface.My Management software is showing high utilization on this MS tcp loopback interface of 10 mb on Cisco works Server.

Arun More Sun, 09/09/2012 - 23:37

hi Joseph,

recently I have faced the same issue and after changing the properties file ANI server started but now i am getting the error "There may be possible ACS config mismatch " where as i have not changed the ACS settings. Could u pls help me out .

Joe Clarke Mon, 09/17/2012 - 05:18

Hey, Arun.  Please start a new for your issue.  With ACS integration, you need to make sure all of the ACS side settings are good.  While you may not have changed anything within LMS, the ACS side may have changed.  For example, an ACS admin may have deleted some of the LMS components in ACS, or ACS may have been upgraded to an unsupported version (e.g., 5.x).

Actions

This Discussion