Switches Supporting IOS

Unanswered Question

Maybe the question should be.  When is old too old?

  I can't find on the Cisco site a break down of which models support IOS.  I am not looking for current models, as far as I know they all support IOS now, but older models to avoid/upgrade because they are not IOS compatible.  In turn not being compatible with IPv6.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Wed, 04/07/2010 - 08:57

Hello Ryan,

if you want to use the switches as L2 LAN switches you will not have any problem with IPv6: IPv6 packets travel inside an ethernet frame as IPv4 packets do.

If you refer to multilayer switching of IPv6 traffic this is a different matter: given the fact that IPv6 addresses are 16 bytes wide this leads to possible problems on the TCAM tables that are used for implementing multilayer switching.

So you need to check if there is hardware support for IPv6 and you should stay away from devices that support IPv6 only in software with clear performance penalties.

Devices like C3750 need a reconfiguration of SDM template that is the schema used by TCAM tables and it can be a starting point

see

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_52_se/configuration/guide/swsdm.html#wp1197622

So there is an hardware limitation also on older devices as you have noted

Hope to help

Giuseppe

Agreed.  I am focused on the multilayer switches and trying to identify which of them are too old to be used in a IPv6 environment as a multilayer switch.

My logic was to approach the problem with the question "what can't be upgraded to IOS software" and I think it requires more than the standard IOS software as well.  From what I can find I also need  the "advanced IP services" versions.

So my updated question is....

What cisco multilayer switches can NOT be upgraded to the Cisco IOS  with "advanced IP services" versions?

Leo Laohoo Wed, 04/07/2010 - 16:59

I hope I understood your question.

The 6500 Sup1 and Sup2, the 3550EMI are two examples that run IOS but since they have reached End-of-Life the development of functional IOS is very, very limited.

My rule of thumb to the infernal question "When is this appliance considered too old?" is when I see the End-of-Life notice.

Giuseppe Larosa Thu, 04/08/2010 - 23:42

Hello Ryan,

regarding IPv6 as I noted in my first post it is not only a question of IOS image and feature set but it depends from hardware TCAM table size.

that is if the TCAM cannot accomodate the 128 bits of the destination IPv6 address and some other flags, hardware based L3 switching of IPV6 packets is not possible regardless of the IOS image feature set.

I remember a typical number of 134 bits for the TCAM size in some devices.

Generally speaking your reasoning is agreeable but for IPv6 there is the hardware question described above.

Hope to help

Giuseppe

Reza Sharifi Wed, 04/07/2010 - 08:57

Hi Ryan,

If you are looking for your devices to support new features, I don't think there is choice not to upgrade to use Native IOS, as Cisco is retiring Cat OS.

Reza

Actions

This Discussion