UCC Database Server Service Fails to Start

Unanswered Question
Apr 7th, 2010
User Badges:

Hello,


I am attempting to configure a new UCC Call Connect Server v1.6 installation. I have installed the software successfully and rebooted however now I cannot get the UCC Database Server Service to start successfully. The service repeatedly attempts to start but immediately fails and then retrys.


Server is running Windows Server 2008 Standard, and has had an earlier version of UCC Server installed but was uninstalled prior to installing the new version.


In the event log i have the following error repeatedly:


Faulting application CCTSDBSVR.exe, version 2.0.0.27, time stamp 0x4b9ab66a, faulting module CCTSDBSVR.exe, version 2.0.0.27, time stamp 0x4b9ab66a, exception code 0xc0000096, fault offset 0x000425f5, process id 0x10b0, application start time 0x01cad683164c0d26.

In "C:\Program Files\Cisco Sytems\Cisco Unified CallConnector Server\logs\ccSDKDatabase.log" I see this:



[DatabaseSDK   ]ConfigurationManager[TRACE]<3156>@[email protected]:15:06.020** [+]ccSDKDatabase::OnAuthenticationResult() - ccSDKDatabase::OnAuthenticationResult() - Authentication Code=2 Authentication result=Internal Server Error
[DatabaseSDK   ]ConfigurationManager[TRACE]<3156>@[email protected]:15:06.020** [-]ccSDKDatabase::OnAuthenticationResult()[0.00125714ms]
[DatabaseSDK   ]ConfigurationManager[TRACE]<3156>@[email protected]:15:09.858** [+]ccSDKDatabase::OnAuthenticationResult() - ccSDKDatabase::OnAuthenticationResult() - Authentication Code=12 Authentication result=Authentication request successfully sent
[DatabaseSDK   ]ConfigurationManager[TRACE]<3156>@[email protected]:15:09.858**   [+]ccSDKDatabase::OnAuthenticationResult - Unknown Error Code received from SIP SDK
[DatabaseSDK   ]ConfigurationManager[TRACE]<3156>@[email protected]:15:09.858**   [-]ccSDKDatabase::OnAuthenticationResult[0.000977778ms]
[DatabaseSDK   ]ConfigurationManager[TRACE]<3156>@[email protected]:15:09.858** [-]ccSDKDatabase::OnAuthenticationResult()[0.117194ms]
[DatabaseSDK   ]ConfigurationManager[TRACE]<1732>@[email protected]:15:12.245** [+]ccSDKDatabase::OnAuthenticationResult() - ccSDKDatabase::OnAuthenticationResult() - Authentication Code=3 Authentication result=Invalid Account
[DatabaseSDK   ]ConfigurationManager[TRACE]<1732>@[email protected]:15:12.245** [-]ccSDKDatabase::OnAuthenticationResult()[0.00181587ms]
[DatabaseSDK   ]ConfigurationManager[TRACE]<3156>@[email protected]:15:12.978** [+]ccSDKDatabase::OnAuthenticationResult() - ccSDKDatabase::OnAuthenticationResult() - Authentication Code=3 Authentication result=Authentication failed
[DatabaseSDK   ]ConfigurationManager[TRACE]<3156>@[email protected]:15:12.978** [-]ccSDKDatabase::OnAuthenticationResult()[0.00209524ms]
[DatabaseSDK   ]ConfigurationManager[TRACE]<3156>@[email protected]:15:16.816** [+]ccSDKDatabase::OnAuthenticationResult() - ccSDKDatabase::OnAuthenticationResult() - Authentication Code=12 Authentication result=Authentication request successfully sent
[DatabaseSDK   ]ConfigurationManager[TRACE]<3156>@[email protected]:15:16.816**   [+]ccSDKDatabase::OnAuthenticationResult - Unknown Error Code received from SIP SDK
[DatabaseSDK   ]ConfigurationManager[TRACE]<3156>@[email protected]:15:16.816**   [-]ccSDKDatabase::OnAuthenticationResult[0.000838095ms]
[DatabaseSDK   ]ConfigurationManager[TRACE]<3156>@[email protected]:15:16.816** [-]ccSDKDatabase::OnAuthenticationResult()[0.203168ms]


I have attached additional CallConnector Server logs.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ian.apruzzese Wed, 04/14/2010 - 20:56
User Badges:

We are having the same error right down to the log entries you have. Have you found an answer?

shtalukd Thu, 04/15/2010 - 10:47
User Badges:
  • Bronze, 100 points or more

We have not seen this problem. Would you please send us the log file ccdatabaseserver.log in Trace Log folder? Have you activated UCC Server yet? Would you please download Dependency Walker from google to check dependency for DatabaseServer or can we setup a webEx session to troubleshoot?

Thanks,

sferrero2 Fri, 04/16/2010 - 11:27
User Badges:

Hello,


Yes I have activated the UCC server.

I ran Dependency Walker against CCTSDBSVR.exe and got the following errors:


GDIPLUS.DLL      Error opening file. The system cannot find the file specified (2).

LINKINFO.DLL     Error opening file. The system cannot find the file specified (2).


I have attached the ccdatabaseserver.log file.


I can set-up a WebEx session if you like.

shtalukd Fri, 04/16/2010 - 11:43
User Badges:
  • Bronze, 100 points or more

Hi Stephen,


We didn't see the DatabaseServer log. Would you please send us the log files? What is your email address so that I can forward you a webEx session? How is 12pm(Pacific time)?


Thanks,

shtalukd Fri, 04/16/2010 - 15:10
User Badges:
  • Bronze, 100 points or more

Hi Stephen,


Thank you for sending us the log files. Can we have you email address and what is a good time to connect webEx with you? Please let us know, then I'll forward you a webEx invitation.


Thanks,

sferrero2 Fri, 04/16/2010 - 15:11
User Badges:

I have private messaged you my email address. I no longer have today for a WebEx session can we schedule for Monday afternoon?


Thank You,

-Stephen

shtalukd Fri, 04/16/2010 - 15:14
User Badges:
  • Bronze, 100 points or more

Thanks, Stephen. What time are you available?

David Trad Tue, 06/15/2010 - 15:39
User Badges:
  • Gold, 750 points or more
  • Cisco Designated VIP,

    2013 Small Business

Hi All,


You are all hitting a known bug " /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;} CSCtg71746" which is specific to server 2008, you will also find that the Data Base for UCC 1.6 can become corrupted at times so straight after install and configuration you should do a DB backup immediately.


To resolve this problem do the following:



  • Download file: Fix for Server2008  CCTSDBSVR.exe as attached
  • Place the file either on the desktop or on the root of the drive
  • Make sure all instances of UCC are shut down, and stop all the UCC services
  • Double click it (You might see a DOS prompt show) wait for it to complete
  • You are done and read to use UCC 1.6 for server 2008




If you are running in a VM environment you should not need this patch, you might be hitting another issue if you are getting like or same problems.


If you are having issues with UCC 1.6 feel free to ask more questions, I have been battling this beast now for months and have hit most known problems and even found new ones (WHY ME???? WHY????)


1.6 is by and large the best installment of UCC but it is not without its issues still, maybe one day we will be lucky and Cisco will release a Linux server version for us to go to market with



Cheers,



David.

Brook Powers Wed, 06/16/2010 - 06:50
User Badges:

I had to get support from Cisco for this step.


We are installing on a Hyper-V based SBS 2008 server.


It turns out there is a known issue with Server 2008 that requires an updated version of CCTSDBSVR.exe. You have to get the updated exe from a username/password protected Cisco web site.


However, I tried to run it as David suggested and it turns out CCTSDBSVR.exe does not install like one would think. Support renamed the existing CCTSDBSVR.exe.old and copied the new CCTSDBSVR.exe to the same folder and the services restarted and stayed running this time.


Then, I had more issues with line vty 0 4 is missing in the UCC Manager setup wizard.


When queried, Cisco Support then provided a document of required steps for the UCC-540 (below);


Configuring the UCC Configuration Manager

To setup the required parameters for UCC Configuration Manager, perform the following steps:

SUMMARY STEPS:

1.       configure terminal

2.       ip http server

3.       ip http authentication local

4.       ip http timeout-policy idle 180 life 180 requests 86400

5.       aaa new-model

6.       username username privilege 15 password 0 password

7.       line vty 0 9

8.       transport input all

9.       transport preferred none

10.   end

DETAILED STEPS:


Command

Purpose

Step 1

configure terminal 
 

Example:

Router# configure terminal

 

Enters global configuration mode.

Step 2

ip http server

Example:

Router(config)# ip http server

Enables the Cisco web browser user interface on the local Cisco Unified CME router.

Step 3

ip http authentication local

Example:

Router(config)# ip http authentication local

Sets http server authentication method to local user authentication.

Step 4

ip http timeout-policy idle 180 life 180 requests 86400

Example:

Router(config)# ip http timeout-policy idle 180 life 180 requests 86400

Sets http server time-out policy parameters.

Step 5

aaa new-model

Example:

Router(config)# aaa new-model

Enables the AAA access control system.

Step 6

username username privilege 15 password 0 password

Example:

Router(config)# username cisco privilege 15 password 0 cisco

Creates a local user account with enough privilege to be used to access CME http service.

Step 7

line vty 0 9

Example:

Router(config)# line vty 0 9

Required for Telnet session.

Step 8

transport input all

Example:

Router(config-line)# transport input all

Selects all protocols.

Step 9

transport preferred none

Example:

Router(config-line)# transport preferred none

Prevents any protocol selection on the line.

Step 10

end

Example:

Router(config)# end

Returns to privileged EXEC mode.

Now, after following the directions exactly, I am stuck with the following error, while trying to import router settings I get;


The entered executive password is not correct. Please change executive password and try again.


I tried the username/password I set for the CCA and the cisco/cisco username/password for the web page and as was set (above) and got the same error. Any suggestions?

shtalukd Tue, 06/22/2010 - 19:45
User Badges:
  • Bronze, 100 points or more

Hi Brook:

When you telnet to the router, do you need to enter the enable password?

If not then, could you please try adding after step 7, the following:


line vty 0 9


Example:

Router(config)# line vty 0 9

Router(config-line)# privilege level 15

If you still have issues, then please send us the router config and the log file cmeconfigurator.log (to [email protected])

Thanks

CallConnector Team