AXL Query Device IP

Answered Question
Apr 7th, 2010
User Badges:

Hi, can't seem be find any AXL query that can return device IP address, possible via AXL ?

Correct Answer by William Bell about 7 years 1 month ago

Actually, the AXL interface is only used for viewing and/or modifying configurations. The API you are looking for is the Serviceability XML API. Specifically, RISPort. It is pretty handy and a solid replacement for devicelistx.asp (if you are familiar with that "API"). I have worked with RISport a little and put together some blogs on the subject. If you are interested, check them out:


http://www.netcraftsmen.net/resources/blogs/good-bye-devicelistx-asp-hel...


http://www.netcraftsmen.net/resources/blogs/identifying-the-correct-devi...


Another good place to look for information on the API: http://developer.cisco.com/web/sxml/home


What you need to look at is the Real-Time Device/CTI feed (RISport).


HTH.


Regards,

Bill

Please remember to rate helpful posts.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
William Bell Wed, 04/07/2010 - 21:29
User Badges:
  • Purple, 4500 points or more

Actually, the AXL interface is only used for viewing and/or modifying configurations. The API you are looking for is the Serviceability XML API. Specifically, RISPort. It is pretty handy and a solid replacement for devicelistx.asp (if you are familiar with that "API"). I have worked with RISport a little and put together some blogs on the subject. If you are interested, check them out:


http://www.netcraftsmen.net/resources/blogs/good-bye-devicelistx-asp-hel...


http://www.netcraftsmen.net/resources/blogs/identifying-the-correct-devi...


Another good place to look for information on the API: http://developer.cisco.com/web/sxml/home


What you need to look at is the Real-Time Device/CTI feed (RISport).


HTH.


Regards,

Bill

Please remember to rate helpful posts.

Gerald Chong Wed, 04/07/2010 - 23:59
User Badges:

Thanks for the reply.


Just tested with RISPort request, and CM7 keep returning HTTP Status 500 internal error.


Have you come across this error before?

Gerald Chong Thu, 04/08/2010 - 19:30
User Badges:

All sorted, WSDL had changed, corrected the XML all working correctly.

William Bell Fri, 04/09/2010 - 05:56
User Badges:
  • Purple, 4500 points or more

Good to hear. Sorry I missed your earlier query about the http status error but it appears you got it all worked out.


Regards,

Bill

Actions

This Discussion

Related Content