Message Filter dnslist("") not working

Unanswered Question
Apr 8th, 2010


I have written a message filter as

RBL: if (recv-listener == "outgoing") AND (dnslist ("")) {

But this does not work. we have C360 (6 no) and OS 7.0.1

any other ways ?

This is basically to stop the spamming done by ur  own customers as we relay mails from them.

we have creadted internal rbl which gets IP information from Ironport outgoing senders.

we want our Ironport to query this rbls and if IP is listed in rbl then it should drop the connection.

Thanks in advance.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jamesnoad Fri, 04/16/2010 - 06:57

Hi Homesh,

There are bugs with the dnslist() behaviour.

Bug #55908: dnslist and dnslisttest only work against
FR #56363: Including the returned data in the dnslisttest result
FR #56364: Adding an option to specify query type in the dnslist filter method

Try using the dnslisttest command in the first instance



This Discussion