loading a script to CUE through the CLI

Unanswered Question
Apr 8th, 2010

My phone system is running on a 2811 router with CUE:


Operating System: Cisco Internetwork  Operating System. Cisco IOS (tm) C2800NM
Cisco IOS  Software: C2800NM-IPVOICEK9-M
Software  Version: 12.4(24)T / CME 7.1
Feature  Package: IP|VOICE|SSH|3DE
Licensing  Information
Default #  personal mailboxes: 25
Default #  general delivery mailboxes: 10
Maximum #  configurable mailboxes: 35
Maximum message  space (minutes): 6000
Maximum  telephony ports: 8
Installed  Packages: Installer (Installer application) 2.2.1
  Thirdparty (Service Engine Thirdparty Code) 2.3.2
  Bootloader (Primary) (Service Engine Bootloader)  2.1.2
  Infrastructure (Service Engine Infrastructure)  2.3.4
  Global (Global manifest) 2.3.4
  GPL Infrastructure (Service Engine GPL  Infrastructure) 2.3.0
  Voice Mail (Voicemail application) 2.3.2
  Bootloader (Secondary) (Service Engine Bootloader)  2.1.2
  Core (Service Engine OS Core) 2.3.4
  Auto Attendant (Service Engine Telephony  Infrastructure) 2.3.0
Installed  Languages: English language pack (English language pack) 2.3.0


The CUE GUI will not allow me to upload a new script for the auto-attendant.  I have been trying to do this through the CLI by using "ccn copy url" and various methods of attempting to copy the file: ftp and http, both of which fail to connect.  I also have the script available on the USB drive that is plugged into the router, but have no idea how to tell it to copy from there.


Upgrading the software is not a good option for me, unless someone could walk me through each step- I am an IT Admin for a nonprofit, and managing the phone system is a small (albeit important) part of my job, so I am definitely not adept at working with this type of system.


Help appreciated!  Amanda

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Thu, 04/08/2010 - 06:26

You either have a configuration problem or not are not using the right commands.


Recommend you either take the time to learn in deep from documentation, or hire a professional fort he job. He/sh can also update you system in few minutes.

cptigers1 Thu, 04/08/2010 - 06:30

How about a simpler question then: is it possible to log into a

service module session and upload the script from the USB drive that is plugged into the 2811?

If so, how would one go about it?


thanks, Amanda

Paolo Bevilacqua Thu, 04/08/2010 - 06:33

It is possible, provided you enable the file first with tftp-server command on the router.


Generally, CUE scripts are uploaded directly from the PC on which they have been created, as there is easy GUI option to do that.

Even more as scripts sometime need to be changed often.

cptigers1 Tue, 04/13/2010 - 08:46

Thanks for responding,


I am using commands referenced in the Cisco Unity Express 2.3 CLI Administrator Guide.


  1. I telnet into the 2811 router
  2. service-module service-engine 1/0 session
  3. ccn copy url (and here I try various commands to try to upload the file from various sources)
    1. ccn copy url ftp:// IP address and pathname of web server where I have uploaded the script script script name.aef username username password password
      1. Response: (7) Connect failed; Success
    2. ccn copy url http:// IP address and pathname of web server  where I have uploaded the script script script name.aef
      1. Response: (7) Connect failed; Success
    3. ccn copy url tftp://IP address of local tftp server and pathname of script script script name.aef
      1. Response: % Invalid input detected ... (not surprising since this wasn't an option, but I am desperate)


I'm assuming that the command was correct, and that it just doesn't want to connect to an external web server or ftp server, but not sure how to resolve that issue.


The simplest solution would probably be to upgrade the Cisco Unity Express GUI, clearly the version we have was older, and the uploading tool in the GUI has probably been fixed; however, I am hesitant to risk messing up our whole phone system as I don't have a clear understanding of how to go about upgrading the GUI.


Gratefully, Amanda

cptigers1 Tue, 04/13/2010 - 08:52

P.S. I haven't found a good resource to explain the CLI to upload the script from the flash, only how to

upload the running-config to the CME.  I am unclear on the difference between file manipulation in the CME and file manipulation in the service module

Jaime Valencia Tue, 04/13/2010 - 09:11

I guess you're following this, right?

Uploading the Auto-Attendant Script File

http://www.cisco.com/en/US/docs/voice_ip_comm/unity_exp/rel2_3/cliadmin/ch3sys.html#wp1075120


Where is your FTP??

What program or app are you using??

Is the script located in the right location regarding your FTP root?

Have you confirmed connectivity is OK and there is nothing blocking this?

Does the script and CUE versions match?


HTH

java

If this helps, please rate

www.cisco.com/go/pdihelpdesk

cptigers1 Tue, 04/13/2010 - 10:23
  1. The instructions in my CUE CLI 2.3 Adminsitrator's Guide pdf for "Uploading the Auto..." are the same as the ones in this link.
  2. I uploaded the script file to my web server (GoDaddy hosting) via Dreamweaver FTP.  I use the same login username and password that I used to set up FTP in Dreamweaver.
  3. The script is in a subfolder of the root directory, but I included this in the pathname of the file
  4. I'm not sure how I would test connectivity specifically from the router, but certainly computers behind the router have no problem connecting to the FTP server.
  5. I haven't the slightest if the script and CUE versions match; however, I wouldn't expect this to interfere with the transfer of the file, just the functioning of it once it is in place.  I edited the script with the CUE Editor software that the Cisco guys left on our network when they originally put in the phone system, so presumably it should be compatible, although I have done one firmware upgrade since then.


- Amanda

TURBOxSPOOL Fri, 12/10/2010 - 06:53

I know this is an old post, but I am having the same problem.


I have an http server running on my local lan, and I want to copy in my script from there.



se-100-1-21-10> ccn copy url "http://172.16.2.253/storage/aa_sample1.aef" script "aa_sample1.aef"


(7) Connect failed; Success


Any ideas? Apparently I can't even ping the server:




se-100-1-21-10> ping 172.16.2.2

PING 172.16.2.2 (172.16.2.2) 56(84) bytes of data.

64 bytes from 172.16.2.2: icmp_seq=1 ttl=255 time=0.385 ms

64 bytes from 172.16.2.2: icmp_seq=2 ttl=255 time=0.268 ms

64 bytes from 172.16.2.2: icmp_seq=3 ttl=255 time=0.228 ms

64 bytes from 172.16.2.2: icmp_seq=4 ttl=255 time=0.227 ms

64 bytes from 172.16.2.2: icmp_seq=5 ttl=255 time=0.225 ms


--- 172.16.2.2 ping statistics ---

5 packets transmitted, 5 received, 0% packet loss, time 1ms

rtt min/avg/max/mdev = 0.225/0.266/0.385/0.063 ms, ipg/ewma 0.378/0.323 ms

se-100-1-21-10> ping 172.16.2.253

PING 172.16.2.253 (172.16.2.253) 56(84) bytes of data.


--- 172.16.2.253 ping statistics ---

5 packets transmitted, 0 received, 100% packet loss, time 4030ms

, ipg/ewma 1007.628/0.000 ms

se-100-1-21-10>


The router where CUE is has the 172.16.2.2 ip address, the server is 172.16.2.253.


Any ideas on why I can't connect to something on the local lan?


Thanks!

TURBOxSPOOL Fri, 12/10/2010 - 12:59

Yes. I 'solved' the problem by temporarily placing the service module on my other VLAN, uploading the script, and then revert back to the original configuration.

Actions

This Discussion

Related Content