etherchannel to servers wont come up

Answered Question
Apr 8th, 2010
User Badges:

im creating etherchannels on a stacked 3750 -lacp but th channel wont come up..is there something wrong w/ my config?

ive shu /no shut all interfaces too


Number of channel-groups in use: 6
Number of aggregators:           6


Group  Port-channel  Protocol    Ports
------+-------------+-----------+---------------------------
10     Po10(SD)        LACP      Gi1/0/43(I) Gi2/0/42(I)



interface Port-channel10
switchport access vlan 14
switchport mode access




Current configuration : 144 bytes
!
interface GigabitEthernet1/0/43
switchport access vlan 14
switchport mode access
channel-group 10 mode active
spanning-tree portfast



interface GigabitEthernet2/0/42
switchport access vlan 14
switchport mode access
channel-group 10 mode active
spanning-tree portfast

Correct Answer by Giuseppe Larosa about 6 years 11 months ago

Hello Nygenxny123,


yes probably LACP daemons has not been started on server side.


You can check this on the log message of the switch you should see messages telling that no LACP message is seen on port.


I see this multiple times when server people asks us an LACP bundle so we usually configure our side after they do their part on server NICs


Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Giuseppe Larosa Thu, 04/08/2010 - 08:50
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Nygenxny123,


check if interface port-channel is not created in shutdown


in order to have the bundle up when using LACP the other side must talk LACP otherwise after some time member links are removed from bundle if no LACP frames are received on them


so check if server or other switch is configured to use LACP


hope to help

Giuseppe

nygenxny123 Thu, 04/08/2010 - 09:20
User Badges:

i bounced my port-channel10 and still nothing



so from my config its safe to assume the other end/servers..may be having issues?


i wonder why the interface is showing (I)


in summary

droeun141 Thu, 04/08/2010 - 11:56
User Badges:

Your config looks good. I think the (i) means that the port's inactive in the etherchannel group (no LACP packets received), but is still able  to function as an individual link.

Tulsi Ram Puttaraju Thu, 04/08/2010 - 11:59
User Badges:

Hi,


Could you pls try the configs with


port-channel 1

switchport mode trunk


interface f0/1

switch mode trunk


interf f0/2

switch mode trunk



Not sure if you wanted the Etherchannel in Bundled( P ), right now it is showing( I )because it is stand alone which is correct if you want in access mode.


Tulsi Ram

Correct Answer
Giuseppe Larosa Thu, 04/08/2010 - 13:25
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Nygenxny123,


yes probably LACP daemons has not been started on server side.


You can check this on the log message of the switch you should see messages telling that no LACP message is seen on port.


I see this multiple times when server people asks us an LACP bundle so we usually configure our side after they do their part on server NICs


Hope to help

Giuseppe

Actions

This Discussion