QoS Policy/Class Map Error help please..

Unanswered Question
Apr 8th, 2010

please help with error, when I add my policy-map to the interface, I get the error below....qos config of policy and class map it complains about is included, thanks in advance..

6513-SUP32(config-if)#service-policy in LAN-EDGE

QoS-ERROR: Addition/Modification made to policymap LAN-EDGE and class VVLAN-VOIC

E is not valid, command is rejected

6513-SUP32(config-if)#

.......start config...................
mls qos map policed-dscp normal-burst 0 24 to 8
mls qos map cos-dscp 0 8 16 24 34 46 48 56
mls qos
mls netflow interface
no mls flow ip
no mls flow ipv6

!

class-map match-all VVLAN-CALL-SIGNALING
  match access-group name VVLAN-CALL-SIGNALING
class-map match-all VVLAN-VOICE
  match access-group name VVLAN-VOICE
class-map match-all VVLAN-ANY
  match access-group name VVLAN-ANY
class-map match-all AGENT-DESKTOP-TRAFFIC
  match access-group name AGENT-DESKTOP-TRAFFIC
!
!
policy-map LAN-EDGE
  class VVLAN-VOICE
   set dscp ef
   police cir 256000 bc 8000
     exceed-action drop
  class VVLAN-CALL-SIGNALING
   set dscp cs3
   police cir 32000 bc 8000
     exceed-action policed-dscp-transmit
  class VVLAN-ANY
   set dscp default
   police cir 32000 bc 8000
     exceed-action policed-dscp-transmit
  class AGENT-DESKTOP-TRAFFIC
   set dscp cs3
   police cir 256000 bc 8000
exceed-action policed-dscp-transmit
  class class-default
   set dscp default
   police cir 5000000 bc 8000
     exceed-action policed-dscp-transmit

!

ip access-list extended AGENT-DESKTOP-TRAFFIC
permit tcp 10.2.2.0 0.0.0.255 any eq 42028
permit tcp 10.2.2.0 0.0.0.255 any eq 59020
ip access-list extended VVLAN-ANY
permit ip 10.1.1.0 0.0.0.255 any
ip access-list extended VVLAN-CALL-SIGNALING
permit tcp 10.1.1.0 0.0.0.255 any range 2000 2002
permit udp 10.1.1.0 0.0.0.255 any eq 5060
permit tcp 10.1.1.0 0.0.0.255 any eq 5060 5061
ip access-list extended VVLAN-VOICE
permit udp 10.1.1.0 0.0.0.255 any range 16384 32767
!

  then error is generated when attempting to add the service-policy input LAN-EDGE command…

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Reza Sharifi Thu, 04/08/2010 - 11:31

Hi Dave,

Have a look at this document.  It seems that there are some limitation  on the 6500 series switch

QoS-ERROR: Addition/Modification made to policymap [chars] and class [chars] is not valid, command is rejected

QoS-ERROR: Addition/Modification made to policymap vtc-map and class voice-video is 
not valid, command is rejected

This error message indicates that the actions defined in the mentioned class is not allowed in Cisco Catalyst 6500 series switches. There are some restrictions during the configuration of policy map class actions.

  • You cannot do all three of these in a policy map class:

    • Mark traffic with the set commands

    • Configure the trust state

    • Configure policing

    You can only either mark traffic with the set commands.

    OR

    Configure the trust state and/or configure policing.

http://www.ciscosistemi.com/en/US/products/hw/switches/ps708/products_tech_note09186a008074d6b1.shtml#topic11

HTH

Reza

Actions

This Discussion