Critical Services deactivated on Unity Connection cluster Publisher

Unanswered Question
Apr 9th, 2010
User Badges:

Unity Connection Serviceability Version 7.0.2.10000-38


Connection Message Transfer Agent and Connection Notifier services show as deactivated on Publisher in Unity Connection Serviceability but Activiated and Started on Subscriber.


I can't see how to activate them on the Publisher and starting the box hasn't changed anything.


If I've missed a crucial but obvious point in documentation somewhere, please let me know.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
David Hailey Fri, 04/09/2010 - 14:27
User Badges:
  • Purple, 4500 points or more

Go to Cisco Unity Connection Servicability > Cluster Management and verify which server is the current primary.  Likely, it is the Subscriber.  If so, manually force the Publisher to become primary and you'll see these services move to an active state on the Publisher.


Hailey


Please rate helpful posts!

vincent.morton Fri, 04/09/2010 - 14:50
User Badges:

Thanks for the quick response. The sub was in Server Status Primary but when I clicked on the Make Primary button for the publisher I got an error message "Could not change Primary".


Under Port Manager, where you normally have the two Stop Taking Calls buttons, the sub has a Stop Takig Calls button but the publisher just displays a message "Conversation Manager Not Running". No button.


Now in the GUI both servers show as Server Status Secondary and the Make Primary button for the sub is greyed out


However, in CLI


admin:show cuc cluster status


Server Name  Member ID  Server State  Internal State  Reason
-----------  ---------  ------------  --------------  ------
stounity01   0          Primary       Pri Active      Normal
stounity02   1          Primary       Sec Acting Pri  Normal


Strangely, in Control Center - Feature Services, the services are now active on the publisher and inactive on the sub so it looks like that's that sorted.


I just need to work out why Connection Conversation Manager shows as started in Feature Services on the pub but Cluster Management displays Conversation Manager not running

David Hailey Fri, 04/09/2010 - 15:07
User Badges:
  • Purple, 4500 points or more

On cli issue utils service list page. If the service shows as running

but you still have inconsistency in the GUI then:


Reboot the pub. Then reboot the sub. Force the publisher to active

after reboot.


Sent from my iPhone


On Apr 9, 2010, at 5:50 PM, "vincent.morton"

vincent.morton Fri, 04/09/2010 - 16:12
User Badges:

Rebooting both servers has sorted the services as they appear in Service Management but in Cluster Management, Server Status for both servers shows as Primary although under Change Status, the sub does have a message saying "Server status change in progress".


It's been like this for about quarter of an hour following the reboot and the Make Primary buttons are, fairly obviously, greyed out for both servers.


From the CLI though, a show cuc cluster status on the pub shows both servers as Primary while the same command on the sub shows both servers as Secondary.

David Hailey Fri, 04/09/2010 - 16:22
User Badges:
  • Purple, 4500 points or more

The switchover after a reboot takes a bit. The severs are replicating

state and figuring out their state. Let it run and the Sub should

eventually change state to secondary.


Sent from my iPhone


On Apr 9, 2010, at 7:12 PM, "vincent.morton"

vincent.morton Fri, 04/09/2010 - 16:25
User Badges:

I thought it might be that but it's been a while. I'll leave it a bit longer and let you know how it goes.

David Hailey Fri, 04/09/2010 - 16:34
User Badges:
  • Purple, 4500 points or more

You can also refresh the page or log out and log back in. See if for

some reason the status hung.


Sent from my iPhone


On Apr 9, 2010, at 7:26 PM, "vincent.morton"

vincent.morton Sun, 04/11/2010 - 14:55
User Badges:

Logged in to check again and after nearly 48 hours the sub is still showing "Server status change in progress"

David Hailey Sun, 04/11/2010 - 15:02
User Badges:
  • Purple, 4500 points or more

Did you reboot both servers or just the Publisher?


Sent from my iPhone


On Apr 11, 2010, at 5:55 PM, "vincent.morton"

Actions

This Discussion