Link aggregation between Cisco 6509 running ios and HP server running Win2003

Answered Question
Apr 11th, 2010
User Badges:

I am trying to setup a 2 by 1gbit link aggregate connection between a c6509 running ios and an HP Proliant DL server running Win2003. The HP server has Hp SLB teaming  configured with 2 1gbit NIC cards.


My questions are:

1. what is the recommended protocol, LACP or PAgP ?

2. should I set LACP mode to ACTIVE (or use PAgP ON mode if PAgP is the preferred protocol) ?


Thanks for your support.

sankung

Correct Answer by vaishalin about 7 years 1 month ago

Hi


You should use lacp and use active mode.


Make sure from server side it is lacp (802.3ad).


Hope this helps


Vaishali

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
vaishalin Sun, 04/11/2010 - 07:11
User Badges:

Hi


You should use lacp and use active mode.


Make sure from server side it is lacp (802.3ad).


Hope this helps


Vaishali

sawosankung Sun, 04/11/2010 - 11:57
User Badges:

Hi,


I tried to convert an existing PAgP aggregate link to LACP but having problems bringing up the bundle. I did the following:

1. Config T

2. int range gi3/46 - 47

3.   no channel-group 99

4. exit

5. no int po99

6. int rang gi3/46 - 47

7.   channel-group 99 mode active

8.   channel-protocol lacp

9.   no shutdown

10. exit

11.int po99

12.  switchport

13.  switchport mode access

14.  no ip address

15.  swi acc vlan 10

16.  sp auto

17.  band 2000000

18   no shut

13.  end


The Portchannel 99 was re-created but it's  status is down/down. Also, I noticed the description field of the new Po99 is the same as the old po99 instead of being blank - meaning that it copied it from the old configuration.


What is the recommended way to reconfigure the Portchannel if I want to use the same portchannel number ?

.

And strangely, the HP server that the ports are connected to, with SLB teaming configured ports, show the teamed port up ? Doen't this mean that LACP is not actually established ?


Thanks for your response.


Sankung  

vaishalin Mon, 04/12/2010 - 07:24
User Badges:

Hi


Follow following steps


1 - Make default interface configuration

with default int configuration on config prompt.


2. Remove int port-channel 99


3. Reconfigure interfaces with channel-group 99 commands( port-channel will automatically gets created)

Add channel-group 99 command last after switch-port mode access and other commands.


4. Dont do any configuration under port-channel interface


5. All interface configuration commands will appear automatically under port-channel interface


6. If any ports are going into err-disabled state....just do shut and no shut that interfaces


Vaishali

Actions

This Discussion

Related Content