Host Not Found - Extension Mobility problem

Answered Question
Apr 11th, 2010

Hi

I have enabled extension mobility.

I understand that the service is configured properly as some users are able to login/logout successfully and when I check the URL in the settings of their IP Phones it displays the IP address of the server.

For some users, when I press the service button it displays message "Host Not Found" and when I check the URL in the settings of their IP Phones it does not display the  address of the server.

I have already tried the common mentioned solutions but no luck.

1. I have already made changes in Enterprise settings and replaced the CCM Hostname with IP Address.

2. I have added an entry in DNS server

3. Re-configured the service

4. Restarted the IP Phones, services [TFTP, Extension Mobility]

5. Rebooted the server

The only thing I missed out on was changing the hostname to IP address.

When i go to System---Server ---Find --- it displays the hostname. I am afraid of loosing service if I change from Hostname to  IP. The application itself warns from doing the same. I am managing the server remotely and have no technical assistance at the site.

Appreciate guidelines from all you techies out there.

Thanks

I have this problem too.
0 votes
Correct Answer by Aaron Harrison about 4 years 11 months ago

Hi

Looks like you have a load that falls foul of the problem listed here:

https://supportforums.cisco.com/message/3032276#3032276

https://supportforums.cisco.com/message/3050219#3050219

Try upgrading them to an interim version of firmware as discussed in those posts, and then upgrading to 8-5-2SR1S.

This is noted in the release notes for that firmware:

http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/firmware/8_5_2/english/release/notes/7900_852SR1.html#wp164599

Regards

Aaron

Please rate helpful posts...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Aaron Harrison Mon, 04/12/2010 - 00:51

Hi

The name in system/servers is sent to the phones and used for registration mainly. If the phones are registered you can leave that as is for now.

When you get the host not found, is this when you :

1) Press 'Services'? This is managed by the Enterprise Param -Services URL

2) Select EM from the services menu?

Aaron

sayeedibrahim Mon, 04/12/2010 - 22:48

Hi Aaron

I get this problem when i press the services button

Ayodeji oladipo... Mon, 04/12/2010 - 02:12

One of the things I would check is that the phones having these issue can reach the server hosting the extension mobility service. I blieve your phones are in different VLANS, hence you need to esure that the affected phones have connectivity to the server.

sayeedibrahim Mon, 04/12/2010 - 22:52

Hi

All my ip phones are in the same vlan. However the DNS server is another vlan. But when I connect a laptop to the switch assigning vlan as access vlan I can ping the CCM, DNS. I can even ping with the name of CCM.

The issue is that on some phones the services get displayed but not on all.

Aaron Harrison Mon, 04/12/2010 - 23:42

Hi

If you can see that you are accessing the services URL with an IP; and you have reset all the phones... and it still doesn't work:

1) Check that you can ping a phone that doesn't work from the service URL IP (i.e. the publisher, with 'utils network ping x.x.x.x')

2) Are the phones in the same VLAN as the publisher? Do a 'utils network arp list' to get the count of ARP addresses in the server cache and post it back

Aaron

sayeedibrahim Tue, 04/13/2010 - 06:13

Hi

One of the IP Phone which gives host not found problem has MAC Address: 00070E362181

Attached file has output for both utils network arp list and ping commands

Aaron Harrison Tue, 04/13/2010 - 06:19

Hi

OK, so reachability looks good.

If you browse to the phone IP, then click 'Netowrk Configuration', what do you see for the services URL?

Aaron

sayeedibrahim Tue, 04/13/2010 - 06:26

Attached is the html file for Device - Network configuration.

On CCM I have specified the IP Address but here it shows

MAC Address00070E362181

CallManager 1RSF-S01-C02-B01-UCM-1 CallManager 2

10.65.57.4 Active

Services URLhttp://CISCO-CALLMANAG/CCMCIP/getservicesmenu.asp
sayeedibrahim Tue, 04/13/2010 - 06:39

I just compared the Network configuration for phone that displays Services and the one that does not. Check below information.

I think the one giving problem should be reset to factory settings and register again with CCM V7.1

Phone displaying the services

User Locale Version4.2(3)Network Locale Version7.1.0.1(3)

Phone giving " Host Not Found" problem

User Locale Version4.1(3)Network Locale Version

4.1(3)

Aaron Harrison Tue, 04/13/2010 - 06:45

Hi

Do you have a different user/network locale configured for those phones in CCM?

If you have an invalid locale (i.e. you've selected a local that you haven't actually installed the files for) that might be why it shows different..

Aaron

Aaron Harrison Tue, 04/13/2010 - 06:40

What happens if you set your Enterprise Parameter for the Services URL to be:

http://x.x.x.x/CCMCIP/getservicesmenu.asp

Where x.x.x.x is your CCM IP? You said in your original post you had done this already?

sayeedibrahim Tue, 04/13/2010 - 06:46

As i mentioned earlier i have already changed server name to ip under Enterprise Parameters.

Tomorrow i will reset the IP Phone with IP 10.65.57.43 to factory settings and try.

Aaron Harrison Tue, 04/13/2010 - 06:52

Hi

OK, but why change it back before it's working? Keep it simple...

I have seen problems with accessing directories and other CCM pages related to locales; they should return in the user's locale, but if you haven't installed that locale on your cluster then you may have problems.

Check the locale set on the phone and any device profile that might be logging in, and make sure you have installed it properly as well.

Regards

Aaron

Joshua Warcop Tue, 04/13/2010 - 13:19

I didn't catch what models phone you have - but make sure you are telling the phones what domain to use when they do a DNS lookup.

If your using an IOS device for DHCP - make sure you have in your "ip dhcp pool Voice" a "domain-name mydomainx.com"

Name resolution should work fine and my personal recommendation is to stick with name resolution and use the CUCM server name instead of IP address.

sayeedibrahim Wed, 04/14/2010 - 01:51

Hello Everybody

The strange thing is that Services are working for some users and not for all users.

Check attached file and take at the loads info.

IP Phone with DN 9556 has all the services working while the other IP Phone with DN 9669 does not have the services running.

Aaron Harrison Wed, 04/14/2010 - 02:18

Hi

Those two phones are running completely different firmware - the non working one has not upgraded.

Can you screen grab the 'network configuration' page on the phones? It looks like one has not been able to upgrade for some reason. Do they both have the same TFTP server configured? Can they be PINGed from the TFTP server?

Aaron

sayeedibrahim Wed, 04/14/2010 - 02:33

I do not have a seperate TFTP server.

Both phones are using CCM as the TFTP server.

On the IP Phone with old firmware I tried basic reset [erase option from settings menu on the phone]  but no changes so i tried factory reset but now this phone keeps rebooting.

Here is the network config info:

1. IP Phone with services working fine

DHCP Server10.65.56.2
BOOTP ServerNo
MAC Address00070E361E98
Host NameSEP00070E361E98
Domain Name
IP Address10.65.57.46
Subnet Mask255.255.255.0
TFTP Server 110.65.57.4
Default Router 110.65.57.1
Default Router 2
Default Router 3
Default Router 4
Default Router 5
DNS Server 110.65.56.2
DNS Server 210.65.50.22
DNS Server 310.65.50.21
DNS Server 4
DNS Server 5
Operational VLAN Id2
Admin. VLAN Id
CallManager 1RSF-S01-C02-B01-UCM-1
CallManager 210.65.57.4 Active
CallManager 3
CallManager 4
CallManager 5
Information URLhttp://10.65.57.4:8080/ccmcip/GetTelecasterHelpText.jsp
Directories URLhttp://10.65.57.4:8080/ccmcip/xmldirectory.jsp
Messages URL
Services URLhttp://10.65.57.4:8080/ccmcip/getservicesmenu.jsp
DHCP EnabledYes
DHCP Address ReleasedNo
Alternate TFTPNo
Forwarding DelayNo
Idle URL
Idle URL Time0
Proxy Server URL
Authentication URLhttp://10.65.57.4:8080/ccmcip/authenticate.jsp
SW Port ConfigurationAuto Negotiate
PC Port ConfigurationAuto Negotiate
TFTP Server 2
User LocaleEnglish_United_States
Network LocaleUnited_States
Headset EnabledYes
User Locale Version4.2(3)
Network Locale Version7.1.0.1(3)
PC Port DisabledNo
Speaker EnabledYes
Group ListenNo
GARP EnabledNo
Video Capability EnabledNo
Voice VLAN EnabledYes
Auto Line Select EnabledNo
DSCP For Call ControlCS3
DSCP For ConfigurationCS3
DSCP For ServicesDefault
Security ModeNon Secure
Web Access EnabledYes
Span to PC PortNo
PC VLAN
CDP: PC PortYes
CDP: SW PortYes

2. IP Phone with " Host Not Found" problem

DHCP Server10.65.56.2
BOOTP ServerNo
MAC Address00070E165CA5
Host NameSEP00070E165CA5
Domain Name
IP Address10.65.57.42
Subnet Mask255.255.255.0
TFTP Server 110.65.57.4
Default Router 110.65.57.1
Default Router 2
Default Router 3
Default Router 4
Default Router 5
DNS Server 110.65.56.2
DNS Server 210.65.50.22
DNS Server 310.65.50.21
DNS Server 4
DNS Server 5
Operational VLAN Id2
Admin. VLAN Id4096
CallManager 1RSF-S01-C02-B01-UCM-1
CallManager 210.65.57.4 Active
CallManager 3
CallManager 4
CallManager 5
Information URLhttp://CISCO-CALLMANAG/CCMCIP/GetTelecasterHelpText.asp
Directories URLhttp://CISCO-CALLMANAG/CCMCIP/xmldirectory.asp
Messages URL
Services URLhttp://CISCO-CALLMANAG/CCMCIP/getservicesmenu.asp
DHCP EnabledYes
DHCP Address ReleasedNo
Alternate TFTPNo
Forwarding DelayNo
Idle URL
Idle URL Time0
Proxy Server URL
Authentication URLhttp://CISCO-CALLMANAG/CCMCIP/authenticate.asp
SW Port ConfigurationAuto Negotiate
PC Port ConfigurationAuto Negotiate
TFTP Server 2
User LocaleEnglish_United_States
Network LocaleUnited_States
Headset EnabledYes
User Locale Version4.1(3)
Network Locale Version4.1(3)
PC Port DisabledNo
Speaker EnabledYes
GARP EnabledYes
Video Capability EnabledNo
Voice VLAN EnabledYes
Auto Line Select EnabledNo
DSCP For Call ControlCS3
DSCP For ConfigurationCS3
DSCP For ServicesDefault
Security ModeNon Secure
Web Access EnabledYes
Span to PC PortNo
PC VLAN4096
sayeedibrahim Fri, 04/16/2010 - 23:19

Any hands on experience how i can upload new firmware on the CCM and IP Phone.

Aaron Harrison Sat, 04/17/2010 - 03:55

You don't need new firmware on the CCM; you need to make sure the phones on your network that have not upgraded can access the firmware you already have.

Regards

sayeedibrahim Sat, 04/17/2010 - 04:46

Pls check the below msgs that i see under the Device Logs - Debug Display

11:23:32a 24: Name=SEP00070E1626A4  Load= 7.2(1.0S) Last=Phone-Reg-Rej11:23:32a  24: Name=SEP00070E1626A4 Load= 7.2(1.0S) Last=Phone-Reg-Rej11:23:39a 6: Name=SEP00070E1626A4 Load=  7.2(1.0S) File Not Found11:23:40a  31: Name=SEP00070E1626A4 Load= 7.2(1.0S) File Auth Fail:  SCCP11.8-5-2SR1S11:23:40a  24: Name=SEP00070E1626A4 Load= 7.2(1.0S) Last=Phone-Reg-Rej

Correct Answer
Aaron Harrison Sun, 04/18/2010 - 12:05

Hi

Looks like you have a load that falls foul of the problem listed here:

https://supportforums.cisco.com/message/3032276#3032276

https://supportforums.cisco.com/message/3050219#3050219

Try upgrading them to an interim version of firmware as discussed in those posts, and then upgrading to 8-5-2SR1S.

This is noted in the release notes for that firmware:

http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/firmware/8_5_2/english/release/notes/7900_852SR1.html#wp164599

Regards

Aaron

Please rate helpful posts...

sayeedibrahim Mon, 04/19/2010 - 23:48

I have opened a TAC case and they suggested the same like you Aaron.

I will update once they solve the problem.

Thanks!

sayeedibrahim Wed, 05/05/2010 - 05:46

All services are now working on the ip phones after upgrading the firmware

All available IP phones had old firmware version 7.x

The new Call Manager 7.1 had phones firmware 8-5-2SR1S

I uploaded SCCP11.8-2-2SR3S on the CCM . IP phones did an auto upgrade to 8-2-2SR3S

Then changed the default device firmware back to 8-5-2SR1S and this time ip phones upgraded to the latest version a/v on the system

Thanks all for the support.

Actions

Login or Register to take actions

This Discussion

Posted April 11, 2010 at 11:43 PM
Stats:
Replies:23 Overall Rating:5
Views:6933 Votes:0
Shares:0
Tags: No tags.
 

Discussions Leaderboard

Rank Username Points
1
rob.huffman
21,530
2
Paolo Bevilacqua
15,141
3
Chris Deren
11,299
4
Ayodeji oladipo...
9,335
5
William Bell
4,940
Rank Username Points
Terry Cheema
325
Marcelo Almeida...
184
Aman Soi
101
bruno rangel
65
Aaron Harrison
61