Reconfiguring an aggregated link protocol from PAgP to LACP

Unanswered Question
Apr 12th, 2010

Hi,

I tried to convert an existing PAgP aggregated link to LACP but having problems bringing up the bundle. I did the following:

1. Config T

2. int range gi3/46 - 47

3.   no channel-group 99

4. exit

5. no int po99

6. int rang gi3/46 - 47

7.   channel-group 99 mode active

8.   channel-protocol lacp

9.   no shutdown

10. exit

11.int po99

12.  switchport

13.  switchport mode access

14.  no ip address

15.  swi acc vlan 10

16.  sp auto

17.  band 2000000

18   no shut

13.  end

The Portchannel 99 was re-created but it's  status is down/down and all member ports are showing as unbundled/single. Also, I noticed the description field of the new Po99 is the same as the old po99 instead of being blank - meaning that it was copied from the old configuration.

What is the recommended way to reconfigure the Portchannel if I want to use the same portchannel number ?

.

And strangely, the HP server that the ports are connected to, with SLB teaming configured ports, show the teamed port up ? What does this mean in terms of the operation of this link ? That is, would the host be LACP load-balancing on the two ports whilst the switch operates them in redundancy ?

Thanks for your response.

Sankung 

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
shailesh.h Thu, 04/15/2010 - 10:45

Can you please actual output of interfaces , status of etherchannel and port channel..

sawosankung Thu, 04/22/2010 - 10:33

Dear support,

One more question relating to EtherChannel.

We have a 2x1gbps EtherChannel link built between an Access and Core switch in our Data center using two ports in a WS-X6548-GE-TX linecard module. However, I read in one Cisco document that only one port per module should be used in an EtherChannel because of the ASIC configuration in this type of module which limits the channel to 1gbps.

Please can you tell me whether this is still the case with C6509 running IOS 12.x. Otherwise, what is the recommended selection of ports for EtherChannel using the WS-X6548-GE-TX ethernet module.

Thank you very much.

Sankung

Actions

This Discussion