IGMP configuration on single LAN segment

Unanswered Question
Apr 12th, 2010

Hi, Have a Cisco SGE2010p small business switch. I am trying to get multicast IGMP working with it, but the switch insists on flooding traffic to every single port.

Have:

* ticked the box Enable IGMP snooping

* ticked the box Enable Bridge multicast filtering (dont really know exactly what this does)

* set ports to Filtering on Unregistered Multicast - this fixed the port flood and allowed existing multicast to finish, but didn't allow new multicast sessions to start. Not sure if should be filtered or forwarded. (forwarding is for another switch connection????)

* have (i hope) enabled igmp querier on the switch as there is no mcast router

Any ideas or suggestions on what else needs to be done (or exactly what the above options do) very greatly appreciated.


/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin-top:0cm; mso-para-margin-right:0cm; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0cm; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

sw1# sh ip igmp snooping int 1

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin-top:0cm; mso-para-margin-right:0cm; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0cm; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

IGMP Snooping is globaly enabled

IGMP Snooping is enabled on VLAN 1

IGMP Snooping admin: enabled

Routers IGMP version: 3

Groups that are in IGMP version 2 compatibility mode:

Groups that are in IGMP version 1 compatibility mode:

IGMP snooping querier admin: enabled

IGMP snooping querier oper: disabled

IGMP snooping querier address admin:

IGMP snooping querier address oper: 192.168.10.9

IGMP snooping querier admin version: 3

IGMP host timeout is 260 sec

IGMP Immediate leave is disabled. IGMP leave timeout is 10 sec

IGMP mrouter timeout is 300 sec

Automatic learning of multicast router ports is enabled

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dan_track Fri, 04/16/2010 - 03:31

Hey,

1. How do you know it is being flooded to all ports in the switch?

2. Can you send us the switch config?

3. Is the switch multilayer? if so is it doing the routing?

Dan

tasdevil555 Thu, 04/22/2010 - 19:30

Hi Dan, thanks for replying i have fixed it now

The problem was that Windows deployment services was using multicast address 239.0.0.x which conflicts from a layer 2 perspective mac-ethernet multicast address of 224.0.0.x. Therefore the switch had no alternative but to send to all ports. Changed the multicast address to something a bit higher (239.45.33.x) fixed the problem working nicely. Seems a strange default to have for a multicasting program, perhaps the really expensive switches that microsoft can afford can process multicast based on the l3 address and not do mac table groups.

You could tell it was flooding because all lights flashed together and counters for ports went up that werent part of the session.

Actions

This Discussion

Related Content