Errors in Unity 4.2(1) after OS upgrade to Windows Server 2003

Unanswered Question
Apr 12th, 2010

I upgraded our Unity VM only server to server 2003 and reinstalled Unity 4.2(1) and restored untiy from backup. After the restore there are multiple errors in the Application log. I have engaged two different Cisco TAC people and neither of them could help me in resolving these problems. Makes me lose confidence in Cisco when I can't even get an American based engineer who knows anything about Unity! Hopefully someone here knows something.

Application Log errors below:

CiscoUnity_Notifier - Event ID 1071 and 1023,

Active Server Pages - Event ID 5,

CiscoUnity_ConvSubscriber - Event ID 187,

VBRuntime - Event ID 1,

CiscoUnity_BMsgConnector - Event ID 10005.

DBWalker returns1 error relating to orphaned entries in the GlobalSubscribers table:

*** Check for orphaned GlobalSubscriber table entries ***

1649:(error)  2 invalid rows found in the GlobalSubscriber table

These rows have no corresponding GlobalLocation table entry and are likely 'stranded' in the directory from a previous install.

The following rows were found to be invalid:

    Alias=USbms_FLAPK001-T03, SubscriberObjectID={069E45E6-B471-4C7C-A4F1-07EE0248EA25}, Bad LocationObjectID={63285FC4-1DCB-4C93-9903-DFAD724D548E}

    Alias=Unity_FLAPK001-T03, SubscriberObjectID={A1E42B80-AF4E-42CF-A2D0-12E2BEA862B4}, Bad LocationObjectID={63285FC4-1DCB-4C93-9903-DFAD724D548E}

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
David Hailey Mon, 04/12/2010 - 14:29

I'll have to look into this a bit more but I can tell you what this essentially means.  There are 3 main system accounts that Unity sets up when the application is installed (assuming you integrate with Exchange 2003).  You actually specify the location for these objects during the permissions wizard and etc.  The 2 accounts here are the primary system account for handling outside calls (Unity_) and the account used for failsafe operations (USbms_) - they are the 2 orphaned entries you see.  It appears the location specified for these accounts may have been invalid during the reinstall or there was some other yet to be determined issue at play here that caused these accounts to be orphaned which is not good.

When you installed Win2K3 and then reinstalled Unity, did you set up Unity to the exact version and ES that your last DiRT backup was saved at?  Also, did you specify the same OU's and etc when you ran the permissions wizard for where to import objects, create objects, and etc.

Can you attach a copy of the installation log and other application logs?  I'll try to look further and see if I can be of more assistance.


Please rate helpful posts!


This Discussion