RPF Failed but there is an RPF nbr entry

Unanswered Question
Apr 12th, 2010
User Badges:
  • Silver, 250 points or more

I am trying to setup my switch to receive mcast data from an upstream switch. The show mroute shows an entry for the rpf neighbor but the show ip mroute count shows "rpf failed". the output does show that i am receiving data. The server requesting the data is also in VLAN40. Please see the relevant switch config below. Interface G1/10 is directly connected to the neighbor device (10.10.10.1).


interface Vlan40
ip address 10.10.10.6 255.255.255.0
ip pim sparse-mode
load-interval 30


int g1/10

interface GigabitEthernet1/10
description Circuit to DATA PROVIDER (MCAST)
no ip address
logging event link-status
speed nonegotiate
switchport
switchport access vlan 40
switchport mode access
switchport nonegotiate
no cdp enable


interface GigabitEthernet9/44
description LS224 Connected to 306.28 Port 8
no ip address
logging event link-status
load-interval 30
  switchport
switchport access vlan 40
switchport mode access

ip pim rp-address 20.20.20.20 2


access-list 2 permit 224.0.62.0 0.0.0.255


sh access-list 2
Standard IP access list 2
    10 permit 224.0.62.0, wildcard bits 0.0.0.255 (487 matches)




sh ip mroute sparse
(*, 224.0.62.2), 00:19:58/00:02:54, RP 20.20.20.20, flags: SP
  Incoming interface: Vlan40, RPF nbr 10.10.10.1, RPF-MFD
  Outgoing interface list: Null


#sh ip mroute count
IP Multicast Statistics
2 routes using 864 bytes of memory
2 groups, 0.00 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)


Group: 224.0.62.2, Source count: 0, Packets forwarded: 0, Packets received: 550720
  RP-tree: Forwarding: 0/-714/0/331, Other: 550720/0/550720



Thanks,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Mon, 04/12/2010 - 12:40
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Etienne,


you can use sh ip rpf to check if the source passes the RPF check


you can enforce using


ip mroute source-address 255.255.255.255 interface-where-you-receive-the-stream


the RPF check is performed on the source of the stream and fails if packets are recevied on an interface that is not the one that unicast routing would use to reach the source


so you can have a PIM neighbor and an RPF neighbor towards the RP that is not the RPF neighbor for the real source.


Hope to help

Giuseppe

Tshi M Mon, 04/12/2010 - 19:08
User Badges:
  • Silver, 250 points or more

Hi Giuseppe,


I did try to use ip mroute statement to no avail before posting my question. I am going to try to use a transit network /30 and setup BGP. Hope that will fix the routing issue

Tshi M Wed, 04/14/2010 - 11:29
User Badges:
  • Silver, 250 points or more

just a quick to say that I setup a transit network and use a routing protocol (in this case bgp) to solve the issue.

Actions

This Discussion