Analog phones with VG224 get fast busy signal in outgoing calls for 5 seconds, then the call goes out

Unanswered Question
Apr 11th, 2010

Hi there,

**********UPDATE*************

I have the same problem with E1/R2 so the sip trunk its ok.

**********************************

Everytime I call a local number from a analog phone (I'm using a VG224) first it gets fast busy signal for about 5 seconds and then the call goes out, I'm using a SIP Trunk, dont know if that could be the issue cause the problem is only with the analog phones, in the IpPhones everything works great.

I ran a debug transalation detail and everything looks good with the dial-peers, actually nothing shows up in the screen before the fast busy signal, then when that fast busy is done the dial-peers start to take action.

Next monday I'm gonna get some E1 for some remote sites, so Ill test the analog phones in those sites to see if the issue has to do something with the CCM or VG224 Configuration or with the SIP Trunk.

Also I checked the SIP Messages from calls from one Analog and one IpPhone and everything looks good... what could it be?

This is the relevant Gateway's configuration regarding sip trunk and dial-peers

voice service voip
allow-connections h323 to sip
allow-connections sip to h323
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

h323
  emptycapability
sip
  bind control source-interface GigabitEthernet0/1
  bind media source-interface GigabitEthernet0/1
  min-se 2000
  registrar server expires max 3600 min 3600
  midcall-signaling passthru
!
!
!
voice class codec 1
codec preference 1 g729br8
codec preference 2 g729r8
codec preference 3 g711alaw
!
voice class codec 2
codec preference 1 g711ulaw
codec preference 2 g729r8
codec preference 3 g729br8
!
!
!
dial-peer voice 2 voip
description **Outgoing Call to SIP Trunk**
destination-pattern 09[1-9].......
rtp payload-type cisco-codec-fax-ind 113
rtp payload-type nte 98
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target ipv4:201.158.135.10
session transport udp
incoming called-number .
dtmf-relay rtp-nte cisco-rtp
fax-relay sg3-to-g3
fax rate 14400
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

!


sccp local GigabitEthernet0/0
sccp ccm 10.0.4.2 identifier 1 version 5.0.1
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate profile 4 register MTPPAL
associate profile 3 register CFBPAL
associate profile 2 register XCODERPAL
associate profile 5 register MTP711a
associate profile 6 register MTP729a
associate profile 7 register MTP729b
!
dspfarm profile 2 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
codec g729br8
maximum sessions 2
associate application SCCP
!
dspfarm profile 3 conference
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
codec g729br8
maximum sessions 4
associate application SCCP
!
dspfarm profile 4 mtp
codec g711ulaw
maximum sessions software 8
associate application SCCP
!
dspfarm profile 5 mtp
codec g711alaw
maximum sessions software 60
associate application SCCP
!
dspfarm profile 6 mtp
codec g729r8
codec g729ar8
maximum sessions software 60
associate application SCCP
!
dspfarm profile 7 mtp
codec g729abr8
codec g729br8
maximum sessions software 60
associate application SCCP

dial-peer voice 3 voip
description **Outgoing Call to Cel**
destination-pattern 09044..........
voice-class codec 1
session protocol sipv2
session target ipv4:201.158.135.10
session transport udp
dtmf-relay rtp-nte digit-drop
!
dial-peer voice 4 voip
description **Outgoing Call to LDN**
destination-pattern 0901..........
voice-class codec 1
session protocol sipv2
session target ipv4:201.158.135.10
session transport udp
dtmf-relay rtp-nte digit-drop
!
dial-peer voice 5 voip
description **Outgoing Call to 01800**
destination-pattern 0901800.......
voice-class codec 1
session protocol sipv2
session target ipv4:201.158.135.10
session transport udp
dtmf-relay rtp-nte digit-drop
!
dial-peer voice 6 voip
description **Outgoing Call to LDI**
destination-pattern 0900.T
voice-class codec 1
session protocol sipv2
session target ipv4:201.158.135.10
session transport udp
dtmf-relay rtp-nte digit-drop
!
dial-peer voice 7 voip
description **Outgoing Call to Cel**
destination-pattern 09045..........
voice-class codec 1
session protocol sipv2
session target ipv4:201.158.135.10
session transport udp
dtmf-relay rtp-nte digit-drop
!
dial-peer voice 9 voip
description **Outgoing Call to EME**
destination-pattern 090..
voice-class codec 1
session protocol sipv2
session target ipv4:201.158.135.10
session transport udp
dtmf-relay rtp-nte digit-drop
!
dial-peer voice 11 voip
description **Outgoing Call to 01900**
destination-pattern 0901900.......
voice-class codec 1
session protocol sipv2
session target ipv4:201.158.135.10
session transport udp
dtmf-relay rtp-nte digit-drop
!

sip-ua
credentials username 8xxxxxxxx password 7 XXXXXXXXXXXX realm default

authentication username 8xxxxxxxx password 7 XXXXXXXXXXXX
no remote-party-id
retry invite 2
retry response 3
retry bye 3
retry cancel 3
timers trying 1000
registrar ipv4:0.0.0.0 expires 300
sip-server dns:dnsserver
notify telephone-event max-duration 500
host-registrar

This is my VG Configuration:

Current configuration : 3510 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VG224-1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$4p82$icQ8Zhgr4eSOAqhICRm0J/
!
no aaa new-model
!
resource policy
!
ip subnet-zero
no ip dhcp use vrf connected
!
!
!
stcapp ccm-group 1
stcapp
!
!
stcapp feature access-code
!
stcapp feature speed-dial
!
voice-card 0
dsp services dspfarm
!
!
!
!
!
!
!
!
!

!
!
!
interface FastEthernet0/0
ip address 10.0.4.11 255.255.252.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip default-gateway 10.0.4.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.4.1
!
no ip http server
!
!
!
control-plane
!
!
voice-port 2/0
timing hookflash-in 600 80
!
voice-port 2/1
timing hookflash-in 600 80
!
voice-port 2/2
timing hookflash-in 600 80
!
voice-port 2/3
timing hookflash-in 600 80
!
voice-port 2/4
timing hookflash-in 600 80
!
voice-port 2/5
timing hookflash-in 600 80
!
voice-port 2/6
timing hookflash-in 600 80
!
voice-port 2/7
timing hookflash-in 600 80
!
voice-port 2/8
timing hookflash-in 600 80
!
voice-port 2/9
timing hookflash-in 600 80
!
voice-port 2/10
timing hookflash-in 600 80
!
voice-port 2/11
timing hookflash-in 600 80
!
voice-port 2/12
timing hookflash-in 600 80
!
voice-port 2/13
timing hookflash-in 600 80
!
voice-port 2/14
timing hookflash-in 600 80
!
voice-port 2/15
timing hookflash-in 600 80
!
voice-port 2/16
timing hookflash-in 600 80
!
voice-port 2/17
timing hookflash-in 600 80
!
voice-port 2/18
timing hookflash-in 600 80
!
voice-port 2/19
timing hookflash-in 600 80
!
voice-port 2/20
timing hookflash-in 600 80
!
voice-port 2/21
timing hookflash-in 600 80
!
voice-port 2/22
timing hookflash-in 600 80
!
voice-port 2/23
timing hookflash-in 600 80
!
ccm-manager sccp local FastEthernet0/0
!
!
sccp local FastEthernet0/0
sccp ccm 10.0.4.2 identifier 1
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
!
!
dial-peer voice 99920 pots
service stcapp
port 2/0
!
dial-peer voice 99921 pots
service stcapp
port 2/1
!
dial-peer voice 99922 pots
service stcapp
port 2/2
!
dial-peer voice 99923 pots
service stcapp
port 2/3
!
dial-peer voice 99924 pots
service stcapp
port 2/4
!
dial-peer voice 99925 pots
service stcapp
port 2/5
!
dial-peer voice 99926 pots
service stcapp
port 2/6
!
dial-peer voice 99927 pots
service stcapp
port 2/7
!
dial-peer voice 99928 pots
service stcapp
port 2/8
!
dial-peer voice 99929 pots
service stcapp
port 2/9
!
dial-peer voice 999210 pots
service stcapp
port 2/10
!
dial-peer voice 999211 pots
service stcapp
port 2/11
!
dial-peer voice 999212 pots
service stcapp
port 2/12
!
dial-peer voice 999213 pots
service stcapp
port 2/13
!
dial-peer voice 999214 pots
service stcapp
port 2/14
!
dial-peer voice 999215 pots
service stcapp
port 2/15
!
dial-peer voice 999216 pots
service stcapp
port 2/16
!
dial-peer voice 999217 pots
service stcapp
port 2/17
!
dial-peer voice 999218 pots
service stcapp
port 2/18
!
dial-peer voice 999219 pots
service stcapp
port 2/19
!
dial-peer voice 999220 pots
service stcapp
port 2/20
!
dial-peer voice 999221 pots
service stcapp
port 2/21
!
dial-peer voice 999222 pots
service stcapp
port 2/22
!
dial-peer voice 999223 pots
service stcapp
port 2/23
!
!
line con 0
logging synchronous
login local
line aux 0
line vty 0 4
logging synchronous
login local
!
end

I attach the SIP Messages for Analog and IP Calls.

What kind of debug or trace could I use to see whats happening between the VG224, CCM and the SIP Trunk? Could it be my Telco?

I have Cisco Call Manager 7.1.3 and a 3825 as voice gateway.

My users are really angry with that fast busy signal...

Any other suggestions?

Thanks in advance!

Eder.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
mezcalito Mon, 04/12/2010 - 15:19

Oh.. Im sure I uploaded the files, nevermind I think the Sip trunk is ok cause I tried to make outgoing calls from an E1-R2 and I have the same problem, Im gonna connect a 1751V with fxs ports to see if that fails too, maybe is the VG224 dont know

Any suggestions?

mezcalito Mon, 04/12/2010 - 20:27

Well I just configured a 1751V with MGCP and 2 ports FXS, and when I use it... everything works!!!! So is not the E1 nor Sip trunk. Well I gotta do some other tests. I need to test those ports in the 1751V with SCCP and the VG224 with MGCP, also Im gonna install another version of Call Manager and try it with that one to see if I have the same problem...

Does someone know a way to see whats going on between theVG224 and the Call Manager?

Regards.

mezcalito Mon, 04/12/2010 - 23:37

I just started from scratch I made some adjustments to my dial plan and everything is working now, I feel so bad instead of happy LOL, next time instead of trying to capture packets or test another way to do the same thing I will start from the most basic and simple stuff... well, at least I learnt a lot of debugging lol

Regards.

spazziani Tue, 01/04/2011 - 04:28

what kind of adjustment you did to solve your problem. I'm having the followingproblems:

I configured a VG224 with CCM 7.1.2 using the SCCP protocol to the analog stations have more features. All 24 branches have been registered in CallManager, but when I make calls to PSTN'm having some problems on IDD calls, 0800 and Services and Emergencies.

IDD calls to have the following problem:

CallManager Route Pattern in -> 000.!

When the extension that is registered in VG224 dials happens the following symptom:

- The user hears a busy tone after 5 seconds and the call is routed to the Voice Gateway and is normally completed. Users are complaining of busy tone before the call is completed. Below is the flow of the call.

    
- User Dials -> call the match on Route Pattern -> User hears a busy tone -> call is routed to the Voice Gateway -> User listens to the Ring Back -> call is completed normally.

I've done some tests, instead of putting the character! (Exclamation mark), put X Calls do not have problems, busy tone stopped happening before the call is completed.

Only one problem that has international calls and 0800 calls and services are of varying sizes can not create routes with X.

Has anyone had a problem like this?

Below are the settings VG224.

Regards,

Vinicius

phooghen Tue, 01/04/2011 - 04:47

You have probably an inter-digit timeout issue.

Can you please do the following on the VG224:



Under the voice-port please issue:



VG224-2(config-voiceport)#timeouts interdigit 12

VG224-2(config-voiceport)#shut

VG224-2(config-voiceport)#no shut



spazziani Tue, 01/04/2011 - 10:26

Thanks for the help. I finished the tests. Now we do not hear more busy tone before the call is completed. It was the timeout interdigit.

Regards

Vinicius

phooghen Tue, 01/04/2011 - 10:35

Can you confirm that changing the interdigit timeout on the VG224 voice-port to a value higher than 5 sec fixed the issue.

thanks,

Pierre.

spazziani Fri, 01/21/2011 - 02:03

Hi Pierre,

I have a question for you, why does this happen? Is there any documentation that explains the timeout interdigit using SCCP protocol?
Because leaving the timeout interdigit take calls too high to be completed. I tested withinterdigit timeout with less than 10 seconds and happens all the ton of busy. Is thereany other solution for calls to be completed faster?

Regard

Vinicius

phooghen Fri, 01/21/2011 - 02:47

CUCM has an interdigit timeout value set to T301timer.

By default, the VG has a smaller interdigit timeout value than the VG. This is the reason why you get the fast busy tone.

A way to fix this issue is to avoid having interdigit timeout on the CUCM.

For example, you can configure your Route Patterns ending with a # character.

If someone dials the number followed by the # character, you just avoid any interdigit timeout.

Pierre.

Actions

Login or Register to take actions

This Discussion

Posted April 11, 2010 at 3:49 AM
Stats:
Replies:10 Avg. Rating:
Views:6310 Votes:0
Shares:0

Related Content

Discussions Leaderboard

Rank Username Points
1 21,026
2 15,047
3 10,314
4 7,999
5 4,856
Rank Username Points
159
95
75
66
55