3825 Router switchport module issue

Answered Question
Apr 13th, 2010

I have a Cisco 3825 router with a switchport module NM-ESW-16.  I am using the switchport as a L2 switch with no problems, with the fastethernet ports configured that way, can ping etc on that module.  What I can not do is get out of that module, I have another router connected.  I created a VLAN (vlan 100) that has right now 1 port assigned but did have more.  I can not ping from the router the workstation and cannot do vice versa. Below is my running config... just a note I do not start adding portfast, stp etc until I am sure it works that is why it is so basic right now.

current configuration : 3714 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname XXXXXX
!
boot-start-marker
boot-end-marker
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
aaa session-id common
no network-clock-participate wic 1
ip cef
!
!
!
!
no ip domain lookup
ip domain name XXXXXXXXXXXXXXXXXX
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username XXXXXXXX privilege 15 password 7 XXXXXXXXXXXXXXXX
!
!
cem 2/0/0
payload-size 32
!
cem 2/1/0
payload-size 32
!
cem 2/2/0
payload-size 32
!
cem 2/3/0
payload-size 32
!
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
!
!
interface Loopback0
ip address 205.10.182.254 255.255.255.255
!
interface GigabitEthernet0/0
ip address 205.10.182.249 255.255.255.252
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface FastEthernet0/0/0
!
interface FastEthernet0/0/1
!
interface FastEthernet0/0/2
!
interface FastEthernet0/0/3
!
interface Serial0/1/0
no ip address
shutdown
clock rate 2016000
!
interface Serial0/1/1
no ip address
shutdown
clock rate 2016000
!
interface Serial0/1/2
no ip address
shutdown
clock rate 2016000
!
interface Serial0/1/3
no ip address
shutdown
clock rate 2016000
!
interface FastEthernet1/0
switchport access vlan 100
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
no ip address
!
interface Vlan100
ip address 205.10.182.1 255.255.255.240
!
router ospf 100
log-adjacency-changes
network 205.10.182.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!

!
line con 0
exec-timeout 5 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 5 0
transport input ssh
!
scheduler allocate 20000 1000
!
end

I have this problem too.
0 votes
Correct Answer by Kevin Brennan about 6 years 8 months ago

Hi Adam,

If you can, it might be an idea to remove the HWIC-4ESW.

This article (http://www.cisco.com/en/US/prod/collateral/routers/ps259/prod_qas0900aecd802a9470_ps5854_Products_Q_and_A_Item.html) suggests that the HWIC-ESW and NM-ESW need to be connected externally for them to work correctly in the same chassis.

Kevin

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
rupam_chakra1983 Tue, 04/13/2010 - 07:37

Can you share the Network configaurtion and other router config.

Also shut down the interface vlan t1 in the pased config.

Thanks

froweina1 Tue, 04/13/2010 - 07:41

what do you mean by network config, also the other router is not in the loop now. I am just trying to get from the switchport module on router A to router A.

Kevin Brennan Tue, 04/13/2010 - 07:46

Hi Adam,

Do you have any other switch modules in the router? If so, are they connected to each other?

Kevin

froweina1 Tue, 04/13/2010 - 07:53

no there is a NM-CEM-4SER and a HWIC-4esw which neither are configured to my knowledge and there are no cabling between them.

froweina1 Tue, 04/13/2010 - 08:05

Ok so I pulled the HWIC-4 esw card out...and it works.  Now I am completly lost. Why would the two cards plugged in not work if they are not configured or cabled together or anything?

I think i am understanding it more after reading.  What I am understanding is it needs to be stacked? So I have to view the switch module as a switch and basically do a router on a stick concept?

Kevin Brennan Tue, 04/13/2010 - 08:42

Hi Andy,

I think that the ISR's only have one internal link to a switch module. In you case it looks like the HWIC one was using it and not the NM-ESW.

Kevin

(Thanks for the rating)

Actions

This Discussion