OSPF/BGP Connectivity Issues

Unanswered Question
Apr 13th, 2010
User Badges:

                        Hello Guys,


                                        I have 2 routers running OSPF I one network that connects to a bgp network and and trying to ping from my OSPF stub router to the iBGP network however the ping fails. I can ping the directly connected OSPF neighbor fine hoever when I attempt to ping the same router using the iBGP IP address it fails. WHY is this? The 3 router configs are below. I have other BGP routers runnning behind that borger router but can ping any o them from the STUB router. Thanks.


This is the stub config



!
hostname BB1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 172.16.12.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
!
router ospf 1
log-adjacency-changes
network 172.16.12.0 0.0.0.255 area 0
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

This is the router that is running OSPF and BGP


hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.12.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 172.16.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
duplex auto
speed auto
!
!
router ospf 1
log-adjacency-changes
network 172.16.12.0 0.0.0.255 area 0
!
router bgp 7500
no synchronization
bgp log-neighbor-changes
network 10.12.1.0 mask 255.255.255.252
neighbor 10.12.1.1 remote-as 7500
no auto-summary
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end


R1



!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.13.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.14.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 10.12.1.1 255.255.255.252
duplex auto
speed auto
!
!
router bgp 7500
no synchronization
bgp log-neighbor-changes
network 10.12.1.0 mask 255.255.255.252
network 10.13.1.0 mask 255.255.255.252
network 10.14.1.0 mask 255.255.255.252
neighbor 10.12.1.2 remote-as 7500
neighbor 10.13.1.2 remote-as 5000
neighbor 10.14.1.2 remote-as 2500
neighbor 10.14.1.2 password cisco
no auto-summary
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end


R3


hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.13.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
!
router bgp 5000
no synchronization
bgp log-neighbor-changes
network 10.13.1.0 mask 255.255.255.0
neighbor 10.13.1.1 remote-as 7500
no auto-summary
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end


R4


!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.14.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.45.1.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 10.46.1.4 255.255.255.0
duplex auto
speed auto
!
!
router bgp 2500
no synchronization
bgp log-neighbor-changes
network 10.45.1.0 mask 255.255.255.0
network 10.46.1.0 mask 255.255.255.0
network 10.140.1.0
network 10.140.1.0 mask 255.255.255.252
neighbor 10.14.1.1 remote-as 7500
neighbor 10.14.1.1 password cisco
neighbor 10.45.1.5 remote-as 2500
neighbor 10.46.1.6 remote-as 2500
no auto-summary
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end


R5


hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.45.1.5 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
!
router bgp 2500
no synchronization
bgp log-neighbor-changes
network 10.45.1.0 mask 255.255.255.0
neighbor 10.45.1.4 remote-as 2500
no auto-summary
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end


R5



hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.46.1.6 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
!
router bgp 2500
no synchronization
bgp log-neighbor-changes
network 10.46.1.0 mask 255.255.255.0
neighbor 10.46.1.4 remote-as 2500
no auto-summary
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
AxiomConsulting Tue, 04/13/2010 - 08:25
User Badges:

Hello,


Please can you post the routing table from the OSPF stub router?


Thanks


PS - GNS3 - cool isnt it!

Charlie Mayes Tue, 04/13/2010 - 08:32
User Badges:


BB1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.12.0 is directly connected, FastEthernet0/0
BB1#

Giuseppe Larosa Tue, 04/13/2010 - 08:37
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Ike,

as you see the routing table is empty with only the connected route in this condition it cannot ping anything


follow my suggestions in previous post to fix it


Hope to help

Giuseppe

AxiomConsulting Tue, 04/13/2010 - 08:29
User Badges:

Sorry, was meant to add that there seems to be no redistribution of routes or default routes setup on any of the routers.


Cheers

Giuseppe Larosa Tue, 04/13/2010 - 08:31
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Ike,

I would suggest to place the configurations on one or more txt files attached to the post to increase readibility


if you don't generate a default route in OSPF, or you don't redistribute the stub router can know nothing about BGP routes


also you are not advertising in BGP the OSPF routes with the network command


minimum set:


edge router generates a default route in OSPF with


router ospf

default-information originate always


+


router bgp

network for OSPF subnets


OR


router ospf

red bgp XX subnets


router bgp

network for ospf subnets


OR


router ospf

red bgp XX subnets


router bgp XX

red ospf yy



Hope to help

Giuseppe

Charlie Mayes Tue, 04/13/2010 - 09:12
User Badges:

Thanks. That was easy. I just have one question. How can I create a completed routing table without redistibtuing my internal OSPF routes in the BGP routing table? I mean how do I introduce the BGP routes in my OSPF table?

Giuseppe Larosa Tue, 04/13/2010 - 09:53
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Ike,


>> How can I create a completed routing table without redistibtuing my  internal OSPF routes in the BGP routing table?


taking advantage of BGP network command that works not only for connected routes but also for all IP routes present in IP routing table


>> I mean how do I introduce the BGP routes in my OSPF table?


by redistributing BGP routes into OSPF but this is not used in real world because BGP usually carry much more IP prefixes then OSPF so the usual choice is to generate an OSPF default route on devices running both OSPF and BGP


Hope to help

Giuseppe

Actions

This Discussion