How to access a RV042 after a system-failure

Unanswered Question
Apr 13th, 2010
User Badges:

Hello,


my RV042 crashed after i tried to enable SSHd, using it's build-in telnet CLI.

I used the commands shown in the openRG users manual.

Everything went fine (the device responded like "expected", answering my commands with a number an AFAIR OK) until i gave the command to write the settings to NVRAM.

From this moment, the device stopped responding.

Internet connection, LAN connection went offline and every method, known to me, i tried to reset the device (60sec reset, 30/30/30 reset, 30sec reset) failed.

Everytime I turn it's power on, it seems to boot. But after a few seconds the DIAG-LED keeps flashing.

The last thing I tried, was to flash the firmware onto the device using TFTP. But the tool provided by cisco is not able to detect the RV042.

The LED that indicates LAN activity on the port to which my PC is connected flashes while the tool tries to connect to the device.

But after a few moments, the tool shows a message that it can't log in.


Now my question, of course, is:

Is there a possibility to "reanimate" a router which shows this symptoms?

or did I kill it without a chance to get it up and runnning again?



greetings from bavaria


Oskar


PS:

Please forgive my bumpy english. I had my last english lesson about 10 years ago ;-)

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Te-Kai Liu Tue, 04/13/2010 - 22:01
User Badges:
  • Gold, 750 points or more

There is a RV042 TFTP Utility that can be downloaded at

http://www.cisco.com/cisco/web/solutions/small_business/products/routers_switches/small_business_routers/index.html-tab-Resources


Before running the utility, unplug the power cable first. Then hold the hard reset button and plug the power cable back. Hopefully the device will blink the DIAG LED. If that happens, you could set a static IP, e.g. 192.168.1.100/255.255.255.0 on your PC and run the TFTP utility.

crash1277 Fri, 04/16/2010 - 12:36
User Badges:

Hi Security Router,


thanks for your fast response.

Your great advice was more than helpful.


Thanks a lot


The TFTP-tool was exactly that utility that .

Unfortunately it turned out, that it would have been a really great advance, if I had just one win-box hangin' around here, to run this app. Because using wine to run it gave me just the ability to connect the router via TFTP. Even though it was a fine feeling, to see that the router is still alive and responding as expected in this situation by telling the TFTP-tool that it's firmware is corrupted, the tool was not able to fullfil this request. After doing something, it finally decided it might be better to hang up.

Fortunately my simple work-around I tried, worked fine. I just tried to access the built-in webfrontend of the router after establishing a connection via TFTP-tool.

And to be honest, I didn't expect that to work, 'cause the webfrontend was inaccessible before. But for any reason, it did.

Maybe establishing the TFTP connection forced it, to go back to work and do it's job like it was used to do all the time before.

Anyway. My router is up and running again and my weekend, along with some money is saved too.



Thanks for your assistance.


Best wishes and greetings from bavaria


Ozzy

Actions

This Discussion

Related Content