Error when add new host

Answered Question
Apr 14th, 2010

Hi,

when I add a new host in inside interface or dmz interface the new host can´t surf over internet.

I view a error in Asa syslog:

3    Apr 14 2010    16:50:51    305006    94.245.80.12         portmap translation creation failed for tcp src inside:192.168.10.12/53995 dst outside:94.245.80.12/80

or

3    Apr 13 2010    09:14:43    305006    8.8.8.8         portmap translation creation failed for icmp src dmz:192.168.9.66 dst outside:8.8.8.8 (type 8, code 0)

: Saved
:
ASA Version 7.2(4)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password EhxQ5dBfvkyaUj52 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.10.8 W2K3-X32-SP
name 0.0.0.201 www.XXX.net
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.10.1 255.255.255.0
ospf cost 10
!
interface Vlan2
nameif outside
security-level 0
ip address 0.0.0.194 255.255.255.240
ospf cost 10
!
interface Vlan3
no forward interface Vlan1
nameif dmz
security-level 0
ip address 192.168.20.5 255.255.255.0
ospf cost 10
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
switchport access vlan 3
!
ftp mode passive
dns domain-lookup inside
dns domain-lookup outside
dns server-group DNS1
name-server W2K3-X32-SP
dns server-group DefaultDNS
timeout 30
name-server W2K3-X32-SP
domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group protocol TCPUDP
protocol-object udp
protocol-object tcp
access-list outside_access_in extended permit ip any any
access-list outside_access_in extended permit tcp any interface outside eq 3389
access-list outside_access_in extended permit object-group TCPUDP any interface dmz eq domain
access-list INSIDE_ACL_OUT extended permit ip any any
access-list 100 extended permit udp any any eq domain
access-list 100 extended permit tcp any any eq ftp
access-list 100 extended permit tcp any any eq ftp-data
access-list 100 extended permit tcp any any eq https
access-list 100 extended permit tcp any any eq 3389
access-list 100 extended permit tcp any any eq www
access-list 100 extended permit icmp any any
access-list inside_access_in extended permit ip any any
access-list inbound extended permit tcp any interface outside eq 3389
access-list RDP extended permit tcp any interface outside eq 3389 log
access-list RDP extended permit tcp interface outside interface inside eq 3389
access-list inside_nat0_outbound extended permit ip 192.168.10.0 255.255.255.0 192.168.5.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.10.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.10.0 255.255.255.0 192.168.4.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.10.0 255.255.255.0 192.168.9.0 255.255.255.0
access-list outbound extended permit ip any any
access-list outside_2_cryptomap extended permit ip 192.168.10.0 255.255.255.0 192.168.5.0 255.255.255.0
access-list outside_3_cryptomap extended permit ip 192.168.10.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list outside_4_cryptomap extended permit ip 192.168.10.0 255.255.255.0 192.168.4.0 255.255.255.0
access-list inside_acl extended permit ip any any
access-list dmz_access_in extended permit ip any any
pager lines 24
logging enable
logging asdm informational
logging from-address [email protected]
logging recipient-address [email protected] level errors
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool pool1 192.168.10.70-192.168.10.75 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 0.0.0.195-0.0.0.206 netmask 255.255.255.240
global (outside) 2 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 192.168.10.0 255.255.255.0
nat (dmz) 1 192.168.9.0 255.255.255.0
static (inside,outside) tcp www.XXX.net ftp 192.168.10.10 ftp netmask 255.255.255.255
static (inside,outside) tcp www.XXX.net ftp-data 192.168.10.10 ftp-data netmask 255.255.255.255
static (inside,outside) tcp 0.0.0.197 3389 192.168.10.9 3389 netmask 255.255.255.255
static (inside,outside) tcp 0.0.0.200 https 192.168.10.9 https netmask 255.255.255.255
static (inside,outside) tcp www.XXX.net https W2K3-X32-SP https netmask 255.255.255.255
static (inside,outside) tcp www.XXX.net www W2K3-X32-SP www netmask 255.255.255.255
static (inside,outside) udp www.XXX.net domain W2K3-X32-SP domain netmask 255.255.255.255
static (inside,outside) tcp www.XXX.net domain W2K3-X32-SP domain netmask 255.255.255.255
static (inside,outside) tcp 0.0.0.198 https 192.168.10.13 https netmask 255.255.255.255
static (inside,outside) tcp 0.0.0.198 www 192.168.10.133 www netmask 255.255.255.255
static (inside,outside) tcp 0.0.0.202 3389 192.168.10.10 3389 netmask 255.255.255.255
static (inside,outside) tcp 0.0.0.200 www 192.168.10.14 www netmask 255.255.255.255
access-group 100 in interface outside
access-group dmz_access_in in interface dmz
route outside 0.0.0.0 0.0.0.0 0.0.0.193 1
route dmz 192.168.9.0 255.255.255.0 192.168.20.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.255 inside
http 192.168.10.0 255.255.255.0 inside
http 0.0.0.194 255.255.255.255 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-NOAUT esp-3des esp-none
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 2 match address outside_2_cryptomap
crypto map outside_map 2 set peer 88.2.225.218
crypto map outside_map 2 set transform-set ESP-3DES-SHA
crypto map outside_map 2 set security-association lifetime seconds 172800
crypto map outside_map 3 match address outside_3_cryptomap
crypto map outside_map 3 set peer 80.24.224.149
crypto map outside_map 3 set transform-set ESP-3DES-SHA
crypto map outside_map 3 set security-association lifetime seconds 172800
crypto map outside_map 4 match address outside_4_cryptomap
crypto map outside_map 4 set peer 80.37.221.171
crypto map outside_map 4 set transform-set ESP-3DES-SHA
crypto map outside_map 4 set security-association lifetime seconds 172800
crypto map outside_map interface outside
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 80000
crypto isakmp policy 30
authentication pre-share
encryption 3des
hash sha
group 1
lifetime 172800
crypto isakmp nat-traversal  15
crypto isakmp disconnect-notify
crypto isakmp reload-wait
telnet timeout 5
ssh timeout 5
console timeout 0
l2tp tunnel hello 120
dhcpd auto_config outside
!
dhcpd address 192.168.10.90-192.168.10.100 inside
dhcpd dns 154.15.255.134 154.15.255.130 interface inside
dhcpd enable inside
!
dhcpd dns 8.8.8.8 8.8.8.4 interface dmz
!

group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
vpn-idle-timeout none
vpn-session-timeout none
vpn-tunnel-protocol IPSec l2tp-ipsec
group-policy DfltGrpPolicy attributes
banner none
wins-server none
dns-server none
dhcp-network-scope none
vpn-access-hours none
vpn-simultaneous-logins 3
vpn-idle-timeout none
vpn-session-timeout none
vpn-filter none
vpn-tunnel-protocol IPSec l2tp-ipsec webvpn
password-storage disable
ip-comp disable
re-xauth disable
group-lock none
pfs disable
ipsec-udp disable
ipsec-udp-port 10000
split-tunnel-policy tunnelall
split-tunnel-network-list none
default-domain none
split-dns none
intercept-dhcp 255.255.255.255 disable
secure-unit-authentication disable
user-authentication disable
user-authentication-idle-timeout none
ip-phone-bypass disable
leap-bypass disable
nem disable
backup-servers keep-client-config
msie-proxy server none
msie-proxy method no-modify
msie-proxy except-list none
msie-proxy local-bypass disable
nac disable
nac-sq-period 300
nac-reval-period 86400
nac-default-acl none
address-pools none
smartcard-removal-disconnect enable
client-firewall none
client-access-rule none
webvpn
  functions url-entry
  html-content-filter none
  homepage none
  keep-alive-ignore 4
  http-comp gzip
  filter none
  url-list none
  customization value DfltCustomization
  port-forward none
  port-forward-name value Application Access
  sso-server none
  deny-message value Login was successful, but because certain criteria have not been met or due to some specific group policy, you do not have permission to use any of the VPN features. Contact your IT administrator for more information
  svc none
  svc keep-installer installed
  svc keepalive none
  svc rekey time none
  svc rekey method none
  svc dpd-interval client none
  svc dpd-interval gateway none
  svc compression deflate
tunnel-group DefaultL2LGroup ipsec-attributes
isakmp keepalive threshold 30 retry 2
tunnel-group DefaultRAGroup general-attributes
address-pool pool1
default-group-policy DefaultRAGroup
tunnel-group DefaultRAGroup ipsec-attributes
pre-shared-key *
isakmp keepalive threshold 30 retry 2
tunnel-group XXX218 type ipsec-l2l
tunnel-group XXX218 ipsec-attributes
pre-shared-key *
tunnel-group xxx.149 type ipsec-l2l
tunnel-group xxx.149 ipsec-attributes
pre-shared-key *
tunnel-group xxx type ipsec-l2l
tunnel-group xxx 71 ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect dns
  inspect icmp
!
service-policy global_policy global
smtp-server 217.76.146.62
prompt hostname context
Cryptochecksum:84daf90e8dbb06197c686f506bff4e45
: end
asdm image disk0:/asdm-524.bin
asdm location 192.168.9.0 255.255.255.0 inside
no asdm history enable

If I change some aleatory configuration like add a nat in outside interface (and then I delete the nat)... all start´s to work fine

thanks a lot!

I have this problem too.
0 votes
Correct Answer by Jennifer Halim about 6 years 7 months ago

Yes, I would remove "global (outside) 1 0.0.0.195-0.0.0.206 netmask  255.255.255.240", and add "global (outside) 1 interface" instead.

After configuration changes, make sure you perform "clear xlate" to clear the existing translation table.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Collin Clark Wed, 04/14/2010 - 09:11

Can you post a show version? This sounds like it could be related to your user license.

cuelate21 Thu, 04/15/2010 - 01:02

Result of the command: "show version"

Cisco Adaptive Security Appliance Software Version 7.2(4)

Device Manager Version 5.2(4)

Compiled on Sun 06-Apr-08 13:39 by builders

System image file is "disk0:/asa724-k8.bin"

Config file at boot was "startup-config"

ciscoasa up 21 days 18 hours

Hardware:   ASA5505, 256 MB RAM, CPU Geode 500 MHz

Internal ATA Compact Flash, 128MB

BIOS Flash M50FW080 @ 0xffe00000, 1024KB

Encryption hardware device : Cisco ASA-5505 on-board accelerator (revision 0x0)

                             Boot microcode   :  CNlite-MC-Boot-Cisco-1.2

                             SSL/IKE microcode:  CNlite-MC-IPSEC-Admin-3.03

                             IPSec microcode  :  CNlite-MC-IPSECm-MAIN-2.05

0: Int: Internal-Data0/0    : address is 0024.97e0.d9c6, irq 11

1: Ext: Ethernet0/0         : address is 0024.97e0.d9be, irq 255

2: Ext: Ethernet0/1         : address is 0024.97e0.d9bf, irq 255

3: Ext: Ethernet0/2         : address is 0024.97e0.d9c0, irq 255

4: Ext: Ethernet0/3         : address is 0024.97e0.d9c1, irq 255

5: Ext: Ethernet0/4         : address is 0024.97e0.d9c2, irq 255

6: Ext: Ethernet0/5         : address is 0024.97e0.d9c3, irq 255

7: Ext: Ethernet0/6         : address is 0024.97e0.d9c4, irq 255

8: Ext: Ethernet0/7         : address is 0024.97e0.d9c5, irq 255

9: Int: Internal-Data0/1    : address is 0000.0003.0002, irq 255

10: Int: Not used            : irq 255

11: Int: Not used            : irq 255

Licensed features for this platform:

Maximum Physical Interfaces : 8

VLANs                       : 3, DMZ Restricted

Inside Hosts                : Unlimited

Failover                    : Disabled

VPN-DES                     : Enabled

VPN-3DES-AES                : Enabled

VPN Peers                   : 10

WebVPN Peers                : 2

Dual ISPs                   : Disabled

VLAN Trunk Ports            : 0     

This platform has a Base license.

Serial Number:

Running Activation Key: 0x

Configuration register is 0x1

Configuration last modified by admin at 08:54:06.304 UTC Thu Apr 15 2010

I just bought  a Cisco Security Plus license.

Thanks!!

Jennifer Halim Wed, 04/14/2010 - 14:45

A few things that I've found:

1) "global (outside) 2 interface" ---> should be "global (outside) 1  interface"

There is no number 2 sequence on your nat statement, therefore, global with sequence 2 will never get invoked.

2) DMZ interface is currently configured with security level 0, same as outside. You would need to change it to something higher, as I wouldn't think you would like your DMZ interface to have the same security level as your outside. If you otherwise think you need it, then you would need the "same-security-traffic permit inter-interface" command.

3) Your DMZ interface is 192.168.20.5/24, however your NAT statement for DMZ is on a different subnet: "nat (dmz) 1 192.168.9.0 255.255.255.0".

Change it to match your interface subnet: "nat (dmz) 1 192.168.20.0 255.255.255.0"

4) Lastly, your global pool address: "global (outside) 1 0.0.0.195-0.0.0.206 netmask 255.255.255.240", overlaps with your static statements. So you would either shorthen the address pool for the global statement so it doesn't overlap with the public address that you have assigned to your static nat statement OR/ completely remove it once you change point# 1 to "global (outside) 1 interface".

Hope that resolves your issue.

cuelate21 Thu, 04/15/2010 - 03:45

halijenn escribió:

A few things that I've found:

1) "global (outside) 2 interface" ---> should be "global (outside) 1  interface"

There is no number 2 sequence on your nat statement, therefore, global with sequence 2 will never get invoked.

2) DMZ interface is currently configured with security level 0, same as outside. You would need to change it to something higher, as I wouldn't think you would like your DMZ interface to have the same security level as your outside. If you otherwise think you need it, then you would need the "same-security-traffic permit inter-interface" command.

3) Your DMZ interface is 192.168.20.5/24, however your NAT statement for DMZ is on a different subnet: "nat (dmz) 1 192.168.9.0 255.255.255.0".

Change it to match your interface subnet: "nat (dmz) 1 192.168.20.0 255.255.255.0"

4) Lastly, your global pool address: "global (outside) 1 0.0.0.195-0.0.0.206 netmask 255.255.255.240", overlaps with your static statements. So you would either shorthen the address pool for the global statement so it doesn't overlap with the public address that you have assigned to your static nat statement OR/ completely remove it once you change point# 1 to "global (outside) 1 interface".

Hope that resolves your issue.

Thanks halijenn


1) I have one  global (outside) 0.0.0.195-0.0.0.206 netmask 255.255.255.240 I need a global (outside) 1 interface too??


2) This problem could affect only to security, no? .I haven´t got security over dmz interface?


3) I have a statement for DMZ in a different subnet because the traffic come from a remote lan 192.168.9.0. This remote lan pass through 192.168.20.1 (route dmz 192.168.9.0 255.255.255.0 192.168.20.1 1) .   I need to add  "nat (dmz) 1 192.168.20.0 255.255.255.0 " ???  traffic  comes from 192.168.9.0 to outside interface passing through 192.168.20.0


4)  I can´t understand. I don´t know where I overlap with the static statement.

thanks a lot!!

Jennifer Halim Thu, 04/15/2010 - 04:52

Here are the answers to your questions:


1) I have one  global (outside) 0.0.0.195-0.0.0.206 netmask  255.255.255.240 I need a global (outside) 1 interface too??

A: as advised earlier, those global pool is ip address 0.0.0.195-0.0.0.206, ie: 12 ip addresses only. It will not be doing PAT, therefore, only 12 internal ip addresses will be NATed to the above 12 addresses.

However, as I said earlier, those pool overlap with your static statements:

static (inside,outside) tcp www.XXX.net ftp 192.168.10.10 ftp netmask 255.255.255.255
static (inside,outside) tcp www.XXX.net ftp-data 192.168.10.10 ftp-data netmask 255.255.255.255
static (inside,outside) tcp 0.0.0.197 3389 192.168.10.9 3389 netmask 255.255.255.255
static (inside,outside) tcp 0.0.0.200 https 192.168.10.9 https netmask 255.255.255.255
static (inside,outside) tcp www.XXX.net https W2K3-X32-SP https netmask 255.255.255.255
static (inside,outside) tcp www.XXX.net www W2K3-X32-SP www netmask 255.255.255.255
static (inside,outside) udp www.XXX.net domain W2K3-X32-SP domain netmask 255.255.255.255
static (inside,outside) tcp www.XXX.net domain W2K3-X32-SP domain netmask 255.255.255.255
static (inside,outside) tcp 0.0.0.198 https 192.168.10.13 https netmask 255.255.255.255
static (inside,outside) tcp 0.0.0.198 www 192.168.10.133 www netmask 255.255.255.255
static (inside,outside) tcp 0.0.0.202 3389 192.168.10.10 3389 netmask 255.255.255.255
static (inside,outside) tcp 0.0.0.200 www 192.168.10.14 www netmask 255.255.255.255

name 0.0.0.201 www.XXX.net

The following ip addresses have been used for your static statements: 0.0.0.197, .198, .200, .201 and .202, which overlaps with your global pool range: 0.0.0.195-0.0.0.206 ---> therefore, your global pool only have 7 addresses left to be used: .195, .196, .199, .203, .204, .205 and .206. Therefore, only 7 addresses from your internal network can be NATed out. If you need more than 7 internal addresses to be NATed out, you would need to have:

global (outside) 1 interface

2) You should not have the same security level on both dmz and outside. Just change the security level to some other number like 50 maybe. DMZ is supported to be protected from the outside.

3) OK, my bad, I didn't see the route dmz statement earlier.

4) As described in 1) above.

cuelate21 Thu, 04/15/2010 - 06:32

thanks halijenn

Yes, I need more than 7 ip nated out so I have to delete global (outside) 0.0.0.195-0.0.0.206 netmask  255.255.255.240 and add global (outside) 1 interface , no? .or the two can coexist?


Summary: The configuration that I have can not do all nat that I need , right?

I'm sorry but this is my first ASA config...


thanks a lot!

Correct Answer
Jennifer Halim Thu, 04/15/2010 - 06:35

Yes, I would remove "global (outside) 1 0.0.0.195-0.0.0.206 netmask  255.255.255.240", and add "global (outside) 1 interface" instead.

After configuration changes, make sure you perform "clear xlate" to clear the existing translation table.

cuelate21 Thu, 04/15/2010 - 06:46

Result of the command: "show xlate"

24 in use, 25 most used
PAT Global www.xxxx.net(21) Local 192.168.10.10(21)
PAT Global www.xxxx.net(20) Local 192.168.10.10(20)
PAT Global 0.0.0.197(3389) Local 192.168.10.9(3389)
PAT Global 0.0.0.200(443) Local 192.168.10.9(443)
PAT Global www.xxxx.net(443) Local W2K3-X32-SP(443)
PAT Global www.xxxx.net(80) Local W2K3-X32-SP(80)
PAT Global www.xxxx.net(53) Local W2K3-X32-SP(53)
PAT Global www.xxxx.net(53) Local W2K3-X32-SP(53)
PAT Global 0.0.0.198(443) Local 192.168.10.13(443)
PAT Global 0.0.0.198(80) Local 192.168.10.133(80)
PAT Global 0.0.0.202(3389) Local 192.168.10.10(3389)
PAT Global 0.0.0.200(80) Local 192.168.10.14(80)
Global 0.0.0.202 Local 192.168.9.8
Global www.xxxx.net Local 192.168.9.17
Global 0.0.0.206 Local 192.168.9.12
Global 0.0.0.204 Local 192.168.9.4
Global 0.0.0.198 Local 192.168.9.66
Global 0.0.0.200 Local 192.168.9.16
Global 0.0.0.205 Local 192.168.9.5
Global 0.0.0.197 Local 192.168.9.7
Global 0.0.0.203 Local 192.168.9.3
Global 0.0.0.196 Local 192.168.10.10
Global 0.0.0.199 Local 192.168.10.9
Global 0.0.0.195 Local 192.168.10.6

this is my xlate table but I see more than 7 global nat...

sorry,I can´t  understand the concept.

thanks thanks a lot...
Jennifer Halim Fri, 04/16/2010 - 03:44

Yes, they are 12 as per your global pool, however, as advised earlier, some of the ip addresses are overlapping with the static statements, which could cause issue.

cuelate21 Fri, 04/16/2010 - 04:18

thanks halijenn


I will change the config in a few days. Now the firewall is in a remote site and I prefer make there the changed .

Actions

This Discussion

Related Content