Cisco Twingig Converter not detecting Catalyst 4900M

Unanswered Question
Apr 14th, 2010
User Badges:
  • Silver, 250 points or more

When i insert the twingig converter i get following error message, i got the replacement Twingig converter from Cisco but error message persists.


%C4K_TRANSCEIVERMAN-3-SEEPROMREADFAILED: Failed to read transceiver serial eeprom on port Te2/1, try reinserting


Anybody has any clue ?


Catalyst 4900M is running following image


cat4500e-ipbasek9-mz.122-40.XO.bin


Twingig converter part number is : CVR-X2-SFP
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
t-yamashita Thu, 04/15/2010 - 00:49
User Badges:
  • Gold, 750 points or more

Hi satish,


Try removing and reinserting the transceiver.


If this message still appears after that, try the transceiver in another port, to verify that the transceiver is bad, and not the port.


If the transceiver fails in another port, return the transceiver, as the transceiver must be reprogrammed for it to work.


If the transceiver succeeds in other ports, but not the original port, that implies that the original port is bad, not the transceiver,

and the module needs to be returned, to fix the port. As a further test of the port, other transceivers could be tried in the suspected bad port.


If these other transceivers also fail in that port, it is very likely that the port is bad.


Please take a look at the link:

http://conft.com/en/US/docs/switches/lan/catalyst4500/12.2/31sga/system/message/emsg.html


HTH,


Tomoyuki

satish_zanjurne Thu, 04/15/2010 - 01:12
User Badges:
  • Silver, 250 points or more

Hi,


As i mentioned i have received replacement from Cisco, but for replacement converter also switch gives same error message. Now ports of the switch cannot be bad, because other 10G fiber module/SFP are detecting on those ports.

Giuseppe Larosa Thu, 04/15/2010 - 03:43
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Satish,

according to C4900M datasheet  the twingig converter is supported only on ports of half cards

>>>>> Yes (half cards only)


see

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps6021/ps9310/Data_Sheet_Cat_4900M.html


So it may be a question of the port you are trying  to insert the module in


Hope to help

Giuseppe

satish_zanjurne Thu, 04/15/2010 - 03:59
User Badges:
  • Silver, 250 points or more

Guys ,


"hw-module module 2 port-group 1 select gigabitethernet" command did the trick.


Here is the sequence


1. I inserted the module it gave me following error.

    %C4K_TRANSCEIVERMAN-3-SEEPROMREADFAILED: Failed to read transceiver serial eeprom on port Te2/1, try reinserting


2. hw-module module 2 port-group 1 select gigabitethernet" command added


    *Apr 15 03:07:56: %C4K_GLMMAN-3-X2INTWINGIGCONVERTERHOLE: X2 inserted in port Te2/2, which is configured for a TwinGigConverter

    4w4d: Port Te2/1: TwinGig Converter inserted: vendor: CISCO SYSTEMS, p/n: 800-27645-01, s/n: FDO12140G92


    So it detected the Twingig module


3.Then i inserted GLC-T in left side of Twingig and it detected the GLC-T as Gi2/9 port


Cisco TAC gave me this commands and i challenged them saying it needs be entered once Twingig is detected ( but i was wrong). I guess Cisco error message documentation needs to mention about this command.


hopefull it will be helpful for other people..

glen.grant Thu, 04/15/2010 - 04:44
User Badges:
  • Purple, 4500 points or more

  Also keep in mind on these twingig converters in the 4900M ,  the next 2 ports in that hardware group can only be gigbit , you cannot make the next port in the hardware group 10 gig  once you have selected gigabit as the speed for that hardware group  , so if ports 1 and 2 are gigabit then ports 3 and 4 can only be gigabit also . A hardware limitation .

Actions

This Discussion