No ringback tone

Unanswered Question
Apr 14th, 2010

Hi

I have the following setup: Nortel PBX - ISDN PRI - CISCO3825

I am trying to call to the other organization but there is no ringback tone on the line. If the other side answers, we can hear each other successfully.

There is a ringback tone when they call us.

Here is the call flow

Nortel PBX - ISDN PRI - CISCO3825 - H323 - Softswitch(gatekeeper) - H323 - CISCO2851 - H323 - PANASONIC PBX with IP module

I am attaching a debug output maybe you can give some advice

And here are the dial-peers

To Nortel PBX:

dial-peer voice 640 pots
tone ringback alert-no-PI <--- added because there were several problems with ringback when someone called us
huntstop
destination-pattern 640....
direct-inward-dial
port 0/3/0:15
forward-digits 4

To the other organization:

dial-peer voice 6335211 voip
translation-profile outgoing ToVoIP
preference 1
destination-pattern 6335211
voice-class codec 3
voice-class h323 1
session target ipv4:x.x.x.x
dtmf-relay h245-alphanumeric
fax rate 9600
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco
no vad

(Don't know about the config at the other side)

Thx

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ayodeji oladipo... Thu, 04/15/2010 - 00:45

you need to enter these commands under your pots dial-peer

progress_ind setup enable 3
progress_ind alert enable 8

OOO Complex Tel... Thu, 04/15/2010 - 01:28

Thank you for your replies

I'd like to understand the background.

As I can see in debugs my router is sending SETUP message with pi=3 already

Apr 15 10:32:54.682: //1023160/CB4D7C04A5D1/CCAPI/ccCallSetupRequest:
   Destination=, Calling IE Present=TRUE, Mode=0,
   Outgoing Dial-peer=6335211, Params=0x685E7864, Progress Indication=ORIGINATING SIDE IS NON ISDN(3)

Short after i receive PROGRESS with pi=8

Apr 15 10:32:55.698: //1023161/CB4D7C04A5D1/CCAPI/cc_api_call_cut_progress:
   Interface=0x708AA3C8, Progress Indication=INBAND(8), Signal Indication=SIGNAL RINGBACK(1),
   Cause Value=0

And ALERTING with pi=8

Apr 15 10:32:55.702: //1023161/CB4D7C04A5D1/CCAPI/cc_api_call_alert:
   Interface=0x708AA3C8, Progress Indication=INBAND(8), Signal Indication=SIGNAL RINGBACK(1)
Apr 15 10:32:55.702: //1023161/CB4D7C04A5D1/CCAPI/cc_api_call_alert:

I suppose that means that the other side provides me ringback tone? But still silence

OOO Complex Tel... Sun, 04/18/2010 - 20:29

I've tried to add this commands to my pots dial-peer

progress_ind setup enable 3
progress_ind alert enable 8

but it did not solve the problem

OOO Complex Tel... Mon, 04/19/2010 - 03:50

further troubleshooting revealed that when dial-peer from my cisco 3825 points directly to cisco 2821 at the other side (gatekeeper excluded) calls are going fine. There is ringback tone.

Seems that backward audio path for is not established through the gatekeeper to carry in-band information.

stephen.himebau... Sun, 07/11/2010 - 08:41

We had a similiar situation but our setup & messages were different from you.  Converted MGCP gateway with Cisco-Nortel trunk to H.323.  After H.323 conversion, calls from Cisco phones to some internal Nortel phones gave ringback; other did not.  So no ringback on calls to some Nortel phones.  External calls to the PSTN go through the Nortel, and always had ringback.

Setup: Cisco IP SCCP phone ->  CUCM 7.1.3 -> 3845 VG 12.4(20)T3 H.323 -> DMS-100 Trunk -> Nortel PBX -> Nortel phone.

Noticed that our no ringback calls did not receive CALL_PROC Q931 message from Nortel.  Different from your situation as I see a CALL_PROC message in your debugs.

Solved the issue by modifying the POTS dial-peer.  Removed the progress indicator commands ( 'progress_ind setup enable ...' ) from the dial-peer, and added ' tone ringback alert-no-PI' command.  Ringback now worked for all Cisco -> Nortel calls.

Abhishek Sharma Mon, 07/12/2010 - 00:55

under the outgoing voice dial-peer # pots, configure these commands: .

progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8

Actions

This Discussion