CUPS 7 Exhange 2007 calendar integration issue

Unanswered Question
Apr 15th, 2010

Hi,

I'm trying to configure calendar integration between CUPS 7 and Exchange 2007.

The status is not updated when we create a meeting.

In Presence Engine Debug, I can see:

ERROR ScalarUserForeignResource - No calendar folder found for sip:USERr@DOMAIN@calendar.DOMAIN locale -1, using default calendar

If somebody has met this issue and can help.

Thank you

Best regards

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
htluo Thu, 04/15/2010 - 11:55

It's a generic message instead of an error.

Has the Presence Engine trace level set to DEBUG?

We need the logs from the Presence Engine startup to the CUPC login.

Michael

http://htluo.blogspot.com

htluo Thu, 04/15/2010 - 12:54

The log was from 18:43:53 to 18:44:51 (less than a minute).

We need the logs from PE restart to the time CUPC login.

What time PE restarted?  What time CUPC logged in?

Thanks!

Michael

guilhem.perez Fri, 04/16/2010 - 01:02

Hi,

I've done two trace:

1) Outlook Presence Gateway is an ISA server (cas2.XXXX) : OWA is using basic authentication

2) Outlook Presence Gateway is an ISA server (mail2.XXXX) using public access (throught a Firewall): OWA is using FBA

I know I should not use OWA which is using FBA (2).

Pass throught ISA Server (CAS) is it supported (1)?

See attachments for Presence Engine logs for both case.

cas2.XXXXX
9:34 Restart Service
9:35 start CUPC
9:36 login CUPC

mail2.XXXXXXX
9:43: restart service
9:44: start/login CUPC

Thank you very much.

htluo Fri, 04/16/2010 - 05:24

FBA is not a problem.  CUPS supports FBA from long time ago.

The problem is ISA.  CUPS never worked with ISA.  It's because meeting notification was initiated from the Exchange server (mailbox server) and send to the "call-back address" that's in the SUBSCRIBE.  "call-back address" is the CUPS address, port 50020, UDP.

You should point CUPS to the OWA server directly.

Michael

guilhem.perez Fri, 04/16/2010 - 05:40

Hi,

Ok, now I'm directly connected do OWA.

I've configured Presence Gateway Outlook username with Exchange  Administrator Full Access rights for testing.

In presence Engine Log, I've got this message:

CalendarSubscription::initiateRecovery: [email protected] SUBSCRIBE 3 Authentication failure on server; Could not authenticate to server: rejected Basic challenge

ERROR Exchange Server Transaction Failed: SUBSCRIBE sip:[email protected]@cas2.itesoft.com:443 3 Authentication failure on server; Could not authenticate to server: rejected Basic challenge - clear calendar information

Thank you

htluo Fri, 04/16/2010 - 05:49

"Exchange  Administrator Full Access" doesn't mean you can read somebody else's email/calendar.

Let say, you're the Exchange administrator, would you be able to read CEO/CFO's email?  Technically, that could be done.  But not without extra configuration steps.

Those extra steps include:

1) Create an mailbox for the integration account.  (mailbox was not actually created until the account logon to Outlook or OWA).

2) Assign permission to the integration account.  (permission could take hours to populate to end user's mailbox)

3) Verify permission on integration account.

For details, you may take a look at Cisco document:

http://docwiki.cisco.com/wiki/Cisco_Unified_Presence%2C_Release_7.x_--_How_to_Configure_Cisco_Unified_Presence_for_Integration_with_Microsoft_Exchange_2007#How_to_Configure_Cisco_Unified_Presence_for_Integration_with_Microsoft_Exchange_2007

Or get a copy of "Deploying Cisco Unified Presence" from http://www.lulu.com/content/5552336.

Michael

http://htluo.blogspot.com

guilhem.perez Fri, 04/16/2010 - 09:07

Hi,

I've bought Deploying Cisco Unified Presence (it's a very good and interasting book).

I've checked step by step log presence message :

Startup OK
Initial attempt OK
Loading cert OK
No Form Base Authentication OK
Error with: initial subscription response:
04/16/2010 17:45:59.031 EPE|system.pe.pa.owa.backend 2065634 INFO received SUBSCRIBE (initial) status: 401 Unauthorized

I'm pretty sure my exchange account is right:

View Only Admin + Use Get-MailboxPermission to check FullAccess on mailbox.

Thank you

htluo Fri, 04/16/2010 - 09:14

Did you test the permission per the doc?  If yes, could you post the test result here?  The command would be like:

Get-MailboxPermission johndoe -user cupsexch | Format-Table -autosize

Where "johndoe" is the end user account, "cupsexch" is the integration account.

Thanks!

Michael

guilhem.perez Fri, 04/16/2010 - 10:38

Hi,

Yes I use:

Get-MailboxPermission mycupc user - user ExchangeViewOnlyAdminAcount | Format-Table -autosize

the result was:

AccesRights: FullAccess

IsInherited: true

Deny: False

as expected from the book.

Thank you again.

htluo Fri, 04/16/2010 - 10:41

If that's the case, try the following:

1) Go to CUPS > Presence > Gateway.  Click the Outlook gateway.

2) Change the integration account to the format of "domain\user".

3) Restart Presence Engine service.

Michael

Actions

This Discussion