IPCom7 registration failed with CUCM6

Unanswered Question
Apr 15th, 2010

Hi team,


My Cisco IPcommnicator 7 was working fine  with CUCM 6 until few days back.

The IPcom 7 registration failed with the following reason.

"File not Found: <MAC addeess>.cnf.xml"

"<MAC address>.cnf.xml"


I have disabled auto registration and tried to register it manually but didnt work.


restarted TFTP services. no joy.

possibly the above .cnf.xml file might be corrupted on CUCM 6


how can I get it working?


Thanks in advance

Sanjeev

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Aaron Harrison Fri, 04/16/2010 - 01:04

Hi


Auto registration only does something the first time a new device attempts to register.


Check your current MAC address from the Preferences/Network screen in CIPC; typically it's best to assign custom device names rather than use MAC addresses, as MAC addresses are more prone to errors and changes. You might assign (for example) your AD username or some other known ID.


Make sure you add either the current CIPC generated device name, or the custom one you specify to CCM.


Regards


Aaron

Rafael Chavantes Fri, 04/16/2010 - 09:56

Try to delete the phone from CUCM and put it again and delete the CTL file in order to force a new update.


Try this procedure:

Erasing the CTL File

If Cisco IP Communicator experiences an error with the CTL file, you can  remove it.

Procedure


Step 1 From Cisco IP Communicator, click Settings > Security Configuration > CTL File.

Step 2 Click **# to unlock  settings.

Step 3 Click Erase to  delete the CTL file from Cisco IP Communicator and restart it.


From IP Communicator Administration Guide

sanjeevreddyallala Mon, 04/19/2010 - 13:08

Hi Rafel and Aaron,

Thank you for your time.

I have tried both of the things you suggested earlier

1. Deleted phone and switched on IPCom & erased CTL file already but still end up the message

"CTL update failed" and

"TFTP time out: .cnf.xml"-------> is that means IPCom failed to recieve conf file from CUCM TFTP server.


By the way CTL service is not enabled on my CUCM.


2. I did uninstall and reinstall Cisco IPCom and tried but still the same.

IPBlue softphone worked fine but its just keep freezing seems got issues with MS Vista.


Thank you

Rafael Chavantes Mon, 04/19/2010 - 13:32

First thing enable the CTI Provider


"the Cisco CTL Provider service changes the  security mode from nonsecure to mixed mode and transports the server  certificates to the CTL file. The service then transports the CTL file  to all Cisco Unified Communications Manager and Cisco TFTP servers."


You need this service to be running. It is the one that handles the CTL transporting


Let us know if it works

Aaron Harrison Mon, 04/19/2010 - 13:40

Hi


If you aren't running a secure cluster (i.e. encrypted RTP etc) you don't need the CTL Provider.


What I would do is this:


1) Go to the CCMAdmin pages, and find your CIPC. Copy the device name.

2) Try this from your PC:


Tftp get sepxxxx.cnf.xml


(Inserting your CM IP, and the copied device name from the CCMAdmin pages)

e.g.


tftp 10.10.0.1 get SEP0012ABCDABCD.cnf.xml


See whether it finds the file...


Aaron

Actions

This Discussion