Idle URL for 7960 / 7940 using CallManager 4.2(3)

Unanswered Question
Apr 15th, 2010

I have installed the Cisco IP Phone SDK on an external Web Server (IP= and am looking just to get the Sample logo to display.  When I point the phone to Idle URL - it will not pull up anything with the Timer set at 1.  I created a phone service just for grins and when I access that I get an HTTP Error 500.  If I plug in the URL into a browser on my PC I get:

msxml3.dll error '800c000e'

A security problem occurred.

/CiscoIPServices/includes/getdeviceip.asp, line 22

Can anyone please help with clearing this issue?

Also, once I get the Sample to load, what parameters of the idleurl.asp need to be updated to display the "real" image that I have?

Thanks in Advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
gogasca Wed, 04/21/2010 - 17:18
I tested the picture and converted to Grayscale and it is working fine.

Here I am listing you the instructions and also attaching you the file that you can follow
to set this on a particular phone.

>> Copy or save the file in attachment, new.gif in c:\CiscoIPservices\tools
>> You can run in command prompt
  1.. From the command prompt, issue the cd CiscoIpServices\tools command.

  2.. Issue the gif2cip new.gif new.xml command

Be sure to change the name of the file to .xml when you are launching the
gif2cip utility.  Instead of having a .cip intermediate filename, use the
.xml extension with the gif2cip command:

gif2cip logo2.gif logo2.xml

save it in C:\CiscoWebs\IPPhoneServices\CCMCIP folder on the Publisher.

>> Now, on Phone configuration page

under idle >> http://IP_address_of_CallManager/CCMCIP/new.xml

Idle timer >> 5

>> Reset the phone

* Creating Idle URL Using Graphics on Cisco IP Phone

Please take a look at this link too:
* Idle URL Logo Does Not Display on the Cisco 7960/7940 IP Phone LCD

Kevin Porter Thu, 04/22/2010 - 06:55

Thanks much for your reply.  I did get the URL to finally launch...It was the Connection protocol to CallManager that had it snafu'd.  We had turned off HTTPS access a while ago and the default protocol on the .asp page is HTTPS.  Change it to HTTP and it launched.  Everything else is pretty straight forward and the display doesn't look to bad using the default Cisco layout where it scrapes the DN's off the Phone configuration page and adds themm to the Image...Just keep in mind that you need to create a seperate .asp page for each possible phone button template applied to the device so that the appropriate number of DN's get populated.  This will require that the Idle URL entry be specific per device, per phone button template...


This Discussion