12.4.24T loses T.38 MGCP configuration

Answered Question
Apr 15th, 2010

I've now experienced this issue with 12.4.24T and 12.4.24T3 on multiple Cisco 2811's.  We configure the following MGCP like this:

mgcp
mgcp call-agent 10.10.10.10 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode nse
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
mgcp default-package fxr-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 ecm
mgcp fax t38 ls_redundancy 2
mgcp fax t38 hs_redundancy 2
mgcp fax-relay ans-disable
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface Vlan2
mgcp bind media source-interface Vlan2

After a reboot, T.38 is always disabled:

mgcp
mgcp call-agent 10.10.10.10 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode nse
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
mgcp default-package mt-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 ecm
mgcp fax t38 inhibit
mgcp fax t38 ls_redundancy 2
mgcp fax t38 hs_redundancy 2
mgcp fax-relay ans-disable
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface Vlan2
mgcp bind media source-interface Vlan2

Any idea how to fix this and keep T.38 enabled across reloads?  Is this a bug?

I have this problem too.
0 votes
Correct Answer by rob.huffman about 5 years 3 months ago

Ho Jordan,

I think you are hitting this bug;

CSCta26864            Bug Details

MGCP fax T38 inhibit and ecm configured upon reload

Symptom:

On a Cisco MGCP gateway registered to  Cisco Unified Callmanager server, running
IOS 124-24T we have enabled  T38. But after a reload following
command lines are seen in the  configuration and all T38 faxes fail:

mgcp fax t38 ecm
mgcp  fax t38 inhibit

Conditions:

Specific to  MGCP T38 fax. The command "ccm-manager config" needs to be
enabled  to cause this issue.

Debug capture during boot up will show:
000386:  Jun 18 21:58:06.588: cmapp_xml_cfg_router: configuring
[mgcp fax  t38 inhibit]


Workaround:

This issue is not  seen in Cisco IOS images 124-15T9 and 124-20T3.

You can also  manually configure this after the reload:
mgcp default-package  fxr-package (if need be)
no mgcp fax t38 inhibit
no mgcp fax t38  ecm

and then reset the gateway from the Callmanager

Status
Fixed             

Severity        
3 - moderate


Last Modified
In Last 2 weeks        

Product
Cisco IOS software         

Technology


1st Found-In
12.4(24)T
12.4(24.6)T9       
      Known Affected Versions This link will launch a new window.

     
Fixed-In
12.4(24)MD
12.4(24)T2
15.1(0.7)T
15.1(0.2)PI12f
15.0(1)M0.5
15.1(24.6.12)PIL13
12.4(22)T4
15.1(1)XB
15.1(0.2.7)PIB13
15.1(1.5.1)PIA13
15.1(0.0.10)PIL14

Cheers!

Rob

Please support CSC Helps Haiti

https://supportforums.cisco.com/docs/DOC-8895

https://supportforums.cisco.com/docs/DOC-8727

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Correct Answer
rob.huffman Fri, 04/16/2010 - 07:49

Ho Jordan,

I think you are hitting this bug;

CSCta26864            Bug Details

MGCP fax T38 inhibit and ecm configured upon reload

Symptom:

On a Cisco MGCP gateway registered to  Cisco Unified Callmanager server, running
IOS 124-24T we have enabled  T38. But after a reload following
command lines are seen in the  configuration and all T38 faxes fail:

mgcp fax t38 ecm
mgcp  fax t38 inhibit

Conditions:

Specific to  MGCP T38 fax. The command "ccm-manager config" needs to be
enabled  to cause this issue.

Debug capture during boot up will show:
000386:  Jun 18 21:58:06.588: cmapp_xml_cfg_router: configuring
[mgcp fax  t38 inhibit]


Workaround:

This issue is not  seen in Cisco IOS images 124-15T9 and 124-20T3.

You can also  manually configure this after the reload:
mgcp default-package  fxr-package (if need be)
no mgcp fax t38 inhibit
no mgcp fax t38  ecm

and then reset the gateway from the Callmanager

Status
Fixed             

Severity        
3 - moderate


Last Modified
In Last 2 weeks        

Product
Cisco IOS software         

Technology


1st Found-In
12.4(24)T
12.4(24.6)T9       
      Known Affected Versions This link will launch a new window.

     
Fixed-In
12.4(24)MD
12.4(24)T2
15.1(0.7)T
15.1(0.2)PI12f
15.0(1)M0.5
15.1(24.6.12)PIL13
12.4(22)T4
15.1(1)XB
15.1(0.2.7)PIB13
15.1(1.5.1)PIA13
15.1(0.0.10)PIL14

Cheers!

Rob

Please support CSC Helps Haiti

https://supportforums.cisco.com/docs/DOC-8895

https://supportforums.cisco.com/docs/DOC-8727

Yorick Petey Thu, 09/01/2011 - 10:04

Hi,

I have the exact same problem with 2900 and 3900 using 15.1(3)T, 15.1(3)T2 and 15.1(4)M1 releases.

I use "ccm-manager config" to download the MGCP configuration from CUCM 6.1.5 and each time I reload or a enter "no ccm config, ccm config" to force the download, all the mgcp config is reset to default.

Before the reload:

mgcp call-agent XXXXXXXXXXXXX service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

mgcp default-package fxr-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax rate 14400

mgcp fax t38 nsf 000000

no mgcp fax-relay sg3-to-g3

mgcp rtp payload-type g726r16 static

After the reload:

mgcp call-agent XXXXXXXXXXXXX service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

mgcp default-package mt-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax rate 14400

mgcp fax t38 inhibit

mgcp fax t38 nsf 000000

no mgcp fax-relay sg3-to-g3

mgcp rtp payload-type g726r16 static

The problem is that I use now 2900 and 3900 ISR G2 routers, and the version 15.x is the minimum.

For the other routers (~10) I dont have problem because I use the 12.4(20)T3 and the config is well saved.

I will try older IOS versions but I would appreciate if someone can advice me directly.

Thank you for your help.

Yorick

rob.huffman Thu, 09/01/2011 - 10:38

Hi Yorick,

Did you try 15.1(1)XB?

Fixed-In

Fixed-in

12.4(24)MD

12.4(24)T2

15.1(0.7)T

15.1(0.2)PI12f

15.0(1)M0.5

15.1(24.6.12)PIL13

12.4(22)T4

15.1(1)XB

15.1(0.2.7)PIB13

15.1(1.5.1)PIA13

15.1(0.0.10)PIL14

15.1(1.7.1)PIA14

12.4(24)GC2

12.4(22)MDA4

12.4(24)MDA1

15.1(0.0.3)PIL15

Cheers!

Rob

Yorick Petey Thu, 09/01/2011 - 11:05

Hi Rob,

Unfortunately, I cannot find it in the Download center.

I can only access to 15S, 15M, 15T and Special and Early, but no one contains a XB release .

Do you think I have to open a case to get it?

I am afraid now because I am pretty sure I have several customers with ISR G2, configured for T.38 on C2900 and C3900. If they reload the routers, no more faxes...

How is it possible a so severe problem is present in so many versions?

Maybe it is related to the version of our CUCM as well (6.1.5)?

I will do some tests tomorrow morning in a customer site owning a 2911 and using T.38 with CUCM 7.1.5.

Thank you for your help.

Yorick

rob.huffman Thu, 09/01/2011 - 11:34

Hi Yorick,

I think a TAC case is an excellent idea. I'm guessing they can find a more current

IOS version that contains the fix for this and set it up for you as a special

download. You should not have to deal with this issue every time the router re-loads.

Cheers!

Rob

Yorick Petey Tue, 09/06/2011 - 00:54

Hi Rob,

For your information, a case is opened to troubleshoot this problem, I still don't get a satisfying answer but in the sametime I compared the same test with different CUCM version.

It seems that the problem only occurs with CUCM 6.1.x. I think it's because the CUCM 7.x and 8.x contain more MGCP parameters (t.38 package, and so on). MGCP config from CUCM webpages is very (too) basic in 6.x and I think in IOS 15.x some parameters are defaulting to a certain value when the parameter does not come populated from the CUCM.

I will post the update as soon as it will be resolved.

Yorick

steve_mils Fri, 07/20/2012 - 01:15

We've suffered with this problem for a number of years, across 2800s & 2900s; both CUCM versions 6 & 7; a range of IOS versions including 12.4T, 15.1 and 15.2.

Our latest incarnation is a 2951 running 15.2(3)T and CUCM 7.1.5.

It's sad to think that it's never been adequately solved!

Thanks, Steve

Actions

This Discussion