RME, failed to export Detailed Device Report to CSV file

Answered Question
Apr 16th, 2010
User Badges:

Hello


I try to export a Detailed Device Report to a CSV. It failes:


<HTML><META HTTP-EQUIV="content-type" CONTENT="text/html;charset=utf-8">

<H1>HTTP Status 500 - </H1>
<HR SIZE=1 noShade>

<P><B>type</B> Exception report</P>
<P><B>message</B> <U></U></P>
<P><B>description</B> <U>The server encountered an internal error () that
prevented it from fulfilling this request.</U></P>
<P><B>exception</B> <PRE>java.lang.NullPointerException
com.cisco.nm.rmeng.inventory.reports.ui.action.InventoryReportsAction.perform(InventoryReportsAction.java:685)
org.apache.struts.action.ActionServlet.processActionPerform(ActionServlet.java:1786)
org.apache.struts.action.ActionServlet.process(ActionServlet.java:1585)
org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:509)
javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
com.cisco.nm.cmf.util.AccessLogFilter.doFilter(AccessLogFilter.java:128)
</PRE>
<P></P>
<P><B>note</B> <U>The full stack trace of the root cause is available in the
Apache Tomcat/5.5.17 logs.</U></P>
<HR SIZE=1 noShade>

<H3>Apache Tomcat/5.5.17</H3>


Exporting to PDF works OK.


CW is running on Windows server. RME is 4.3.1


Can anyone help?

Correct Answer by Joe Clarke about 7 years 1 week ago

IE 8.0 is not yet a supported browser.  Try with IE 7.0 or Firefox 3.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Joe Clarke Fri, 04/16/2010 - 23:42
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This could be a problem with your JSP cache.  Shutdown Daemon Manager, then delete all files and directories under NMSROOT/MDC/tomcat/work/Standalone/localhost.  Then restart Daemon Manager, and see if the problem persists.


--


Please support CSC Helps Haiti


https://supportforums.cisco.com/docs/DOC-8895

https://supportforums.cisco.com

Eydfinnur Mortensen Mon, 04/19/2010 - 00:00
User Badges:

Thanks for the answer.

I did what you suggested, but unfortunately I got the same error again.  :-(

Joe Clarke Mon, 04/19/2010 - 00:11
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

There is a potential bug in the code in this area, but I cannot reproduce the problem.  How many devices are you exporting?  What type of devices are they?

Eydfinnur Mortensen Mon, 04/19/2010 - 00:19
User Badges:

It's only one device.

Here's from Show version:

Cisco IOS Software, Catalyst 4500 L3 Switch Software (cat4500e-IPBASEK9-M), Version 12.2(53)SG1, RELEASE SOFTWARE (fc1)

cisco WS-C4510R-E (MPC8548) processor (revision 6) with 524288K bytes of memory.


For a test I tried with a WS-C2960-8TC-L and it gave same result.

Joe Clarke Mon, 04/19/2010 - 00:25
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

What browser and version are you using?

Eydfinnur Mortensen Mon, 04/19/2010 - 00:42
User Badges:

Internet Explorer 8


Version 8.0.6001.18702
Krypt. 128-bit


I've just tried to install Firefox 3.6 on the server. With this it works OK.


Problem is, I cant install it on my worstation. Company restrictions.

Correct Answer
Joe Clarke Mon, 04/19/2010 - 08:23
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

IE 8.0 is not yet a supported browser.  Try with IE 7.0 or Firefox 3.

Eydfinnur Mortensen Mon, 04/19/2010 - 23:30
User Badges:

Thank you for the answer. I must see what my IT-department can come up with.


Just tried another IE:

I have the possibility to log in to Cisco Works via Citrix. Here is IE version 7.0.5730.13 used to open Cisco Works.
It gives the same error.

Fabrizio De Carlo Sat, 07/02/2011 - 07:01
User Badges:

Hi community,

I have Ciscoworks LMS 4.0.1 and I have the same problem.

According the documentation IE 8 is supported.

(http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_lan_management_solution/4.0/install/guide/instl.html#wp1585158)


Is there another issue then. Can you help to resolve the exception for CSV export? Is there a log for apache or tomcat to see?



thank you

Fabrizio

Joe Clarke Sat, 07/02/2011 - 13:52
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please start a new thread for your issue.

Mehdi Talei Wed, 04/08/2015 - 12:34
User Badges:

This solution worked for me on LMS 4.2.3

 

You rock Joseph Clarke :-) Thanks for the post...

Actions

This Discussion