IGMP/Multicast on L2 VLAN on 6500 vs unmanaged switch

Answered Question
Apr 16th, 2010

I have a dumb (unmanaged 8-port Linksys Gig switch) which we are currently using for some linux clustering servers. It works fine, but I want to move the servers to our 6500.  When I moved them from the switch to our 6500, the cluster breaks because multicast isn't working in the same way as it is on the unmanaged switch.  Each server has 3 NIC interfaces, (Production network routed, iSCSI private, and metadata (multicast) private) so one physical port is residing on it's own VLAN. All server interfaces are static IP assignments. The other 2 VLANs are working properly, the metadata VLAN seemingly is breaking the cluster because they can't communicate via multicast. Vlan 999 is for the clustering metadata, and is defined as a VLAN.

I had defined vlan 999 as a SVI with no ip address and enabling pim sparse-dense-mode, but that didn't work for the servers either.

I would appreciate any help in getting the member ports of that vlan to act like the dumb switch the servers are now on. The multicast traffic needs to stay isolated (like it is on the separate switch).  All the vlan ports are on the same line card.

Global Config:

ip multicast-routing

Vlan config:

vlan 999

name Data_iSCSI_Metadata

!

port config:

interface GigabitEthernet4/33

switchport

switchport access vlan 999

spanning-tree portfast

!

I have this problem too.
0 votes
Correct Answer by Jon Marshall about 6 years 7 months ago

Okay, looks like the command is not available on your switch. Apologies for that.

You are correct, with a 6500 running SXH you should turn off IGMP snooping under the vlan interface. So you could do one of 2 things -

create a L3 vlan interface for 999 and then

1) turn off IGMP snooping under the interface in which case the multicast traffic should be flooded to all ports in that vlan

or

2) configure the IGMP snooping querier function for that vlan so that only the ports that want the multicast traffic get it

Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jon Marshall Fri, 04/16/2010 - 07:42

dklusmann wrote:

I had defined vlan 999 as a SVI with no ip address and enabling pim sparse-dense-mode, but that didn't work for the servers either.

I would appreciate any help in getting the member ports of that vlan to act like the dumb switch the servers are now on. The multicast traffic needs to stay isolated (like it is on the separate switch).  All the vlan ports are on the same line card.

Global Config:

ip multicast-routing

Vlan config:

vlan 999

name Data_iSCSI_Metadata

!

port config:

interface GigabitEthernet4/33

switchport

switchport access vlan 999

spanning-tree portfast

!

try adding this in your config -

no igmp snooping vlan 999

Jon

dklusmann Fri, 04/16/2010 - 08:18

Thank you.  Isn't that command only available for a SVI? (no ip igmp snooping)

I don't mind defining an interface vlan for use of the command, but want to make sure I actually need to do so.

Does multicast not work in a plain old vlan, but does work in an interface vlan?

Jon Marshall Fri, 04/16/2010 - 08:57

dklusmann wrote:

Thank you.  Isn't that command only available for a SVI? (no ip igmp snooping)

I don't mind defining an interface vlan for use of the command, but want to make sure I actually need to do so.

Does multicast not work in a plain old vlan, but does work in an interface vlan?

The command is available for the vlan ie. you simply use the vlan id you don't want IGMP snooping on -

http://www.cisco.com/en/US/docs/ios/ipmulti/command/reference/imc_02.html#wp1046498

I thought you wanted to make the vlan act as a dumb switch ie. in effect turn off multicast for vlan 999 ?

Jon

dklusmann Fri, 04/16/2010 - 09:21

I don't think I want to turn off multicast, I guess it is needed for the cluster members to talk to each other.

But that's what I don't understand regarding our current setup.  Everything is working using a dedicated Linksys/Cisco SD2008 (unmanaged switch) for those 3 servers, and the cluster is functional/working, etc. but is hardly scalable for a virtualization environment.

I want the ports/vlan on the switch to be essentially configured the same as the dumb switch, since it's working as expected in that configuration it should be easy to configure it on the 6509.

WS-C6509-E running 12.2(33)SXH

When I enter the command on the switch for the ports (not the vlan) it drops me out of the interface to the config prompt.

Core_6509E(config)#int gi4/33

Core_6509E(config-if)#no ip igmp snooping vlan 999

                                               ^

% Invalid input detected at '^' marker.

Core_6509E(config-if)#no ip igmp snooping

Core_6509E(config)#

Core_6509E(config)#vlan 999

Core_6509E(config-vlan)#no ip igmp snooping vlan 999

                                         ^

% Invalid input detected at '^' marker.

Core_6509E(config-vlan)#exit

Core_6509E(config)#no ip igmp snooping vlan 999

                                                            ^

% Invalid input detected at '^' marker.

Core_6509E(config)#exit

Core_6509E#no ip igmp snooping vlan 999

                           ^

% Invalid input detected at '^' marker.

Core_6509E#

Is this expected?

Giuseppe Larosa Fri, 04/16/2010 - 09:42

Hello DKlusman,

the command has to be given under the SVI L3 interface

interface vlan 999

no ip igmp snooping

see

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SXF/native/configuration/guide/snooigmp.html#wp1027812

you should consider the use of IGMP snooping querier instead that allows to use IGMP snooping forwarding optimization features

but the SVI will need an ip address to be used as source for the IGMP queries

Router# interface vlan 200 
Router(config-if)# ip address 172.20.52.106 255.255.255.248
Router(config-if)# igmp snooping querier 

Correct Answer
Jon Marshall Fri, 04/16/2010 - 09:42

Okay, looks like the command is not available on your switch. Apologies for that.

You are correct, with a 6500 running SXH you should turn off IGMP snooping under the vlan interface. So you could do one of 2 things -

create a L3 vlan interface for 999 and then

1) turn off IGMP snooping under the interface in which case the multicast traffic should be flooded to all ports in that vlan

or

2) configure the IGMP snooping querier function for that vlan so that only the ports that want the multicast traffic get it

Jon

dklusmann Fri, 04/16/2010 - 16:15

Thank you.

Turning IGMP snooping off was the key.

Interface Vlan 999

no ip address

ip pim sparse-dense-mode

no ip igmp snooping

end

This works.

Actions

This Discussion