Sub-Interfaces - not working

Unanswered Question
Apr 16th, 2010
User Badges:

MY requirement is to terminated Two service provider on the same router and same interface.

Router is 2801 with two FE ports.

Two Service provider links are terminated on 2960 Switch, trunk is configured between switch and Router.


Interface fa 0/0

description " Goes to LAN"

ip address 192.168.1.253 255.2555.255.0


Interface fa 0/1

no shutdown


Interface fa 0/1.10

description " SP1"

encap dot1q 10

ip address 196.8.2xx.x 255.255.255.248


Interface fa 0/1.11

description " SP2"

encap dot1q 11

ip address 198.102.x.x 255.255.255.240


Interface fa 0/1.15

description "Connected to Switch"

encap dot1q 15

ip address 10.1.1.100 255.255.255.0


ip route 0.0.0.0 0.0.0.0 10.1.1.253   


The above configuration dont work on sub-interface with Two Service-provider

If I configure only SP1 on interface fa 0/1 it works

If I configure only SP2 on interface fa 0/1 it works

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
harisivaji Fri, 04/16/2010 - 07:39
User Badges:

Hi,


Are you terminating SP connections to Switch ?


We need to terminate SP to router and switch is for LAN. Can you shed more info on this.



Thanks,

Hari

mathews.cisco Fri, 04/16/2010 - 07:43
User Badges:

I mean physical connection of two SP on switch only

How would you connect  two SP on single interface of router.

Jon Marshall Fri, 04/16/2010 - 07:46
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Are the ISP links vlan 10 & vlan 11 ?


What is vlan 15 used for ?


What is the native vlan on the switch ?


Jon

mathews.cisco Fri, 04/16/2010 - 08:15
User Badges:

Vlan 10 & Vlan 11 are for ISP

VLAN 15 to manage switch on which ISP connection is terminated

VLAN 100 is native


Switch port configuration connecting to Router.


interface FastEthernet0/1
switchport trunk native vlan 100
switchport trunk allowed vlan 7-13
switchport mode trunk
spanning-tree portfast



I added on the router2801


interface GigabitEthernet0/1.100
encapsulation dot1Q 100 native


but this doesnt seems to work as well.

harisivaji Fri, 04/16/2010 - 08:36
User Badges:

Ok,


I got it now. The problem seems to be due to native vlan.

In your switch Trunk try configuring Allowed vlan including 100 and rest of the vlan in it

mathews.cisco Fri, 04/16/2010 - 08:41
User Badges:

native vlan is already configured but not working


SW configuration


interface  FastEthernet0/1
switchport trunk native vlan 100
switchport  trunk allowed vlan 7-13
switchport mode trunk
spanning-tree  portfast

harisivaji Fri, 04/16/2010 - 08:49
User Badges:

Is it correct?

earlier you mentioned FE and now GE


also


can u test using extended ping ie, specify the source ip address

from the router and check whether you are able to reach all the network vlan

bapatsubodh Fri, 04/16/2010 - 08:58
User Badges:

Hi,

1. Try removing port-fast on the trunk port.

2. Try removing any native VLAN see if you can ping to both ISP side IP address with corresponding source IP address, if that works problem is most likely on the router configuration like default route or routing protocol.

3. Also check  correct VLAN membership of the ports where you are connecting the ISP side cables. Those  shoud be in correct VLAN.

Hope this helps.

Thanks

Subodh

Jon Marshall Fri, 04/16/2010 - 08:53
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Well your config is fine.


ip route 0.0.0.0 0.0.0.0 10.1.1.253   


what is the above route ie. that seems to be on vlan 15 which is just a management vlan isn't it.


Presumably you have assigned the switchports on the switch into the correct vlans ie. vlan 10 & 11 ?


How are you confirming it isn't working ?


Jon

mathews.cisco Fri, 04/16/2010 - 13:12
User Badges:

VLAN 15 is management Vlan, this is to ensure I can reach switch from the router.


How are you confirming it isn't working  ::::  pinging service provider router (next-hop) with source address doesnt ping,


I was worrying on the configuration, if thats incorrect, jon you reply made me smile

On Cisco Website I couldnt find similar scenario or sample configuration

Actions

This Discussion