IP Secondary

Answered Question
Apr 17th, 2010
User Badges:

Hi all,


how can i reach R1?  I can see the route in the table routing  but i can't access by telnet and not respond to ping from R2 and R3.I think i don't understand the secondary address feature. Someonte to help me?


This is mi configuration on R2:


interface FastEthernet0/0
ip address 192.168.0.2 255.255.255.128 secondary
ip address 192.168.1.30 255.255.255.0
ip virtual-reassembly
duplex half
speed auto
!

interface GigabitEthernet1/0
ip address 213.190.2.182 255.255.255.0
ip virtual-reassembly
negotiation auto

!

no ip classless
ip route 192.168.0.0 255.255.255.128 FastEthernet0/0

Attachment: 
Correct Answer by Giuseppe Larosa about 7 years 1 month ago

Hello Juan,

in addition to good note from Reza I would suggest to use extended ping in order to be able to specify the source address for the ping attempts.


When you ping an ip address on a LAN interface on local router the packet doesn't go out on the wire.


When you attempt to ping R1 ip address R2 should use its secondary address as source but to be sure it is better to use the extended ping


Hope to help

Giuseppe

Correct Answer by Reza Sharifi about 7 years 1 month ago

Hi Juan,


I do not understand what the secondary interface is for.  You have 3 routers.  Router 1 physically connects to router 2 and also router 3 physically connects to router 2.

Can you post the interface config from all 3 routers for all the interfaces.  To be able to ping end-to-end, you need a static route from router 1 pointing to router 2 interface and also a static route from router 3 pointing to router 2 interface.


HTH

Reza

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
emilio1973 Sat, 04/17/2010 - 08:15
User Badges:

I don`t understand this:


R1#ping 192.168.0.2


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 104/163/216 ms



and on the otherside:


R2#ping 192.168.0.91


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.91, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)



I need help!!

Correct Answer
Reza Sharifi Sat, 04/17/2010 - 08:49
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Hi Juan,


I do not understand what the secondary interface is for.  You have 3 routers.  Router 1 physically connects to router 2 and also router 3 physically connects to router 2.

Can you post the interface config from all 3 routers for all the interfaces.  To be able to ping end-to-end, you need a static route from router 1 pointing to router 2 interface and also a static route from router 3 pointing to router 2 interface.


HTH

Reza

Correct Answer
Giuseppe Larosa Sat, 04/17/2010 - 13:39
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Juan,

in addition to good note from Reza I would suggest to use extended ping in order to be able to specify the source address for the ping attempts.


When you ping an ip address on a LAN interface on local router the packet doesn't go out on the wire.


When you attempt to ping R1 ip address R2 should use its secondary address as source but to be sure it is better to use the extended ping


Hope to help

Giuseppe

emilio1973 Sat, 04/17/2010 - 15:53
User Badges:

Hi all,


I'm sorry but I was wrong with the topology. Add the new topology and configs of the 3 routers. I need to reach R1  from anywhere using telnet, icmp, or SSH.


I got it from R2 but I can not do it from R3. Why? I do not know. I think the problem is the NAT.


I appreciate your help

Attachment: 
Reza Sharifi Sat, 04/17/2010 - 17:08
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Hi Juan,


on r3

You have an incorrect static route on r3. You have this:

ip route 192.168.1.128 255.255.255.192 213.19.2.182


Change it to this:

ip route 0.0.0.0 0.0.0.0 192 213.190.2.182




on r2

ip address 192.168.0.2 255.255.255.128 secondary
ip address 192.168.1.30 255.255.255.240


replace with

ip address 192.168.0.2 255.255.255.128


And try pinging again


HTH

Reza

Actions

This Discussion