LMS 3.2, why so many duplicate?

Unanswered Question
Michel Hegeraat Mon, 04/19/2010 - 02:56
User Badges:
  • Gold, 750 points or more

This is usually cause by the fact that DNS did not work on the first discovery, and you devices gets discovered with the IP as display name.


Next it gets discovered again, now while DNS works and for some reason the display name does not get updated but a new device with the same IP gets added to the DCR.


I'm not sure why cisco has decided for this to work this way.


I try to convince my customers to get the DNS entrys in place before device deployment.


Cheers,


Michel

Michel Hegeraat Mon, 04/19/2010 - 03:16
User Badges:
  • Gold, 750 points or more

I've only seen this where the decive initially did not resolve


If the CS discovery is always able to resolve the ip addresses then normally no new device is created.


Can you post the Discovery Settings Summary here?


Cheers,

Michel

Michel Hegeraat Mon, 04/19/2010 - 03:29
User Badges:
  • Gold, 750 points or more

So on the servers console a ping -a with the device ip, will give you the hostname?


And if you resolve the duplicate in RME, (and thus delete the device with the IP address in the display name), it comes back after the next discovery?


That is new to me. Not seen that behaviour yet.


Cheers,


michel

Michel Hegeraat Mon, 04/19/2010 - 03:31
User Badges:
  • Gold, 750 points or more

Are the devices that come back also used as seed device?


if you remove them and use DCR as seed. Do the devices still come back?


Cheers,


Michel

Michel Hegeraat Mon, 04/19/2010 - 04:16
User Badges:
  • Gold, 750 points or more

If you don't want to use discovery then disable/remove the discovery schedule.


If you want both active then best you use the "Resolve by SysName" option.


Cheers,


Michel

Michel Hegeraat Mon, 04/19/2010 - 04:08
User Badges:
  • Gold, 750 points or more

You are not using discovery? I'm not following here?


How do you add devices then? From an import file?




A IP address should resolve if you hosts file is OK


I configured a name in my hosts file ( old-vmhost ) and I can do this


I:\>ping -a 10.170.46.120


Pinging old-vmhost [10.170.46.120] with 32 bytes of data:


Reply from 10.170.46.120: bytes=32 time=3ms TTL=126
Reply from 10.170.46.120: bytes=32 time=1ms TTL=126


Ping statistics for 10.170.46.120:
    Packets: Sent = 2, Received = 2, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 3ms, Average = 2ms
Control-C
^C
I:\>ping old-vmhost


Pinging old-vmhost [10.170.46.120] with 32 bytes of data:


Reply from 10.170.46.120: bytes=32 time=2ms TTL=126
Reply from 10.170.46.120: bytes=32 time=1ms TTL=126
Reply from 10.170.46.120: bytes=32 time=1ms TTL=126


Ping statistics for 10.170.46.120:
    Packets: Sent = 3, Received = 3, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 2ms, Average = 1ms
Control-C



Check your hosts file


Cheers,


Michel

Michel Hegeraat Mon, 04/19/2010 - 04:12
User Badges:
  • Gold, 750 points or more

Try the option "Resolve by SysName" and put this name in you hosts file


Cheers


Michel

Actions

This Discussion