3750-E baud rate issue

Unanswered Question
Apr 19th, 2010
User Badges:

Hi


Having trouble resetting the baud rate to 9600 on a 3750-E.  Basically the device cannot be set to anything other than 115200 baud rate.


I have changed this via startup-config (which lost connection) reconnected and saved config but after reload was back to 115200.


Tried via bootloader to 'set 9600' but the termial program paused for a bit then the switch prompt returned.


Tried the same to 'unset baud' but the same thing as above happened.


I have erased and reloaded flash etc but this does not help.


all other operations are ok


Any ideas??

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
fabian-idrissi Tue, 04/20/2010 - 07:36
User Badges:

Hi Shailesh


Thanks for your reply.


I can configure an IP address on the switch manually - but generally I don't go through Express Setup to do this.  Do you suggest I should start again and go thorugh Express Setup ?


We need to use the standard baud rate throughout the organisation.  Plus, not being able to set it permanently may indicate further issues.


Regards


Fabian

shailesh.h Wed, 04/21/2010 - 06:05
User Badges:
  • Bronze, 100 points or more

I would suggest you to go ahead with express setting and setup router to the configuration you want. Once you have visibility then check the hardware, version and go for specific commands to set the console speed.


Usually console port speed is 9600 BAUD and to access through any terminal emulation program. Once you are in the router config you have good flexibility to analyse and set configuration to your wish

fabian-idrissi Thu, 04/22/2010 - 01:08
User Badges:

Thanks again, but this didn't work.


Setting the line console speed via 'bootloader' or 'express setup' or 'running/startup-config' does not hold the setting upon reloading.


Are there any other options to try or should the device be declared faulty?


Regards


Fabian

shailesh.h Fri, 04/23/2010 - 05:44
User Badges:
  • Bronze, 100 points or more

Startup config should retain even after re-loading the router. If it's not happening then certain

ly you treat the equipment as fault and ask for replacement.


But usually this fault is very rare.


With regards,


Shailesh

CSCO10704818 Wed, 03/28/2012 - 20:27
User Badges:

I had and fixed the same Issue, it seems setting the baud rate in rommon does not work with "SET BAUD 9600", but instead configured under line con 0


After a reload, the switch returned to a baud rate of 115200


Switch#show run | beg line con 0 

line con 0

speed 115200

line vty 0 4

login

line vty 5 15

login

!

end


The change below, persisted the configuration through reloads.   The "feature" will need to be remembered, so keep it in mind if the equipment is repurposed and you write erase the startup-config



Switch#config t

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#line con

Switch(config)#line console 0

Switch(config-line)#speed 9600

Switch(config-line)#end

Switch#wr mem

Building configuration...

[OK]

Switch#reload

dennishyde Wed, 03/13/2013 - 09:45
User Badges:

I know this is a little old but just went through some of the same scenarios.


I have a 3750G with the same problem.  I had sped up one last week to 115200 to copy over a *.bin and then set it back to 9600 with no problems.


Today I found a switch in our spares that is set to 115200.  I tried to change the speed at the Console port and after reboot found it went back to 115200.


So, I tried what BlackHawk08 suggested, in another post, by going into ROMMON by holding down the mode button during boot.  The set BAUD 9600 did not work.  But the unset BAUD did work.  I then did flash_init waited and then type boot and waited.  The switch rebooted and came up at 9600.  I then did a show run and the Console port is no longer at 115200. 


So, I've been able to change the speed on a switch to copy the IOS over and set back successfully and fix a switch that had been changed to 115200.


Dennis

Actions

This Discussion

Related Content