UC520 Wireless Access

Unanswered Question
Apr 19th, 2010

Hi There,

We have got number of                          UC520-8U-FXO/BRI, Cisco   Aironet 1252, Cisco Unified Wireless IP Phone 7921G, Linksys WRT 300N, CCA v 2.1.

Coulld anyone please tell me-- is this combination okay to connect 7921 phones to each other.

In our UC520 I don't see any built in wireless AP.

I am really interested to see the two Unified Wireless IP Phones are talking to each other. If this collection not enough, can you please tell me why and what I should get to make my aim successful.

Thanks in advance.

Mohammad Hassan

RMIT University

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
aaronc123 Tue, 04/20/2010 - 08:18

You'll need to configure those AP's by hand; CCA wont do it for you  ... but what you have should work.

UC500 -> tunk port -> AP 1252 (Map voice VLAN to Phone SSID) -> SSID -> WiFi Phone

rono711 Tue, 04/27/2010 - 04:58

Hi Aaron,

Bit late though!

THNAKS for your suggestion.

I have tried that.

I connected f 0/1/7 of my UC520 to my Aeronet 1252 Gigabit Etrhernt 0.

My configuartion in aeronet was as follows-

configure terminal
interface dot11radio 0
ssid batman
vlan 1
authentication open
exit
interface GigabitEthernet0.1
encapsulation dot1Q 1 native
exit
interface Dot11Radio 0.1
encapsulation dot1Q 1 native
exit

interface dot11radio 0
ssid uc
vlan 100
authentication open
exit
interface GigabitEthernet0.100
encapsulation dot1Q 100
bridge-group 100
exit
interface Dot11Radio 0.100
encapsulation dot1Q 100
bridge-group 100
exit

I used ssid Batman for data network and ssid uc for voice.

I haven't configured anything in uc520.

I made areonet dynamic ip enabled. I got this output in aeronet-

ap#sh ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
BVI1                       192.168.10.14   YES DHCP   up                    up
Dot11Radio0                unassigned      YES unset  up                    up
Dot11Radio0.1              unassigned      YES unset  up                    up
Dot11Radio0.100            unassigned      YES unset  up                    up
Dot11Radio1                unassigned      YES unset  administratively down down
GigabitEthernet0           unassigned      YES other  up                    up
GigabitEthernet0.1         unassigned      YES unset  up                    up
GigabitEthernet0.100       unassigned      YES unset  up                    up

In my windows xp machine I saw CIPC 7.0.2 had a phone number (207) that it recevied wirelessly and communicated succesdfullyone with my 7960 IP phone (204) which is connected with UC520 f0/1/6.

However, my problem was while I tried to connect wireless 7921 phone with ssid: uc, security: open, dhcp enabled with all other default setting I found Connection failed.

I would highly grateful if you or anyone can tell me what my problem was and why I could not connect 7921 to aeronet and thereby could not communicate with winxp cipc wirelessly.

Please help.

Kind regards,

Mohammad Hassan

aaronc123 Tue, 04/27/2010 - 09:27

What is your UC config for f0/1/7 ? Is it a trunk?

Also, try to connect the PC to the UC SSID ... you should be able to connect and get an IP.

If you still are not connecting ... look at the security configuration of the AP for Auth and Encryption.

rono711 Sat, 05/01/2010 - 01:30

Hi Aaron,

Mu UC config is as below-

interface FastEthernet0/1/7
switchport mode trunk
switchport voice vlan 100
macro description cisco-phone

!
interface FastEthernet0/1/8
switchport mode trunk
macro description cisco-switch
!
interface Vlan1
description $FW_INSIDE$
ip address 192.168.10.1 255.255.255.0
ip access-group 102 in
ip nat inside
ip virtual-reassembly
!
interface Vlan100
description $FW_INSIDE$
ip address 10.1.1.1 255.255.255.0
ip access-group 103 in
ip nat inside
ip virtual-reassembly
!
ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0
!
ip http server
ip http authentication local
ip http secure-server
ip http path flash:
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.1.1.0 0.0.0.255
access-list 1 permit 192.168.10.0 0.0.0.255

access-list 1 permit 10.1.10.0 0.0.0.3

access-list 100 remark auto generated by SDM firewall configuration

Rgds,

Mohammad

aaronc123 Mon, 05/03/2010 - 19:10

Sorry for the delay ....  I would look at that ethernet port. Use CCA to set it to be an AP port. I don't like the switch port mode trunck and voice on the same port ... It should just be a trunk port from what I can remember.

rono711 Tue, 05/04/2010 - 15:20

Aaron,

I now can communicate between two wireless PC software phones (CIPC 7.0.2) without any problem. These are on two different SSIDs i.e batman (data) & uc (voice) . These phones also can communicate the wired 7960 phone connected with UC520. However when we try to connect wireless 7921 with DHCP enabled, authentication open & proper SSID name (uc) it shows me coonection failed.

I checked 7921 configuration guide it suggestes that if DHCP is enabled then it should get the IP from DHCP sever i.e my UC520. It also tells the AP (Aeronet 1252) should be in autonomous mode. I don't know how to make it autonoumous mode. Can you please help?

I am having an impression UC520 configuration is good as it serves the other wireless devices.

May be something I am missing in 7921.

What other things I need to look at....

Help is really required.

Thanks.

Rgds,

Mohammad

Actions

This Discussion