Losing leading digit

Answered Question
Apr 19th, 2010

Hi All,

I've got a route pattern 1.04XXXXXXX which whenever a call uses this pattern it drops the 1. The discard digits choice is <None>

I have no idea where my 1 is going. It is set up just the same as one that keeps the 1. It did have the discard predot when I first put it in, but I have deleted the pattern and re-added it without ever turning on the discard predot. Could it still be 'remembering' and dropping the 1 because of that?

anyway, at a loss for ideas, so anything is appriciated.

Thanks in advance,

Here is the dialed number analyzer:

Results Summary
Calling Party Information
Calling Party = 7418
Partition =
Device CSS =
Line CSS = International_HM
AAR Group Name =
AARCSS =
Dialed Digits = 1041234567
Match Result = RouteThisPattern
Matched Pattern Information
Pattern = 1.04XXXXXXX
Partition = National_HM
Time Schedule =
Called Party Number = 041234567
Time Zone = (GMT+12:00) Wellington, Auckland
End Device = RL_HM
Call Classification = OffNet
InterDigit Timeout = NO
Allow Device Override = Disabled
Outside Dial Tone = NO
Call Flow
Route Pattern :Pattern= 1.04XXXXXXX
Positional Match List = 041234567
DialPlan = North American Numbering Plan
Route Filter
Filter Name =
Filter Clause =
Require Forced Authorization Code = No
Authorization Level = 0
Require Client Matter Code = No
Call Classification = OffNet
PreTransform Calling Party Number = 7418
PreTransform Called Party Number = 1041234567
Calling Party Transformations
External Phone Number Mask = YES
Calling Party Mask =
Prefix =
CallingLineId Presentation = Default
CallingName Presentation = Default
Calling Party Number = 7418
ConnectedParty Transformations
ConnectedLineId Presentation = Default
ConnectedName Presentation = Default
Called Party Transformations
Called Party Mask =
Discard Digits Instruction =
Prefix =
Called Number = 041234567
Route List :Route List Name= RL_HM
RouteGroup :RouteGroup Name= RG_HM
PreTransform Calling Party Number = 7418
PreTransform Called Party Number = 1041234567
Calling Party Transformations
External Phone Number Mask = On
Calling Party Mask =
Prefix =
Calling Party Number = 7418
Called Party Transformations
Called Party Mask =
Discard Digits Instructions =
Prefix =
Called Number = 1041234567
Device :Type= H323Gateway
End Device Name = 10.15.10.250
PortNumber = 0
Device Status = Unknown
AAR Group Name =
AAR Calling Search Space =
AAR Prefix Digits =
Inbound Fast Start = Disabled
Outbound Fast Start = Disabled
Call Classification = OffNet
Tunneled Protocol = None
Calling Party Transformations
PreTransform Calling Party Number = 7418
Calling Party Selection = Originator
Calling Party Presentation = Allowed
CallerID DN =
Calling Party Number = 7418
Alternate Matches
Note: Information Not Available

I have this problem too.
0 votes
Correct Answer by gogasca about 6 years 7 months ago

Oh ok

I would gather cucm traces to see its not a change notification problem in which DBreports certain configuration but current ccm process is using in its internal tables differnet information.

At some point there was a config in that specific route pattern that removes the digit?

You can delete pattern and see what you get now, or try to restart CCM service to re-red info from DB if config its ok.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
gogasca Mon, 04/19/2010 - 21:30

End Device = RL_HM

Do you have any digit modification at Route List level?

Check RL details

or at GW level?

DigitalCindie Mon, 04/19/2010 - 22:00

oh, forgot to mention, CCM 4.1.

I couldn't see anything that would do it, but details below:

Route List details:

Calling Party Transformations
Use Calling Party's External Phone Number Mask - On
Calling Party Transform Mask 
Prefix Digits (Outgoing Calls) 
 
Called Party Transformations
Discard Digits  < None >
Called Party Transform Mask 
Prefix Digits (Outgoing Calls )

Gateway:

Device Pool* 
Call Classification* 
Media Resource Group List 
Location 
AAR Group  < None >
Tunneled Protocol   < None >
Signaling Port*  1720
Media Termination Point Required
Retry Video Call as Audio
Wait for Far End H.245 Terminal Capability Set
Path Replacement Support 
 
Multilevel Precendence and Preemption (MLPP) Information
MLPP Domain (e.g., "0000FF") 
MLPP Indication Not available on this device
MLPP Preemption Not available on this device
   
Call Routing Information
Inbound Calls
Significant Digits*  7
Calling Search Space 
AAR Calling Search Space  < None >

Prefix DN 
Redirecting Number IE Delivery - Inbound
Enable Inbound FastStart

Outbound Calls
Calling Party Selection*
Calling Party Presentation* 
Called party IE number type unknown* 
Calling party IE number type unknown*
Called Numbering Plan* 
Calling Numbering Plan* 
Caller ID DN 
Display IE Delivery
Redirecting Number IE Delivery - Outbound
Enable Outbound FastStart

Correct Answer
gogasca Mon, 04/19/2010 - 23:35

Oh ok

I would gather cucm traces to see its not a change notification problem in which DBreports certain configuration but current ccm process is using in its internal tables differnet information.

At some point there was a config in that specific route pattern that removes the digit?

You can delete pattern and see what you get now, or try to restart CCM service to re-red info from DB if config its ok.

DigitalCindie Tue, 04/20/2010 - 15:23

Yes there was, when I first put the route pattern in, it had discard predot. I set discard to None and it still dropped it. So I deleted and recreated the route pattern and it still dropped it. I will give the box a restart tonight and let you know if that makes any difference.

Edit: I have been doing test calls, not just the number analyzer.

DigitalCindie Mon, 04/26/2010 - 18:05

Well I changed a few, and after the restart they are no longer dropping the 1 =)

Thanks for your help.

Actions

This Discussion