redistribute 0.0.0.0/0 from bgp into eigrp? - urgent

Unanswered Question
Apr 20th, 2010

hi expert

I am trying to redistribute default route into eigrp, 

router eigrp 1

redistribute static

redistribute bgp 65555 metric 1000 100 255 1 1500 route-map get-default

router bgp 65555

bgp redistribute-internal

ip prefix-list def-route swq 5 permit 0.0.0.0/0

route-map get-default permit 10

match ip address prefix-list def-route

ip route 0.0.0.0 0.0.0.0 10.1.1.1

but, when I do sh ip eigrp top 0.0.0.0

I can only see the static one , not bgp one.

Could anyone advice me what is wrong with my configuration?

Any comments will be apprecaited

Thanks in advance

julxu

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Giuseppe Larosa Tue, 04/20/2010 - 02:36

Hello Juxlu,

the static default route is the one installed in the IP routing table so you get an EIGRP route as result of redistribute static, the iBGP or eBGP default router is not eligible for redistribution

if the static route were floating like

ip route 0.0.0.0 0.0.0.0 10.1.1.1 220

the eBGP or iBGP default route would be installed in the IP routing table and then possibly redistributed into EIGRP.

This would happen if dealing with a normal route.

a specific IP subnet X is redistributed from protocol A to protocol B if :

subnet X is present in database of protocol A

subnet X is installed in IP routing table (unless it is a connected route in that case it is accepted even if appears as connected in routing table and A is a dynamic protocol)

you can also try by removing the default static route but default routes have special treatment so it is possible that redistribution of BGP default route into EIGRP doesn't work even without the static default route.

to be noted there are three ways to generate a default route in EIGRP:

- ip route 0.0.0.0 0.0.0.0 next-hop + red static into EIGRP process

- ip default-network for a different major network (A.B, C) covered by a network command in EIGRP process (the route advertisement is needed because in this case an external flag on the route is sent not prefix 0.0.0.0/0 into EIGRP domain)

and

- int type x/y

ip summary-address eigrp 0.0.0.0.0 0.0.0.0   [201]

out a specific interface (requires attention the AD parameter should be used to avoid a black hole to null0 it is 5 by default and it can create problems)

So I would say what you see is the expected behaviour.

Hope to help

Giuseppe

Actions

This Discussion