LMS 3.1 processes unable to start

Unanswered Question
Apr 20th, 2010
User Badges:

Hi!

I have had LMS 3.1 installed for more than one year - and it has been working as expected.

After a reboot of the server (Windows 2003 R2) the solution stops working.


When browsing the syslog.log file i see messages like:

Apr 20 08:28:28 127.0.0.1 100: <30>   dmgt[7668]: 3001(I):Using port: tcp/42340.
Apr 20 08:28:28 127.0.0.1 100: <30>   dmgt[7668]: 3007(I):Started application(Tomcat) "SERVICE " pid=4612.
Apr 20 08:28:34 127.0.0.1 100: <28>   dmgt[7668]: 2095(W):Internal Error: The daemon manager cannot run application TomcatMonitor.

This message appears for each application that tries to start up. I'm enclosing a copy of the content in the syslog.log file.


I have tried to install the sw on another server (new), and applying the license to this. The same errors occur here.


Does anyone have a clue on what's going on here ?


Thanks,


Pål

Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joel Monge Tue, 04/20/2010 - 10:14
User Badges:
  • Cisco Employee,

Why was this server rebooted, was anything changed? Post a screenshot of your Windows Services. Make sure you are not running any anti-virus on-access scanning on CSCOpx.

pthuland Tue, 04/20/2010 - 11:09
User Badges:

I'm running ACS v4.2 on the same server and did a reboot in order to resolve a lock on one of the configuration pages there.



The enclosed jpeg contains a snapshot of the relevant part of services.


Thanks,


Pål

Attachment: 
Nael Mohammad Tue, 04/20/2010 - 11:19
User Badges:
  • Silver, 250 points or more

How much free disk space do you have ? And you will want to have ACS and LMS running on two separate servers as this is not a recommended setup.


Get the pdshow > pdshow.txt if possible . If not get the NMSROOT/MDC/tomcat/logs/stdout.log files .


-nael

Nael Mohammad Tue, 04/20/2010 - 11:46
User Badges:
  • Silver, 250 points or more

1. Get me the file size of the CSCOpx\lib\jre\bin\java.exe

2. Get the NameServer.log from CSCOpx\log directory.

3. Do a "pdreg -l NameServer" and get me the output.

4. And do a "netstat -an > netstat.txt"


Get me the above outputs so I can examine further and ensure you have full admin rights when starting processes.


I strongly recommend that you move ACS to a different server as well.

pthuland Tue, 04/20/2010 - 11:53
User Badges:

Filesize:

C:\Documents and Settings\admin>dir "\Program Files\CSCOpx\lib\jre\bin\java.exe

Volume in drive C has no label.
Volume Serial Number is E0CE-F473

Directory of C:\Program Files\CSCOpx\lib\jre\bin

10.11.2006  13:28            49 248 java.exe
               1 File(s)         49 248 bytes
               0 Dir(s)  21 417 316 352 bytes free


pdreg:

C:\Documents and Settings\admin>pdreg -l NameServer
        Process      = NameServer
        Path         = C:\PROGRA~1\CSCOpx\lib\jre\bin\java.exe
        Flags        =  -classpath C:\PROGRA~1\CSCOpx,C:\PROGRA~1\CSCOpx\lib\cla
sspath,C:\PROGRA~1\CSCOpx\www\classpath org.jacorb.naming.NameServer -DOAPort=42
342
        Startup      = Started automatically at boot.
        Dependencies = Not applicable


Files attached.

Attachment: 
Nael Mohammad Tue, 04/20/2010 - 12:30
User Badges:
  • Silver, 250 points or more

The netstat output indicates that the NameServer is not listening on the port 42342 and due ACS and LMS running on the same server, they are competing for similar resources.


My suggestion is that you install LMS on its own server and ACS on a seprate server.  And upgrade to LMS 3.2 as well from http://www.cisco.com/survey/exit.html?http://cisco.mediuscorp.com/lms_w


-nael

pthuland Tue, 04/20/2010 - 12:42
User Badges:

I think it's an idea to upgrade to 3.2.

I did though install the sw on a fresh server earlier today (as mentioned in my first post), without ACS and got the same error messages.

So i do not think that only an install of 3.1 will fix this issue.

Actions

This Discussion