Problem with nat wic ADSL

Unanswered Question
Apr 20th, 2010
User Badges:

Hello, first sorry for my English, is bad. I have a problem with a nat cisco 2611 router with adsl wic, the configuration I think this ok, but not working properly. I put the configuration and the result of the debug ip nat. Thank you.

DEBUG IP

========

*Mar  1 05:10:43.152: NAT: s=62.43.x.x, d=77.231.x.x->192.168.0.2 [19369]
*Mar  1 05:10:46.161: NAT: s=62.43.x.x, d=77.231.x.x->192.168.0.2 [19377]
*Mar  1 05:10:52.159: NAT: s=62.43.x.x, d=77.231.x.x->192.168.0.2 [19390]

*Mar  1 05:11:52.161: NAT: expiring 77.231.x.x (192.168.0.2) tcp 25 (25)

77.231.x.x is the external fixe ip on asl

CONFIG

======

service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
memory-size iomem 10
ip subnet-zero
!
no ip domain lookup
!
ip audit notify log
ip audit po max-events 100
!
voice call carrier capacity active
!
mta receive maximum-recipients 0
!
interface ATM0/0
mac-address 0024.d2c2.831f
no ip address
no ip route-cache
no ip mroute-cache
no atm auto-configuration
no atm ilmi-keepalive
no atm address-registration
no atm ilmi-enable
bundle-enable
dsl operating-mode auto
no fair-queue
hold-queue 208 in
!
interface ATM0/0.1 point-to-point
ip address dhcp
ip nat outside
no ip route-cache
no ip mroute-cache
pvc 0/44
  encapsulation aal5snap
!
!
interface Ethernet0/0
ip address 192.168.0.222 255.255.255.0
ip nat inside
half-duplex
hold-queue 100 out
!
interface Ethernet0/1
no ip address
shutdown
half-duplex
!
ip nat inside source list 1 interface ATM0/0.1 overload
ip nat inside source static tcp 192.168.0.2 25 int atm0/0.1 25


ip classless
ip route 0.0.0.0 0.0.0.0 ATM0/0.1
ip http server
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
call rsvp-sync
!
mgcp profile default
!
dial-peer cor custom
!
line con 0
line aux 0
line vty 0 4
login
!
end




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Tue, 04/20/2010 - 12:09
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Likely the problem is with the mail server.


You should enable ip route-cache anyway.

raulcarrascopadilla Tue, 04/20/2010 - 12:25
User Badges:

The mail server is ok, is working from another router on the same network.



Router#ping 192.168.0.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Router#telnet 192.168.0.2 25
Trying 192.168.0.2, 25 ... Open
220 mail.domain.com ESMTP MDaemon 10.0.0; Tue, 20 Apr 2010 21:18:59 +0200

exit

[Connection to 192.168.0.2 closed by foreign host]
Router#

Actions

This Discussion