SGE2010 inter-vlan routing

Unanswered Question
Apr 20th, 2010

I purchased an SGE2010 for a small lab network within a test and development lab that are on different subnets/VLANS, but I want to be able to share some servers e.g. a wiki server, IM server, and a storage repository on the test VLAN to the development VLANs.

So far I have:

Development VLAN 1000 - IP address /24

Test VLAN 2000 - IP address /24

all machines on the development VLAN (1000) will be 192.168.1.* and the test VLAN (2000) machines will be 169.254.6.*.

The three servers I wish to share from the test VLAN (2000) are at ip address - 102.

I have configured the SGE2010 as a layer3 switch (via telnet configuration console) and can successfully join a test PC to either VLAN, but cannot see (ping) anything on the "other" VLAN including the VLAN IP addresses (253).

I have tried to add a static route - destination to next hop of (VLAN IP address), but the config utility changes the .6.100 to .6.0 and says that the defautl gateway cannot be an IP address on this switch.

Am I mistaken in thinking that a layer 3switch should be able to do this?   Any help in adding routes or enabling inter-vlan routing would be appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
brentoleary Thu, 04/22/2010 - 10:05

Hopefully this will help someone else out some day.  With the help of CISCOs small biz support team I was able to get this working like I wanted.

To enable inter-VLAN routing we did the following:

1. Put switch in layer3 mode via telnet or console, then reset the switch so that it takes affect.

2. Created 2 VLANs (e.g. 1000 and 2000) in the Bridging section of the webconfig.

3. Assigned an IP address to each VLAN e.g. VLAN 1000 = /24 and VLAN 2000  /24 in the ipv4 configuration section of webconfig

4. Joined several ports to each VLAN.

5. Set up all NICs on VLAN 1000 that I want to communication with VLAN 2000 with 192.168.1.* /24 addresses and a default gateway of VLAN 1000 IP address)

6. Set up all NICs on VLAN 2000 that I want to communication with VLAN 1000 with 169.254.6.* /24 addresses and a default gateway of (VLAN 2000 IP address)

Essentially, the VLAN IP addresses serve as default gateways that can route to other VLANs on the switch.  Using this configuration basically gives me a gigE router with 48 ports, which is all I really wanted for my lab to begin with.

I had actually tried all of this this before, but it turns out I was asking too much of a WIN2K (don't ask) server with dual NICs to route echo responses back through its assigned default gateway.


This Discussion