RVL200 - Invalid or Expired Certificate in Internet Explorer

Unanswered Question

When using Internet Explorer, users try to start an SSL VPN session, however the ActiveX Controls are blocked because the certificate is either expired or invalid. How to you update the certificate with a current certificate?  Can I purchase a certificate and install it on the RVL200?  What is the process for installing an enternal certificate on the RVL200?  I can't find any documentation anywhere online.

The virtual passage can still be launched using Firefox or Chrome, but cannot be launched through Internet Explorer which is the only browser installed on all my users' computers.  It is not acceptable to turn off or reduce my users' security settings.  I just want to eliminate the error and make it seamless for my users. Your help would be appreciated.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Te-Kai Liu Tue, 04/20/2010 - 12:47

I was told the firmware that fixed the expired ActiveX certificate issue should be posted in the next few days. Let's wait and see.

This seems to have solved the expired certificate issue through 2011. Please be aware that as soon as I upgraded the firmware, my users were no longer able to VPN. I had to go to the firewall tab and enable SSL VPN. The upgrade disabled that setting and I had to go back in and enable that.

Previously, under the Firewall tab, there was a single option for enabling both Remote Management and SSL VPN. That was a bit of a security problem, as I definitely wanted to enable SSL VPN (the purpose for which I purchased/installed this box), but I definitely DID NOT want to enable remote management of the box for security purposes. This firmware separates the two items, so one can enable SSL VPN, but keep remote management of the box disabled.

This was a great move (Linksys/Cisco), but this separation is why the upgrade broke the SSL VPN. It's a quick fix, but not being aware of this can cause you and your users some grief.

Te-Kai Liu Mon, 04/26/2010 - 16:04

Thanks for this important reminder. I have found the following info in the release note, which should have been highlighted.

When the RVL 200 is upgraded from firmware version 1.1.7 to, the SSLVPN feature needs to be enabled manually.


This Discussion