GLBP - None Option

Unanswered Question
Apr 20th, 2010


We want to force all connections through 1 of a pair of 6590Es, which are using GLBP, for testing purposes. However, even though the doco says 'none', it still defaults to 'round robin'. Doing a sh glbp displays round-robin. We want it to be like HSRP for a short time. (Few months).

So how do I get the GLBP to force all connections through one 6509 and not the other? What would the command line be? Is the doco correct?

From CISCO Doco:


If no load-balance algorithm is specified then GLBP will operate in an identical fashion to HSRP, the AVG will only respond to Address Resolution

Protocol (ARP) requests with its own Virtual Forwarder (VF) MAC address, and all traffic will be directed to the AVG with no occurrence of

load balancing.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Jon Marshall Wed, 04/21/2010 - 00:42


That should work however an alternative would be to configure weighting which allows you to specify whether the router should become a forwarder or not -

GLBP weighting

Don't forget that return traffic can use either router as path.


positeksystems Thu, 04/22/2010 - 18:11


I have been focused on using the 'none' option and was expecting this to force operation the same a HSRP - as the documentation states.

The problem was that we wanted only one routing table to be used, and not both. When looking at sh glbp commands, I found that ARP's were still being distibuted across the 2 core switches.

However, I will investigate the weighing option to do this. Alternativley, revet back to use HSRP on the switch.

Thanks for the help.


This Discussion

Related Content