CUCM 6.1 "file get tftp" line command

Unanswered Question
Apr 21st, 2010

Hi All,

I need to get desktop images for ip phones from CCM 6.1.

I got "file get tftp" command line.When i tried i got error"Could not connect to host on port 115. Please verify SFTP settings"

The same error on port 22.

Any ideas.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
htluo Wed, 04/21/2010 - 05:06

"file get" command is to trasfer file to your SFTP server.

It looks like CUCM was not able to connect to your SFTP server.  and I don't think you can change port number of the SFTP.

Could you check if your SFTP server is running?  You may download PSFTP from and save to your C:\.

Then open a command prompt on your PC.  Go to C:\ and type "psftp ip_address_of_SFTP".  See if you could log in.


htluo Wed, 04/21/2010 - 05:46

From the screenshot, it looks like either the SFTP server was not running, or the network was blocking SFTP connection.

Where the SFTP server was running on?  Was it on a Windows box?  If yes, you may copy the psftp.exe to that box and do the same test.


David Hailey Wed, 04/21/2010 - 05:47


Exactly what is the 10.x.x.x server you are trying to connect to?  Is that your CUCM server or a dedicated SFTP/FTP



youssef.ahmed Wed, 04/21/2010 - 06:13

My SFTP is my windows XP laptop which is

My CUCM is

David Hailey Wed, 04/21/2010 - 06:19

Therein lies your problem. You won't be opening an inbound SFTP to your CUCM from PSFTP. You need to go to the CLI of the CUCM and issue the "file get" command for whatever file you want to offload to your SFTP machine. From there, you'll walk thru a series of configurations and you'll be asked to enter the SFTP machine (presumably your Windows laptop) and file path (\home\ or just \ in some cases). On your XP machine, make sure you turn off Windows or 3rd-party firewall unless you have a rule to allow port 22. Also, network ACL's could be in play that block this type of traffic to machines on a data VLAN.


Please rate helpful posts!

htluo Wed, 04/21/2010 - 06:22


I guess you misread.  He's trying to connect to his WinXP  Not the CUCM.


Are you sure the SFTP server is running?  Have you turned off your Widnows firewall on XP?  Are you testing psftp.exe on the same Win XP machine?


David Hailey Wed, 04/21/2010 - 06:33

Actually, I'm looking at this PSFTP screenshot in which he's trying to do an open on the (CUCM) address and it fails because CSA is going to block inbound connections of this type to CUCM.

Conversely, he's trying to open the connection to this Windows XP from a DOS prompt at c:\psftp so unless PSTFP.exe is in the root of C - this won't work either.

htluo Wed, 04/21/2010 - 06:37

I see.  We were looking at different places on the same screenshot

From the bottom command prompt, you can see psftp was giving a connection error when he tried to connect to his own WinXP.  That means:

1) He found psftp in the right place.

2) SFTP connection was blocked on his WinXP

Actually, you CAN sftp to the CUCM server (with the right credential).  CSA won't block the connection.  Because SFTP use the same port number as SSH.  See what can you do when you sftp to CUCM server at


youssef.ahmed Wed, 04/21/2010 - 06:37

i ensured that SFTP server is running on my XP machine.

I tried to login to myself (

also tried to login to my server (

htluo Wed, 04/21/2010 - 06:38

Don't try  It won't work.

You may try the command "telnet 22".  See what happens?


youssef.ahmed Wed, 04/21/2010 - 07:11

actually i got from internet on SFTP port i found that it is on port 115 not 22

i tried to login on both ports

I failed on port 22

BUT i succedded on port 115

I attached the results of both ports

youssef.ahmed Wed, 04/21/2010 - 07:24


if SFTP connects to port 115,so i think csa is blocking the connection.

David Hailey Wed, 04/21/2010 - 07:27

I don’t know what SFTP client you're using - but I've never heard of one that connects by default on 115.


htluo Wed, 04/21/2010 - 07:27

Could you post the link where it says SFTP was port 115?

Neither CUCM CLI nor PSFTP would use port 115.  They will use port 22.

I guess you "customized" your SFTP server to use a non-standard port.


htluo Sat, 04/24/2010 - 05:56

The link was referring to Simple File Transfer Protocol.  So sad that it use the same acronym as Secure File Transfer Protocol.

CUCM does not support "Simple File Transfer Protocol".  CUCM only supports "Secure File Transfer Protocol".

"Secure File Transfer Protocol" use port 22.  Make sure your SFTP server was listening to port 22.



David Hailey Sat, 04/24/2010 - 11:23

Funny, I never even thought of Simple FTP. This is pretty clear in the CUCM docs - Michael is correct, SFTP = Secure FTP. You can use FTP but it's not recommended. That's it.


youssef.ahmed Sat, 04/24/2010 - 23:29

Thx you all guys,

I simply got what I need from the following command which i ran it on my PC

the command is:

tftp -i get Desktops/320x212x16/TN-Fountain.png


This Discussion