What could be causing EssentialsDM to be stalled?

Answered Question
Apr 21st, 2010
User Badges:

Good evening all,

I have a problem in which RME is not discovering devices from CS.  It did work until several (52) Microsoft updates were installed and the machine rebooted.


LMS 3.2

CiscoWorks Common  Services 3.3.0

Campus Manager 5.2.1

CiscoView 6.1.9

CiscoWorks  Assistant 1.2.0

Device Fault  Manager 3.2.0

Internetwork Performance  Monitor 4.2.0

LMS Portal 1.2.0

Resource Manager  Essentials 4.3.1


Hardware Details:  Windows 2008 Server  - 4 x Dual Core with 8 Gb memory


The system was working until MS updates were installed:

     kb installations from 16 april 2010.pdf


Now the Essentials DM is waiting to initialize


Showing 1 records
1.
Waiting to initialize.5080004/21/2010 4:51:31 PMNot applicable



Because this EssentialsDm is waiting - there are 11 other processes that have not started:



ProcessState ProcessId ProcessRC ProcessSigNo ProcessStopTime

1.ChangeAuditNever started000N/ANot applicable
2.ConfigMgmtServerNever started000N/ANot applicable
3.CSDiscoveryNever started000N/ANot applicable
4.CTMJrmServerNever started000N/ANot applicable
5.DCRDevicePollNever started000N/ANot applicable
6.FHPurgeTaskNever started000N/ANot applicable
7.ICServerNever started000N/ANot applicable
8.PMCOGSServerNever started000N/ANot applicable
9.RMEOGSServerNever started000N/ANot applicable
10.SyslogAnalyzerNever started000N/ANot applicable
11.UTMajorAcquisitionNever started000N/ANot applicable



I have reinstalled:


     CS, Java, & RME

to no avail.

I have attached EssentialsDM and EssentialsDM_Server for perusal and perhaps some help in resolving this conundrum.

PS: Rolling back the MS updates is not an option.

Any hints/tips?

All help gratefully received...

Regards

Russ

Correct Answer by Nael Mohammad about 7 years 1 month ago
Try the following steps:

1. net stop crmdmgtd
2. Take backup of the following files
       NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/lib/ctmregistry and
       NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/lib/ctmregistry.backup

Note: NMSROOT is the C:\Program Files\CSCOpx directory.

3. Remove the above two files ctmregistry and ctmregistry.backup
4. net start crmdmgtd

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Nael Mohammad Wed, 04/21/2010 - 12:59
User Badges:
  • Silver, 250 points or more
Try the following steps:

1. net stop crmdmgtd
2. Take backup of the following files
       NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/lib/ctmregistry and
       NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/lib/ctmregistry.backup

Note: NMSROOT is the C:\Program Files\CSCOpx directory.

3. Remove the above two files ctmregistry and ctmregistry.backup
4. net start crmdmgtd

Russell Bovaird Wed, 04/21/2010 - 16:58
User Badges:

Thank you very much Nael.

It's all working fabulously now.

Just for my reference:

          How did you know that these files were the culprits and what to do with them? 

          Did the logs help and which part in particular?

Thanks again.

Kind regards

Russ

Actions

This Discussion

Related Content