LAP migration error: "migration template in progress"

Unanswered Question
Apr 21st, 2010
User Badges:

Hello,


We are having a problem when trying to migrate an autonomous AP to a lightweight AP.


The process we use is to add the autonomous AP to the WCS inventory, then we apply a migration template which upgrades the AP using an external TFTP server. We have been doing this operation several times before, and never had any problem with it.


The problem which now occurs is that the WCS thinks another migration process is in progress (which is erroneous) :


ap.PNG


We have been trying the following actions, with no success:

-stop/start WCS server

-stop/start the host server

-checked that all services (WCS+Apache+DB) are running


About the log files:


The operation raised a warning 3 or 4 times when we were trying :


 4/20/10 11:16:50.317 INFO[general] [2395] Entering executeConvertAction 
4/20/10 11:16:50.317 INFO[general] [2395] Migration Input CSV File Name :: lstautonome.txt
4/20/10 11:16:50.317 INFO[general] [2395] 4
4/20/10 11:16:50.317 INFO[general] [2395] 10.179.217.219
4/20/10 11:16:50.317 INFO[general] [2395] cisco
4/20/10 11:16:50.317 INFO[general] [2395] *****
4/20/10 11:16:50.317 INFO[general] [2395] *****
4/20/10 11:16:50.328 INFO[general] [2395] Migration :: Controller Time 11:16:49 Apr 19 2010
4/20/10 11:16:50.332 INFO[general] [2395] 10.179.216.5 /apcisco/ c1130-rcvk9w8-tar.123-11JX1.tar tftp://10.179.192.152/apcisco/
4/20/10 11:16:50.332 INFO[general] [2395] Total Number of APs selected for Migration process :: 1
4/20/10 11:16:50.332 INFO[general] [2395] 10.179.217.219 [removed] 10.179.192.5
4/20/10 11:16:50.333 INFO[general] [99678] Main Take input..done 10.179.217.219
4/20/10 11:16:50.333 INFO[general] [99678] Submitted task 10.179.217.219
4/20/10 11:16:50.333 INFO[general] [99678] Submited task 10.179.217.219
4/20/10 11:16:50.333 INFO[general] [99678] Main Take input..
4/20/10 11:16:50.333 INFO[general] [99695] Telnet and configuring Controller/AP 10.179.217.219
4/20/10 11:16:50.333 INFO[general] [99695] Individual path /opt/WCS4.2.81.0/webnms/webacs/migration
4/20/10 11:16:50.333 INFO[general] [99695] filename path /opt/WCS4.2.81.0/webnms/webacs/migration/10.179.217.219.txt
4/20/10 11:16:50.333 INFO[general] [99695] Logging the output.. to /opt/WCS4.2.81.0/webnms/webacs/migration/10.179.217.219.txt
4/20/10 11:16:50.337 INFO[general] [99695] Updating Report...[email protected]
4/20/10 11:16:50.337 INFO[general] [99695] Updating Report...
4/20/10 11:16:50.337 INFO[general] [99695] Writing In Progress to database..
4/20/10 11:16:50.343 INFO[general] [2395] Addedd IP 10.179.217.219
4/20/10 11:16:50.345 ERROR[general] [99695] Stopping SSC thread4 10.179.217.219 com.cisco.nm.lib.cmdsvc.CmdSvcException: java.net.ConnectException: Connection refused
4/20/10 11:16:50.346 INFO[general] [99695] Updating Status for Failure SSC AP 10.179.217.219.
4/20/10 11:16:50.349 INFO[general] [99695] Updating Report...[email protected]
4/20/10 11:16:50.349 INFO[general] [99695] Updating Report...
4/20/10 11:16:50.349 INFO[general] [99695] Writing Fail to database..
4/20/10 11:16:50.353 INFO[general] [99695] Total Report Size is..0
4/20/10 11:16:50.355 INFO[general] [99695] SSC : Number of Completed APs :: 1
4/20/10 11:16:50.355 INFO[general] [99695] CreateControllerConnection :: Releasing controller session.


It seems that there is a database related issue at this point, but we don't know why.


And now, the operation fails immediately with the following error:


 4/20/10 12:40:30.614 INFO[general] [2395] Entering executeConvertAction 
4/20/10 12:40:30.614 INFO[general] [2395] Migration Input CSV File Name :: lstautonome.txt
4/20/10 12:40:30.614 INFO[general] [2395] 4
4/20/10 12:40:30.614 INFO[general] [2395] 10.179.217.219
4/20/10 12:40:30.614 INFO[general] [2395] adminsat
4/20/10 12:40:30.614 INFO[general] [2395] *****
4/20/10 12:40:30.614 INFO[general] [2395] *****
4/20/10 12:40:30.617 TRACE[com.aes] [2395] [NmsExceptionHandler:execute] THROW
com.cisco.server.common.errors.IllegalOperationException: errors.MO-144.migrationTemplateInProgress
     at com.cisco.server.services.MigrationService.initiateMigration(Unknown Source)
     at com.cisco.webui.action.configure.bridge.MigrationEditAction.executeConvertAction(Unknown Source)
     at com.cisco.webui.action.configure.bridge.MigrationEditAction.executeAction(Unknown Source)
     at com.cisco.webui.action.common.UiAction.execute(Unknown Source)

Controller: Cisco WiSM, version                       4.2.130.0

WCS: version 4.2.81.0

Cisco AP: AP1131 AG (relased after june 2005 => no SSC)


Has anybody ever faced this situation ?


Thanks,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ELSISTART01 Mon, 05/17/2010 - 02:20
User Badges:

Still no answer to the question ?


Any help would be much appreciated.


Thanks,

srosenthal Wed, 03/02/2011 - 18:48
User Badges:

I have just encountered the same issue.


Anyone got any ideas?


Seth

srosenthal Thu, 03/03/2011 - 07:27
User Badges:

Ok, well I got mine to work today.  I did not have the controller added to the WCS and once I added it I was able to apply the migration template to the AP.


I forgot that I had reloaded the WLC to factory defaults and did not add it back to the WCS.


Seth

Actions

This Discussion